Submit Interaction feature does not work on mobile devices

I have a simple hotspot question with 1 correct answer.  The player trigger is set to Submit Interaction when the user clicks the Submit button.  The Submit button is on in the slide navigation controls.  The Submit scoring is set to By Player Button.  Works fine on a computer but on an iPad or Phone the button does not work.

Anyone experience this.

Thanks,
Nick

6 Replies
Ashley Terwilliger-Pollard

Hi Nick,

I'm sorry to hear the submit button isn't working on iOS devices - so let's get that fixed right away! 

Can you tell me what version/update of Storyline you published the course with? Can you tell me what iOS version you're using? 

What happens when you click the submit button? Does the slide advance to the next slide but not capture the score? Or, does the user get stuck on that slide?

If you can send me a copy of your .story file I can give it a quick test! You can upload it using the “ADD ATTACHMENT” button at the bottom of the reply window. 

Nicholas Bird

Hi Ashley,

It works outside of our LMS but not inside.  I have Storyline 360.  I am in 10.2.1 on my iPhone.  After clicking the Hotspot the Submit button does not submit the interaction so the question essentially fails.  The same thing happens on an iPad.  So I built it another way (version 2 attached) where I did not use Storyline's questions I just created hotspots and layer interactions.  This works perfectly in my LMS.

Appreciate any help!

Thanks,
Nick

Alyssa Gomez

Hi there Nick,

Thanks for sharing those files with me. I published the original file (not version 2) for LMS and uploaded it to SCORM Cloud for testing. From there, I tested this link on an iPhone and iPad iOS 10.2.1, and the hotspot interaction worked well on both devices.

Could you try testing this link on your devices, as well? Keep me posted on how it goes!

Matthew Smith

Did this get resolved?

I'm encountering the same problem with mobile devices. The submit button works fine when I view the link directly but when open the story course from my LMS, the submit button doesn't do anything.

I have tested it in SCORM cloud and seems to work fine there as well.

My course is published as SCORM 1.2

Alyssa Gomez

Hey Matthew,

Since your course worked fine in SCORM Cloud, that's great information to share with your LMS provider. From here, reach out to your LMS support team, and they'll be able to help you with issues that are specific to that environment.

What LMS do you use? Maybe other folks who use the same one can chime in and assist!