Text autofit improvements not compatible with latest Storyline 3

Feb 14, 2022

I have done so much research and exploring and STILL sit with the issue where a Storyline 360 file is not compatible with the latest version of Storyline 3 due to "Text autofit improvements".  Is there ANY workaround to this that anyone has had success with?

I have tried the latest versions of both 360 and 3 and have also tried the Design > Fonts > unticked 'Display accessible type by default'.  I can't find the text box with the issue and Storyline does not indicate where it is either.  I have removed over 80% of slides and have only 4 slides left to see if it works, but I still don't have success.

Overall, coming from a graphic design background, I find the UX of Storyline quite primitive and frustrating (excluding the bombing out when trying to save a file and losing everything but that's a different story).  Overall not a good experience with this software unfortunately with so many bugs and impractical user experiences.

The solution to this article Text Autofit Improvements: Turn Off? - Articulate Storyline Discussions - E-Learning Heroes unfortunately does not work either.

Does this mean that my colleague has to redo all the courses in Storyline 3?  Surely this should not be the case?


4 Replies
Josh Dean

It's my understanding that 360 projects default to having the autofit option off. But when it's enabled, storyline prompts to save a backup copy as it's a global change. I believe that even if you had a blank project and deleted all the slides it's still something that is enabled for that file. I think the autofit is a good feature and has its place, but isn't backwards compatible - it seems. Sorry you're having trouble. If you are in a mixed dev environment, here is a list of other difference that could crop up for you. https://articulate.com/360/storyline#compare 

All that being said. I just tried something that worked for me to restore a file to a stage before updating the autofit. This is a very hacky approach and you absolutely MUST MUST MUST do this on a backup of your file. 

I took my 360 storyline file with autofit enabled. 

  • I duplicated the file.
  • If windows doesn't show your file extensions then enable them under the folder view options so you can see the ".story" extension.
  • Rename the duplicate file by removing ".story" and adding ".zip"
  • Unzip the folder
  • You'll see a number of folders. We are going to change 3 files in here. Use notepad, not MS Word.
  • Edit theme.xml in the \story\theme folder. Change "true" to "false" where is says "usenewautofitdefaults"
  • Edit the featureManifest.xml file in the docProps folder. Remove the portion that starts with "<TextScrolling2" and ends with the next "/>"
  • Edit the story.xml file in the story folder. Near the top change two things: change "true" to "false" next to both "usenewautofitdefaults" and "autfitupgraded".
  • Select all the folders that (not the parent folder) of what you had unzipped and rezip it all.
  • Rename the zip file to remove the ".zip" portion and add ".story"

When I did this and opened the story file in 360 the option for autofit had been restored to its previous state. I was unable to test the output file in storyline 3. 

I've attached below the storyline 360 file that I had upgraded to autofit then manually downgraded using the above. Feel free to test opening it in storyline 3 to save you the time if the above steps won't end up working.

Please Please, for all that is holy, do this on a backup of your project. Somewhere out there an articulate dev is shaking their head at me for this craziness.

Bryan Tregunna

I have encountered an issue when importing a PPT file. Am I right in thinking that PowerPoint now also has the text autofit? 

Having started a new project by importing a PPT file into it and, having done loads of work on it, I can no longer open the file as it tells me that it has text autofit. The file has been nowhere near 360!

I have raised a ticket with support, but thought I'd come on here to warn others to save hours of lost work.