Text not appearing correctly

Hi

Has anyone had an issues before where the text that they type into a text box appears differently when you click out of the text box?

Sometimes I type something and then when I'm finished it looks like a different font and the spacing is different yet when I click back into the text box to edit it, it changes to the original typing I put in!

 

Any suggestions appreciated!

12 Replies
Hayley Wesley

Hi thanks for the tips.

I am using SL1 still. As far as I am aware the slide was at 100% and I had more than one text box on the slide and it wasn't happening to all of them. But I will make sure to check that in future.

I always work locally and then upload manually to cloud storage afterwards if needed because syncing has caused me huge issues in the past with other video editing software.

Lauren Connelly

Hi Richard!

I'm happy to help! I've tried to recreate this issue on my end in Storyline 360 (Build 3.52.25156.0), and I do not see the same behavior. Are you finding this happens with every text box in your course or just a specific one? 

If you'd like me to take a look at your project, you can attach the .story file to this public discussion or share it privately in a support case.

Judy Nollet

FYI: I encountered similar behavior after I upgraded to the most recent version of SL3. I never checked the exact spacing. But, sometimes when I clicked to edit a text box, the text shifted as if I had expanded the spacing. Then it would return to normal when I clicked away from the text box. The problem was inconsistent. I didn't see a pattern.

This reminds me of how the text boxes acted in SL1. 

The attached file has a few slides that demonstrate the issue (at least, to me, using SL3).

Leslie McKerchie

Hi Judy,

I appreciate you sharing an example with the details. I see the text shift in your example. Unfortunately, I'm unable to replicate the behavior in a new file.

I've opened a support case on your behalf so that one of our support engineers can dig in a bit deeper to see what's happening here.

You should hear from someone soon.

Judy Nollet

Update: I received an email from Articulate support last night. The engineer said "it appears that the issue might be related to the Slide master layout applied to the Slides."  He was able to replicate the issue. 

Well, that explains when the issue occurs. But it doesn't solve the issue. 

Here's what I see in my own additional testing: 

  • I add 12 points of line spacing to the text box in the Master layout. 
  • I create a slide with that layout, and add 3 lines of text (separated by returns). 
  • With my cursor in just 1 line, I adjust its line spacing. But that changes the spacing for all of the lines. (That didn't happen in the past. I could adjust the spacing for any single line.)
  • If I add a bullet to a line and adjust the spacing directly in the Paragraph options (i.e., without first clicking the Indent button), SL applies the adjustments to all of the lines. 
  • If I add a bullet, click the Indent button, and then adjust the spacing in the Paragraph options, those adjustments will impact only that line (as expected). 
    • After I've done that, I can adjust the spacing for each line.

From my perspective, I'd say that the latest update broke how the Master layout works.

  • Best guess on the cause: it's related to Text Styles. 
  • Another observation: In the above testing, I couldn't replicate the issue with the line spacing appearing to change when I clicked in the text box and then reverting when I clicked out. The file where I did encounter that issue was developed before the recent update. So that aspect is likely related to how the text "upgraded" to the new version that includes the option for styles. It doesn't seem to occur with new text boxes. (But we'll see...)
  • What I'm sure of: Articulate didn't do enough validation testing.