The process cannot access the file because it is being used by another process

Hello all,

I'm having this error windows when I try to save a project in Storyline 2 Updated 10. It is the same one other users reported before, but I can't see an specific solution for that: "The process cannot access the file 'C:\<name of file>.story' because it is being used by another process."

After that, I 'Save As' to create a new file, but it keeps creating double copies. Can you please help me with this situation?. Please see some attachments.

31 Replies
Leslie McKerchie

Hi Catherine! Sorry to hear that you are having difficulty. Is it just one file that is causing issue? Can you import into a new file to see if that alleviates the issue? Thanks for letting us know that you are utilizing the latest update as well. I am concerned about your Save As issue that you mentioned, so a repair may be in order as well.

Catherine Sanchez

Hi Leslie, It is not just one file, it is with a couple of them. So, I tried what you told me to do, I create a new file and it keeps happening (See the attachments). Even after I re-installed the software completely according with the instructions with Articulate Support. Because I also create a support case file and that was the initial instruction: uninstall, reboot and install storyline again.

I will appreciate other possible solutions. Thank you for your time.

Leslie McKerchie

Hi Sanavaz!

I popped in to check on Catherine's case mentioned above and it looks like we did not hear back from the user, so I do not have any conclusion or resolution to share with you here.

I would advise a repair of your software.

Just let us know if you need anything further or you are welcome to reach out to our support team here.

Shanavaz S F

Hi leslie,

I tried all the repair work mentioned by your support team, uninstall, reinstall, system restart etc.,

but it did not work out....

I did a system restore on 11th October and it worked for a while but in 1 hour or so the issue popped up again.

Today I disabled the .net framework in programs and features and it seems to work so far. Will revert if it doesn't work.

I am using windows 10 for your information.

 

Case #00906002: The process cannot access the file [file directory ...    [ ref:_00D30Txo._5003311IRtn:ref ]

Matt Bell

I too have been dealing with this issue for a long while...  is there any plan to resolve this? I've tried reinstalling, tried importing into a new fresh document, tried using my co-workers computer to save the file, even went as far as a fresh new laptop (with a new install), all to no avail!

Others in my office are experiencing the same issue. would love to have a solution to share with our greater good :)

Ashley Terwilliger

Hi Angie,

I can't say what the specific issue was for Shanavaz, but I did look at his case and he was able to resolve it with as he mentioned disabling the .net framework. It's not something we'd recommend since Storyline uses the .NET framework. 

If you're still having difficulty you could look at trying to uninstall and reinstall Microsoft .NET Framework 4. Here's how: 

1) Go to Start > Control Panel > Programs > Programs and Features. 

2) Uninstall Microsoft .NET Framework 4. 

3) Download and install a fresh copy of Microsoft .NET Framework 4: 
https://www.microsoft.com/en-us/download/details.aspx?id=48130 

4) Reboot your system and test again on a newly created project file, saved on your local drive. See if you can replicate the same issue. 

If you'd like to work with our Support team on this issue they'd also be happy to take a look at what's happening on your side. 

Hannah Montroy

I have been having the same issue currently. I have uninstalled and reinstalled the program.  It does not allow me to pull up the file.  If I can't get it then it is hours and hours of work down the drain for a large project that I am working on.  I had the same issue about a year ago with a different computer and company and had no resolution (lost all of it) so I am very worried.  What are some other new options for me?

Ashley Terwilliger

Hi Hannah,

Are you unable to open a particular Storyline file, or the program as a whole? If it's just one file that won't open do you see a particular error message? If it's just that one file and you're receiving a message about corruption, you may be able to find a copy of that file in your temp folder. Here's how to check: 

1) Open this folder in Windows Explorer: %appdata%\Articulate\Storyline 

2) Scan the contents of this folder for a file that starts with the name of your project. If you find one, copy it to your desktop. If you find more than one, copy the latest version to your desktop. 

3) Change the file extension of the copy on your desktop from *.tmp to *.story. 

4) Double-click the file to open it in Storyline. 

If you can't open Storyline as a whole, and you've already gone through the steps above - let's have you work directly with our Support Engineers so that we can take a look at what's happening. 

Kim  Schmid

Hello. Does anyone have a solution for this issue? Myself and my entire department is now experiencing this issue. We exclusively work on files from our hard drive, never a networked location. We are on Windows 7 and Storyline 2 Update 13: 1804.2716. All of our files can't just suddenly become corrupt. Is there a regedit as noted above (the article is no longer available).

Diarmaid Collins

This issue has suddenly manifested since yesterday. Alarming, considering the number of projects I got to get out the door by EOFY.

I think the autosave must be glitching because when I do go to save there are already a number of extra copies in my folder (XX2, XX3, etc) when I get the "The process cannot access the file..." message.

Sorin Lascu's link isn't working anymore, and maybe it is a Parallels / Windows issue but it's freaking me out.

Any clear cut solutions? I only did a complete refresh install of Storyline to the latest version last week.

Message

Result

Kim  Schmid

Hi Diarmaid. I had the same issue recently and it took a while to figure it out. My issue was resolved after working with Carbon Black/Bit9 which is something we use at my firm and was causing the issue. Carbon Black suggested that we just exclude the Storyline.exe file from any processing in Bit9 and after that the issue has be fixed. Hope that helps. 

Dominik Ginthier

I am experiencing a similar issue since a couple of weeks. Whenever I try to open a Storyline file for the first time it works fine. Opening the file a second time (at the same day) I receive the following message:

"The file ... is being used by another process or you do not have the proper security permission to access this resource."

It is pretty annoying, but luckily there is an easy workaround for this. I can open the file by selection it from the recently opened files. Please see screenshot below.

Does anyone know the reason for this?

Thank you.