The project file could not be saved. Failed to construct a huffman tree using the length array. The stream might be corrupted.

Hey all,

I'm getting the following error when trying to save my Articulate (Storyline 2) file. It's a file I've been accessing and updating over the last few days, where I'm doing an overhaul of the E-Learning module I've created. I can open it, make further changes to the file but I'm unable to save at all now.

File is saved locally on my C: of course.

Any ideas? It's pointing to a corrupt file but I don't want to face that reality just yet...

The project file could not be saved. Failed to construct a huffman tree using the length array. The stream might be corrupted.

Alex.

5 Replies
Alyssa Gomez

Oh no, Alex! We definitely don't want you losing your work, so let's try and get this sorted out.

Thanks for letting me know you're working from your local hard drive, as that's usually one of the first things I ask. 

Here are a few more things you can try:

  • Try both Save and Save As, and try saving to various folders on your local hard drive. 
  • Keep your file name short.
  • Clear out any temporary files you no longer need, and locate a backup version of the file you're currently working on if one is available. Here's how. 
Alex Hagues

Hey Alyssa,

Thanks for the reply!

- Just tried 'Save As' instead of 'Save' but still gives the same message
- I did update the file name the other day before I created this thread as did a bit of digging online and on here for anything useful or similar but didn't make a difference
- Cleared out those old temp files but still getting the same error I'm afraid

I've just tested it with a colleague and got them to try and open my file, saved to their own C drive and it gave them same error when trying to save/save as. So doesn't seem related to my machine.

I just had a thought, would starting a new project and then importing from the old file be a way forward? It may just copy the corruption over into the new file but it's worth a shot?

 

Alex Hagues

Hey Alyssa,

No worries, good to try. Thanks for getting back to me.

I think I'm managed to sort it! I started a new project, set all my player settings and story size settings etc. and then used File > Import > Storyline and browsed to the old file I was getting the error with. It imported and is allowing me to save ok...strange but at least it's working.

Few minor touch up's required and just going through and testing the buttons/triggers etc. but it seems to be ok, touch wood.

Should I raise a case with the Support Engineers anyway, for them to investigate the error or leave it for now as appears to be working ok after the above.

Alex.