Triggers, States and Conditions Not Working

Hi there E-Learning Heroes!

I know it is Friday but I'm hoping some of you have those thinking caps still on because I need your expertise! I am experiencing some issues with a Corrective action course I am building. This is my first time working with numerous states, triggers and conditions. Please see the challenges listed below and let me know if you have any follow up questions. Any help would be greatly appreciated!

Slide 1.3: Main Menu - Course Navigation

Here is the desired behavior:

1. User clicks Topic 1 to review content.

2. Once Topic 1 slides are reviewed, Topic 1 title shows as Visited, and the next topic is unlocked. The unlocked “live” state will be displayed in black font.

3. Once Topic 2 slides are reviewed, Topic 2 title shows as Visited, and the next topic is unlocked.

4. Etc… When the user clicks through all topics, the Quiz topic is unlocked.

5. Users should be pushed though the course linearly and topic states should not change until all of the conditions are met and the topic is unlocked.

Here is what the main menu looks like the first time the user reached it:

What I am currently experiencing is:

· Users can change any of the topic states by clicking on any of the topics in any order. This conflicts with what I had originally set up in the conditions.

· The links to the pages seem to be working with the conditions I have set up. (So the states will still change if they click the topic out of order, but the triggers will not allow them to view the slide until all of the topics have been reviewed in order - make sense?)

Actual Behavior:

Here is a sample of the triggers I have set for the state changes:

Slide 1.5

Desired behavior:

· Once all of the topics have been reviewed by the learner, the bottom directions box should change states and a trigger should appear to link the user back to the main menu.

Actual behavior:

· Triggers and visited states work – however once I publish the course the yellow zigzag box appears to shift - and is not visible on screen at all.

Here is how the trigger looks:

I know this is a tall order but I have faith that one of you ROCK STARS can help Thanks in advance for taking a look. I am happy to share the file if needed.

Thanks again,

Danielle

26 Replies
Wendy Farmer

Hi Leslie

first thing - the objects in your timeline need rearranging. Pic 3 which relates to the Introduction was the last item in your scrolling panel list of items and Pic 26 was in its place. I rearranged and put Pic 3 at the top and Pic 26 at the bottom and you can now click the introduction. See attached video of how it's working now and let me know if that is what you are after.

You are displaying the introduction as soon as the slide starts so if you want that to have the completed tick you'd need to set a trigger.

 

Also in the states panel I can see the green tick on the visited state but no change of colour - what am I missing