Trouble with Storyline translation import function

Hi all

I have a reoccurring issue when importing a document that has had changes made to it during translation that has no obvious cause. Once re-imported, some text boxes lose their text. When you select the text box, the font has also changed to a Microsoft San Serif font. 

At first I thought it was because the changes made in the document were made with a different font to that used in Storyline but that hasn't proved to be the case. It also seems to affect text boxes where no changes have been made. 

This has been very disappointing as one of the main reasons for adopting Storyline was for the translation functionality and at the moment it seems we cannot trust it will work.

Hope you can help.

Sally

40 Replies
Jennifer St. George

Hi there,

I'm experiencing the same exact issue and I have a course which has been translated into 25 languages.  I imported the first language yesterday and all seemed ok until I got to the last scene and found all the text boxes empty.  Also, I'm finding quiz text is not importing correctly either.

Peter, can you advise if you were able to resolve for Sally?

Thanks!

Jennifer

Peter Anderson

Hi Jennifer

It looks like Sally's case worker is waiting to hear back from her, so I don't have a resolution for that yet documented. 

One thing to keep in mind when working with translations (and always), is to be sure you're working from your local hard drive (typically your C: drive). Working from a network drive or a USB drive can cause erratic behavior, such as file corruption, an inability to save changes you've made to your project, and loss of resources. 

If you'd like, we'd be happy to take a closer look at your specific project. Please submit a case, including your .story file, using this link so our support team can assist you further.

 

Thanks!  

Jennifer St. George

Hi Peter,

Hmmm, I was careful to keep everything on my local drive.  It's odd, the rest of the file imports beautifully, just the last scene and a couple of the quizzes were left out.  Very odd.

I will submit the storyline file in English with the German translation to be imported via your link above.

Thanks!

Jennifer

Jennifer St. George

Hi Peter,

I wanted to complete my import before submitting anything - have you found out anything on your end?

Here are my statistics and languages, can't put my finger on what is going on.  When I say "dropped" below, it looks like all the text is gone from the text boxes on those slides/scenes.

I'd love some help; otherwise I'll be manually laying in the text using 3 documents to make sure I get the right text in the right place!  (i.e. the possibility for error is very high doing this manually).

Thanks!

Jennifer

Normal 0 false false false oNotPromoteQF /> EN-US X-NONE X-NONE MicrosoftInternetExplorer4

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

25 total languages

  14 imported without issue

  10 imported with issue

  1 in translation still(Portuguese)

Chinese - Simplified

No issue 3-15-13

Chinese - Traditional

No issue 3-15-13

Croatian

No issue 3-18-13

Czech

No issue 3-12-13

Dutch

Last 3 slides did not import properly, 3-18-13

French

Last scene dropped, 3-18-13

French Canadian

1/2 of last scene dropped

German (includes Swiss version)

Import issue, dropped last scene
3/11/2013

Greek

No issue 3-18-13

Hungarian

No issue 3-18-13

Indonesian

Last two scenes dropped in import, 3-18-13

Italian

Dropped last 4 slides in import, 3-18-13

Japanese

No issue 3-18-13

Korean

No issue 3-18-13

Polish

Last scene and 1/2 dropped in import
3-18-13

Portuguese

Translating Now – Not Imported Yet

Portuguese - Brazilian

Last 2 1/2 slides dropped in import, 3-18-13

Russian

No issue 3-18-13

Slovakian

No issue 3-19-13

Spanish

No issue 3-19-13

Spanish - Latin American

Last 2 1/2 slides dropped in import, 3-19-13

Swedish

No issue 3-19-13

Thai

No issue 3-19-13

Turkish

No issue 3-19-13

Vietnamese

3.9 through 9.6 (about 1/2 of total course) did not import,
3-19-13

Jennifer St. George

Sorry, one more thing - I did notice that most of the languages which had import issues also had two associated Word error messages.

and this one

Have you seen these before?

BTW, whenever I could, before I did the import, I changed the dictionary and the text labels on the player first and then imported.

Hope this helps!

Jennifer

Peter Anderson

Hi David, 

Jennifer's particular case has been sent to our QA team for further testing, and we're waiting to hear back. Any chance we could take a look at your file also to try and learn more about what might be going on here? You can open a ticket here and upload the .story file on the second page of that link. 

Thanks!

Peter Anderson

Hi Jennifer (and David)

We've become aware of issues when using XLIFFs to translate Storyline content.

@Jennifer, are you using XLIFF for translation purposes? 

It's been reported to our QA team for further examination, and I'll be sure to update here as soon as I hear any news. 

Really sorry for the inconvenience in the meantime...

Jennifer St. George

Hi Peter,

With regard to the Thai rendering incorrectly in the player:  I used the Word import function and am experiencing the same issue.  I just tried fiddling around with the font and font size (hoping that would DO something) but no luck.

Any luck with my other import issue above?  I still have 1/2 my languages to finalize and I'd rather just do a re-import with a patch than manually build the translation based on multiple documents since my translated content is in the Word export file.

Any ideas on your side?  Help!

Thanks!

Jennifer

Jennifer St. George

Thanks!  I just finished rendering the languages which imported correctly and still have to test them to confirm functionality so I have a little time (a few days) before I'll have to start manually fixing.  Just wanted to check in earlier rather than later. 

For David - On the Thai language issue, as a possible workaround - I'm looking into a way to lay in the audio transcript on the slide with minimal disruption to the learner.  Not sure if I have space on the slide to do it; I may have to release it the way it is an fix once a patch comes out.  Neither is my preferred method but I need to get the course available soon.

Catherine Moore

Hi All,

Just wondering if this issue was fixed?? I have been experiencing the same problem. I have the latest version (our support team here has loaded it twice) and when I import back into storyline a 3-column word document through the translation option, text is randomly changed to MS Sans Serif font.

I tried outputting the document and directly inputting the document back in without changing the word document and text fonts were randomly changed.

I opened a support ticket with Articulate, but the support team couldn't replicate this on their end ... Any solutions?

Thanks,
Catherine

Leslie McKerchie

Hi Catherine! I looked back at the cases filed and the other two aren't exactly what your issue was.  Did you try the troubleshooting that was provided to you by John? If you can still reproduce this problem your best bet would be to send him a Screenr of your reproducing the problem so that he could assist you.

Ashley Terwilliger

Hi Thomas and welcome to Heroes! 

I took a look at a few of the other cases here, and didn't find one that was exactly the same as what you're describing but did notice a few common threads:

- Ensure you're working with local project files, for both your .story file and the Word translation document. If your .story file was not local, you may want to try importing it into a new project to resolve any corruption issues. 

- Conduct a repair of Storyline, and the supporting Windows software. 

Please let us know how it's behaving after conducting the repair and confirming that you're working with local project files.