Unable to Publish - Storyline 1.08

Jan 29, 2015

Hi folks.

Started up Storyline 1 today, needing to republish an existing course for web delivery, and got the Flash 16 error. Installed the 1.08 update, and now I have an unusual problem. When I try to publish for web, LMS, or CD-ROM delivery, I can't. After I click "Publish," I get the usual progress bar for about five seconds and maybe a 3-5% tick through the bar, and it just stops, leaving me at the Publishing screen again.

When I check on what it did, I found that it created a \Temp folder, and a \story_content folder, and a \mobile folder in the appropriate output destination, all with no contents in those folders.

I re-saved the .story project, in case it was corrupted, and tried again. Same behavior. Tried publishing to other versions (LMS, CD). Same behavior. Tried different options (no html5, no ipad player, etc.). Same behavior. Tried different folder names and locations (all on local drive). Same behavior. Reinstalled the update. Same behavior. Uninstalled Storyline and reinstalled the program. Same behavior. Ugh.


10 Replies
Ashley Terwilliger-Pollard

Hi Steve,

We've heard some recent reports of users having difficulty publishing, and it just freezing - so as Wendy mentioned we're happy to try out your file here as well. For those users who have had difficulty, it seems to be solved after they try to publish the file a second time (and not making any additional changes to the publish settings). If you'd like to share the .story file we can take a look or feel free to send it along to us here. 

Steve Semler

For this specific project, I need to post the course to be playable from a free-standing website directory as a demo/resource. I can't get this to work with the output I previously published for web; the player loading icon just whirls. I suspect that changing the top level folder name breaks internal links, but I don't really know why this isn't working. For that project, I am trying to figure out how I can name the course what it needs to be named, while having the output files bear a much shorter name with no spaces or special characters.

The big issue, though, is that now I can't get any courseware to publish.

Ashley Terwilliger-Pollard

Hi Steve,

If elements are not publishing and you've already done the repair, we'd want to look into where you're publishing (ensure it's a local drive, well under the 260 character file path limit, and no special characters, etc in file name or path) and any other items recently installed on your system that could be interfering with the publish behavior. 

I can't assist with any changes you've made to the published output - but when I publish a Storyline file, I see a folder created that matches the name I included here: 


But the files with the folder are more generic in terms of story.html. When you're placing the content within the intended web environment are you using the entire folder? You'll need all the contents generated to upload those to your web server - but if you've changed the file names that may be interferring with the publish files. 

Steve Semler

I changed only the top level folder name in which the contents are located,
before uploading it to the web server.

So: www.learningsim.com\content\12secrets\story.html

Instead of: www.learningsim.com\content\12 Secrets of Effective Trainers
web output\story.html

For example.

No changes to anything underneath that output folder, just changing the
folder name and uploading it into the \content web folder.

*scratches head*

This discussion is closed. You can start a new discussion or contact Articulate Support.