Using the (...) in trigger wizard to add file does not work

I have followed directions to attach PDF files using the trigger wizard. When I publish and click on the button,  I receive an error:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>732029207EF15580</RequestId>
<HostId>
o49zUJTkGhZ4GxXgOgcF8DQQVeV6kUtiLa5KVoH0c+Cn4lvSbO1CCgkVZ6kot3JuND6MJ5goK3Q=
</HostId>
</Error>

2 Replies
Gai Tuz

Hello Cristina,

I'm a user too. But I wonder if any of the following scenarios match yours and hopefully can serve as a solution:

Thread 1 -- Same error was showing up but this got resolved by using the recommended name convention for file names. Specifically, another user had to rename the PDF attachment and remove "#" or special characters in the project.

Thread 2-Here is another good thread if the above does not seem a similar situation for you. This thread has lots of suggestions about following the naming convention too and path optimization. Though I'd quote that from here:

"Be sure the file paths to your projects and published output are well under the 260-character limit imposed by Microsoft Windows. (The publishing process adds characters to the file path you selected. If it exceeds 260 characters, your published output will be incomplete.)

Avoid using special characters, accents, or symbols in your file paths and file names. Learn more about naming conventions in this Microsoft article."

Ashley Terwilliger

Hi Cristina, 

In addition to Gai's suggestions, I'd also want to check that you had uploaded the published output to your web server or LMS. Often testing the published content locally can cause errors or issues with playback.

If you're not ready to upload to your live environment, take a look at a few of the options mentioned here. 

Please keep us posted if you need more help!