Why are there swf files in my Storyline 360 HTML5 only output?

This has been driving me insane all afternoon - any thoughts would be appreciated. Using Storyline 360 and publishing as HTML5 only there are still swf files in my published output - does anyone know why? I've tried multiple times but they are always there and mean that I cannot upload to my LMS without making manual edits to the published output. 

Thanks

 

74 Replies
Steve  Galway

I know it's only 4 files but that's kind of missing the point. The 4 swf files prevent the published files going to my LMS without a manual edit of the imsmanifest and deleting the 4 files. My LMS no longer accepts any Flash content. As you appear to have found yourself it doesn't happen with every course so I'd like to understand what the issue is. 

Crystal Horn

Thanks for the insights, here, Bob! 

Steve, definitely feel free to post your .story file if you would like a hand with investigating this issue.  We've noticed that .swf files are created for embedded Engage interactions and logos, even when you've set your format to HTML5 only.  Can you let me know if either of those scenarios applies to you?

Emmanuel NIEL

Hello all, i have the same issue, it seems that the SWF files are related to my video files. But i don't know why because the videos are MP4 files and the published settings are HTML5 only. When i delete the swf files the videos are still working. So the real problem is that more and more customer/LMS plateform doesn't accept package with SWF files inside.
Does someone have more information about these SWF files?

Bob O'Donnell

Try posting a sample page. My guess is, as Crystal mentioned above, that you may be using an icon somewhere that is Flash based.

Same issue for almost all our clients. Their systems no longer allow .swf content. Somewhat good news for us as we're converting a bunch of old Flash courses so they work on the LMS systems.

Emmanuel NIEL

Here is an example of a content with only one MP4 video slide. Published with Storyline 360 HTML5 only then the output (attached) have a SWF file in story_content folder and linked in imsmanifest file. So a narrowed LMS platform doesn't validate this package. I have to delete the swf file first and the imsmanifest link. Why this SWF file ?

Andrew Hanley

Wow, this a game breaker if true!.

I just checked some courses from a couple of weeks back that have video in them, and they do not have swf file output. All videos are MP4. (phew)

However, Im wondering if this swf problem has been introduced in the latest round of updates to Storyline? I cant even try publishing with an older version as Articulate dont let you roll back.

Andrew Hanley

OK I did a test, and my old course with MP4 video has just published out by the latest version of SL360 and it did not have any swf files in the output.

That leads me to think it might be the encoding of your MP4 video that is causing the problem?

Can you try a differently encoded video just as a quick "1 slide project" test?

Steve  Galway

After much frustration wasting my time with codecs on video files I think I've finally tracked down the 'bug' that's causing the swf file problems in our published courses.

If you add a 'zoom region' to a slide it appears to cause a swf file to appear in the published HTML5 Only output. I've attached an example with nothing other than a 'zoom region' on a blank slide and it creates a single swf in the published HTML5 Only output - both in the 'web' and 'LMS' settings that I've tried.

I would appreciate it if someone could test this and see if they experience the same behaviour?

Cheers

Steve 

Alyssa Gomez

Thanks, Steve. I took a peek into your case, and I see that Ryan did log this problem as a software bug. 

For others following along, we found that a SWF file is created, even if you publish a file for HTML5 only.  Specifically, this happens only when there is a "Zoom Region" on a slide.

I really appreciate you bringing this problem to our attention, and we'll be sure to notify everyone in this thread as soon as the issue is resolved.