Delayed Animation and Incorrect Aggregate Quiz Results Slide

I have a sample course that is designed to allow user to choose their department to access a quiz. After the user takes the quiz, they should receive a completion mark for each quiz, and reach a slide with an aggregate quiz score. 

Currently, the animation to mark completion for the 2nd quiz {group} is delayed and the aggregate slide is producing a failed grade even though I passed all the quizzes (cumulatively). 

 

I attached the files.

6 Replies
Joey Buys

Hi Virginia.

I had a look at your Storyline file and noticed a few mistakes.

1. In your 'Moon' scene, there seems to be a slide order error that is preventing the logic from being executed properly. Your results slide is slide 2.2, but your questions are on slides 2.3 and 2.4. To remedy this, you can either move your questions to a question bank (advised for branching scenarios) or you can simply go to the 'Correct' and 'Incorrect' layers (on slide 2.4) and change the 'Jump to Next slide' triggers on the continue buttons, to jump to 2.2 Results Slide instead.

2. You do not have any pass criteria on your final results slide (4.1). You will need to tell this results slide to reference the scores present on the previous two results slides (Slide 2.2 and 3.3).

To do this, go to slide 4.1 and click on the big grey EDIT RESULTS SLIDE button on the right-hand side of the screen. This will open the Result Slide Properties. Click on the drop down next to the 'Calculate results for:' field and select the 'Selected results slides' option. Now select both the results slides in the list presented. This will fix your problem.

I also fixed the delayed animation error for you as well. You will notice that I used different logic (reused the existing variables that Storyline creates) to achieve this goal.

The buttons' change state logic looks like this:

I have reattached the fixed file herewith for you.