GUIDE: How to Upload Storyline Content to the Web Using Amazon S3

Hi All!

I've seen many people asking for additional help on how to upload Storyline projects using Amazon S3, so I put together a tutorial that should help out. If you have any additional questions or if anything needs to be modified, just let me know in the comments below.

http://www.devlinpeck.com/posts/upload-storyline-to-web

Thanks,

Devlin

 

66 Replies
Billi Thompson

I have the AWS account created. I have uploaded the file. I have chosen "make  public.  I published the story and then zipped it.  I uploaded the zip file to AWS. When I click on the link, I just get the zip  file contents.  It doesn't play.  I am sure this is a very ignorant mistake I have made... but what did I do wrong?

Lanie Williamson

Thanks for these instructions.   I was able to get my folder (unzipped) into Cloudberry and then to AWS.  I made it public, but I am getting this error when I click on the link: "This XML file does not appear to have any style information associated with it. The document tree is shown below."

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>8C067F478C787DB6</RequestId>
<HostId>
GGvQh5cybaNZcEHZ45u6T9SxoUrfr1uKlUnTZvUN+TrWuMjj88o7bMeU4MjFk72CydxnaQk90wg=
</HostId>
</Error>

 

Here is a screenshot of my files in AWS:

 

screenshot

 

Any suggestions welcome!  I am new to all this so I very well may be missing something obvious.  Thanks!

 

Devlin Peck

Can you please share with me the link that you used? Here are a couple of other things that may help:

  • Make sure you made the entire Storyline output folder public...you don't need to make anything inside of it public individually
  • If you need to upload your course again for any reason, make sure that you delete the entire Storyline output folder from Amazon S3, then re-upload it from scratch (I've had issues before when I did not do this)

I hope that helps!

Lanie Williamson

I tried this again with a different Storyline file with the same result so I'm sure I'm doing something wrong just not sure what!    I made the whole file public as shown in the directions, though I am getting an error here at the bottom - see screenshot.

Screenshot

Here's the link address:

https://s3.us-east-2.amazonaws.com/laniewilliamsonprojects/Reference+Interview+with+a+5-year-old+-+Storyline+output/story.html

 

 

Lanie Williamson

I figured it out (I think - it works now at least!).  The new settings for making the bucket public don't match what you have.  I went to "edit public access settings" and unchecked them all and now it works.

If I should have left any of these checked please let me know!  Thank you!