Next button won't work in quiz when accessed through Citrix

Feb 08, 2017

Hi all,

We're in the process of creating short courses in RISE to use with our LMS at launch in a few weeks but are having issues.  The latest issue has us stuck.

We have users who will access learning through tablets (Android and iPad) but also have desk based staff who will use PCs.  The PC users access Windows through Citrix and because we have Windows 7 they use IE11, and this has caused some issues with interactive slides.

The current roadblock is the following:  Our Citrix users access the web through Citrix, courses work fine until they get to a Next button in a Quiz.  The mouse cursor doesn't turn into a pointing finger cursor as it should.  Sometimes, if you're patient enough and hover over the button with your mouse cursor the cursor will change and you can click through to the next question.  But this isn't always the case, at some point you get stuck and can't get it to change at all.

Has anyone come across this? If so, how did you fix it or work around it?

I'm open to any and all suggestions but need to make sure that the course still works for mobile users on any device.

PS:  I have tested this using a SCORM Cloud hosted course as well as on our LMS People Streme and the behavior is the same.

12 Replies
Justin Grenier

Hi, Lionel.

It sounds like there is something unique about IE within your Citrix environment.  There are a couple of things we can check.

First, let's check your Compatibility View settings:

  1. Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Compatibility View settings.
  2. If the website where your Rise course is hosted is listed in Compatibility View, select it and click Remove.
  3. Also, if you're using an intranet, such as SharePoint, to host your Rise course, temporarily uncheck Display intranet sites in Compatibility View.
  4. Click Close, then launch your Rise course again. If the page is still blank, try the following method.

Use the Developer Tools to Switch Document Modes:

  1. Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Developer Tools. They'll open across the bottom of your browser.
  2. On the right side of the developer bar, you should see an icon that looks like a computer monitor and a smartphone with a number beside it. When you hover over the icon, a tooltip will say Document mode (with a number). Click the icon to display a list of Internet Explorer version numbers.
  3. Select version 11, then launch your Rise course again.

If your Rise course continues to misbehave in Internet Explorer after trying the methods above to fix it, let us know.  Thanks!

Justin Grenier

Hi, Lionel.

Is Edge the currently selected mode?  If so, it sounds like IE is OK, and this may be a Citrix problem.

Citrix can be unfriendly to media-rich content.  Do you have a Citrix administrator in-house, and if so, can you demonstrate how the content behaves one way in Desktop IE 11, and another way in Citrix IE 11?

Marc Koenecke

Hi Justin,

Thanks, yes we do have a Citrix Admin in house and he has been shown the issue.  He is apparently already looking into the Compatibility issue you highlighted.  Not sure though why the list shows only Edge (which is the default and doesn't show 11 and down.  Also, when I check the IE version we're running through about as mentioned it says it's 11.

I agree that it's probably Citrix, but because it's a bit of a road block I loath to just leave it with our Systems team - but I may have to.   

Marc Koenecke

OK, so we've dug around a bit more and have discovered that our IE version shows as Edge for all of the external sites we visit, looks like it defaults to lower versions when we access SharePoint (but this might be because of some component we use).  Still can't figure out why the browser shows Edge when it's about tells us it's IE 11.  It's lying to the sites it's visiting - not sure how or why.

Our systems guys have tried to figure it out and this is what they had to say:

"I have also checked the settings in IE to see if there is anything that may cause it not to be working but have not found anything there either.

 To me it seems like it is not rendering the page correctly within the Citrix environment.

 Do you know if they have tested this within a Citrix XenApp 7.12 environment on Windows 2012R2 Servers with IE11?"

For now we've changed our quiz's to not show the correct answers after question submission, removing the need for the next button, but it is a work around.

Justin Grenier

Thanks so much for the specs on your Citrix Server, Lionel.  That really helped!

I was able to reproduce the problem using IE 11 on a Windows 2012 R2 Server, and I've asked our team to take a look at a possible fix for this.  It doesn't seem to be a Citrix-specific problem--likely a uniqueness in the Server 2012 edition of IE 11.

We'll take a look and keep you posted on our findings.  Thanks again for reporting this!

Marc Koenecke

Hey Justin,

Any chance your team have come up with anything on this.  Right now we're only able to use a quiz as a test and not as a formative exercise for users to test their existing knowledge, because we can't set the quiz to reveal answers as the Next button then appears o allow for forward progress. 

Kind regards


Marc Koenecke

Hi Justine,

I'm not sure how but I missed your last response.

We gave up on the quiz result and of course the Next button issue was then no longer an issue.  Now we are having issues with Quiz results where learners are answering correctly but they still get a fail result - this is intermittent.

To fix this, and after a bit of quick testing I turned answer results on and this fixed the issue.  Now it appears that we might have the same issue as we'd had previously.

Any ideas how we can get around this?

Chrome isn't a great solution for our Citrix environment because it doesn't play nicely with SharePoint.

Any advice or suggestions would be greatly appreciated.

This discussion is closed. You can start a new discussion or contact Articulate Support.