Rise package - completion errors

Good day

We are experiencing extensive problems with Rise packages after upload to our LMS. Learners' completion statuses are not recording accurately i.e learners have confirmed they have completed the module up to 3 times and have sent screenshots proving this, however on the report they appear as incomplete or not attempted. Is there anybody else having the same issues and is there any hope for a resolution?

30 Replies
Nadja Augustyn

Good day

Thank you for your response.

I am not sure about Scorm cloud - we don't use that.

We are using Moodle 3.7 and browser is either Internet Explorer or Google Chrome.
Kind regards

[http://webrightagency.co.za/clients/OMMS/1047/LogoHR.png]

NADJA AUGUSTYN

LEARNING LEADER | OMF HUMAN CAPITAL

T. +27 (0)12 533 1004 I C. +27 (0)65 970 8639
West Campus, Mutualpark, Jan Smuts Drive, Pinelands, Cape Town, South Africa
nadja.augustyn@omfinance.co.za I www.oldmutualfinance.co.za
f. OldMutualSA t. @OldMutualSA li. old-mutual-south-africa

[http://webrightagency.co.za/clients/OMMS/1047/SA-175-Years-Logo.jpg]

[http://webrightagency.co.za/clients/OMMS/1047/bottomLine175HR.png]

Alyssa Gomez

Hi Nadja,

Could you help me with a few more details about your course?

  • Have you seen this problem when you test the course yourself in the LMS?
  • Does the course have an Exit Course button? If so, do you notice different behavior when using the Exit Course button rather than simply closing the browser window?
  • What date was this course published? 
Ash Baxter

Hi, 

We are also experiencing this issue with Rise and Moodle.  We have had this issue for a while now.  I have tried different Complete/Incomplete and Passed/Incomplete combinations but this does not seem to alleviate the situation.

Initially, I thought it had something to do with the safari browser on some Apple products.  I managed to re-create the error when completing the course on my iPhone.  Since then I have also had confirmation that dell office users experienced the same issue using the MS Edge browser.

Courses that do record completion successfully show completion without the exit course button being selected when I have tested.

The first time I came across this issue was in April with a course published then.

The issue raised today in reference to Edge was for a course published on Friday 26th June.  

Any help on this would really be appreciated.

Megan Joy Jeniker

Hi, I am replying on behalf of Nadja Augustyn.

Regarding the questions above:

Have you seen this problem when you test the course yourself in the LMS? YES

Does the course have an Exit Course button? If so, do you notice different behavior when using the Exit Course button rather than simply closing the browser window? Yes it has an exit button selected from the Rise settings. There is definitely a difference in reporting when one closes the window as suppose to closing using the exit button. Closing reflects as either "Incomplete" or "Not attempted" and using the exit button reports as "Completed" or "Passed".

What date was this course published? This course was published on 08 June 2020.

Crystal Horn

Hi everyone. There may be two issues happening in this discussion:

  • Courses exited by closing the browser window in Chrome 83 or Edge are not showing as complete or resuming as expected.
  • Courses aren't recording completion in other browsers, like iOS mobile Safari.

Here are some details on the Chrome 83/Edge behavior:
Chrome has deprecated a technology that was used by many LMSs to allow a course to communicate back to the LMS when the course window is closed. If your LMS hasn't upgraded their system, or if you're using an older version of your LMS that doesn't include an update to address this change, the course cannot communicate progress or completion properly. This causes learners to start over from the beginning instead of resuming a course or recording completion after they close the browser window.

Please reach out to your LMS and find out if they have released an update to address the Chrome changes.

For other browsers, please reach out to us here so we can investigate what is happening with completion in your particular environment. 

Megan Joy Jeniker

I've checked with our developer who confirmed the following errors still arising:

1.  "Module not loading, just freezes on a white screen.

2.  Module gets completed but reflects as not attempted or incomplete.

3. I have also had queries of people where it shows 100% completion on the module and they exit at the final screen and it still reflects as incomplete."

Our LMS (Moodle 3.7) was upgraded late last year. This issue only occurs with Rise, none of the other Articulate apps.

Please advise.

Mike Hobby

we are experiencing this issue of completing the content but the lms not reflecting completion. w are using paradiso LMS and i have logged in as the users and tired with Chrome, Edge Chromium and IE 11, all do the same. i also originally pubished the content with exit course button but it doesn' t show in edge or IE so i republished it with no exit course button. lack of completion at the LMS happens with both situations.

i tried it in scorm cloud and it worked fine.

 

 

Crystal Horn

Hi there, Mike. Thank you for those details. Since the completion is working in SCORM Cloud, it sounds like this issue is specific to your LMS environment. We are happy to help confirm! You can privately share your course output with us by clicking here.

Also, when I viewed a recently published course in Edge, I was able to see the Exit Course link at the top of the page. Let me know if you still don't see the Exit Course link in Edge or IE, and we can dig deeper on that issue, as well.

 

Alyssa Gomez

Hi Ashley, thanks for letting us know what's going on. Can you help me with a few more details?

  • Have you seen this problem in your own testing?
  • Does this problem happen in all web browsers, or certain browsers in particular?
  • Does your course have an Exit Course link? If so, do you notice an improvement if you close the course using the Exit Course link rather than simply closing the browser window?
Alyssa Gomez

Hi Ashley,

Some LMS's won't receive completion data unless you include an Exit Course link inside your Rise 360 course. Crystal shared more detail about that in her post above.

There are two ways you can add Exit Course functionality to your course:

  1. Add a button block, and set the button destination to "Exit Course."
  2. Publish the course for LMS, and on the publishing screen, toggle the "Exit Course" link to ON. 

Test the course again in your LMS, and let me know if the completion data is communicated correctly!

Jen Edgerton

We are experiencing this also with some Rise courses. The issue is intermittent and does not seem to be tied to the browser. We do have the course set to click exit and it's still happening. I have not yet tried adding a button block, but will do so. We've had Articulate Support and our LMS (Bridge) look at the course. We've also tried republishing it.

Lionel Dieperink

Hi, thought I'd chime in as we're also having an intermittent issue.  The learner passes the quiz - the mark of success - and yet still has the course as in-progress instead of as completed.  It doesn't seem to matter what device they are using, although anecdotally Android phone users seem to have more issues.
We have dozens of courses created in RISE and none of these are having issues, but I have as it turns out begun to use the Complete block before continuing Continue button a lot more than I did in the past, which perhaps explains some of the issues.

We also have the Exit button visible - I haven't tried to use a command button as an Exit button yet but will try this with the next course.

We use PeopleStreme V8.

Alyssa Gomez

Hi folks!

I recently shared some information about this problem in another discussion, but I'll reference it here, too!

Is it possible some learners aren't using the Exit Course button, and are instead manually closing the browser window? 

Also, it sounds like your LMS may need to update their system to account for the recent change in Chrome.

Chrome has deprecated a technology that was used by many LMSs to allow a course to communicate back to the LMS when the course browser window is closed (not using the Exit Course button). We made an update to Rise 360 in February to account for this change in Chrome. 

If your LMS hasn't upgraded their system, or if you're using an older version of your LMS that doesn't include an update to address this change, the course cannot communicate progress or completion properly.

I would share this information with your LMS support team to see if you can get more information on their plans for updating!