Storyline Blocks not showing up in Rise Course in Review

I'm adding Storyline blocks into Rise, and they appear and function when I am previewing the course. However, when I put the course up in Review, the storyline blocks are randomly dropping out. There is a gap on the page where it should be, but it's blank space and nothing loads. Back in Rise, it's still there and functioning properly. I have the two versions of how it's appearing below. Any ideas as to why this is happening?

23 Replies
Crystal Horn

Hi there, Phoebe. I'd like for us to gather some details from you so we can help better! Click here to open a private case with us, and please share this information:

  • the Share link of the content in Review 360
  • the Share link from Rise 360
  • in which browser(s) you're seeing this behavior, and whether using a different browser helps

We'll go from there!

Peter Johnson

One solution: export to a local drive, not a network drive.

I was having the same problem. In Rise, I was exporting the course, with the Articulate block embedded, to a network drive. When I previewed the Rise course everything worked. But, there was a blank area where the Storyline block was supposed to be when I viewed the published content/index.html file.

Instead of exporting to a network drive I saved the published Rise file to my desktop and everything worked as expected.

Meghan McKay

Posting here because we had the same issue, and what was even more baffling was that it suddently started for both myself and a coworker within the past 24 hours, on totally seperate Rise accounts. 

The SL block would preview perfectly in Rise, and we'd publish it and it would just be blank - exactly like Phoebe's screenshots show.  It wasn't just one SL block either. We'd make an update to another SL block, publish it to Rise, and now THAT totally seperate SL block that WAS working is now showing as a blank. 

We'll likely have to open a case with Articulate when time allows, but in the interim I just wanted to pass on a workaround that seemed to get our blocks working again. 

We were using Google Chrome.  We know Chrome updates have caused all sorts of issues with Articulate Rise and our LMS lately, so on a hunch, I exported our Rise course in our other browser (MS Edge) and the SL blocks suddently started working again.  I can't say it is a for sure fix, but if you are desperate like we were, try opening Rise in another browser before your export a new zip, and see if that fixes it.  We managed to get all of our "dead" SL blocks working again by doing that. 

Brian Roemer

Thanks Crystal for the quick response on this issue.  For me, the symptom is variable.  Upon publishing to either Review360 or SCORM 1.2, some SL blocks in the course will work and others won't.  We'll republish the course and find that different SL blocks work and fail.  This started for us maybe 1-2 weeks ago, but prior to very recently it seemed like refreshing the SL block or deleting/recreating the block entirely would fix it.  Now, doing so doesn't help.  Good luck with the fix.

Natascha Matthes

Following.
This is affecting us majorly as learners can't complete modules where SL blocks have to be completed before they can continue to the next lesson in a Rise module.
We tried the Edge fix as suggested above with no luck, unfortunately. The behaviour of SL blocks showing or not seems completely random.

Natascha Matthes

There is a temporary workaround mentioned in a different thread:
https://community.articulate.com/discussions/rise-360/storyline-block-doesn-t-show-up#reply-714305

While this does not seem to be applicable to Review publishes (because you can't edit the published files on the Review server), it is possible to edit the files in a SCORM package manually for this workaround.

Please note that you do so at your own risk, and should be familiar with editing HTML files containing script.

Problem causing the issue:
It looks like there can be random line breaks in the story.html files for the Storyline blocks in the SCORM package published by Rise (random line breaks in addition to those line breaks that are ok to use). These random line breaks are cutting off information that needs to stay on one line.

Note that there is a story.html file for each Storyline block that you have embedded in Rise.

Sometimes there are no problem-causing line breaks in the story.html file (SL block displays fine), sometimes there are line breaks in varying spots that seem to throw out the browser, and can't be interpreted.

We removed those error-causing line breaks and re-zipped the SCORM package, all SL blocks now displayed fine for us on SCORM cloud.
The fix also worked for the "Web" published version which you can test locally on your computer.

Natascha Matthes

If you are going down the workaround path, this seems to be the quickest way to identify the SL blocks that need fixing, especially helpful if you have a range of SL blocks within Rise:
(again, at your own risk, you should also know how to edit HTML files with script without deleting vital information)

  • Unzip your SCORM
  • Go to folder /scormcontent/assets
  • Go through all sub-folders with alpha-numeric names (these are the SL block content folders)
  • In each of these folders, double-click the story.html file to open it in a browser
  • If the SL block shows correctly in the browser, it should work fine in the SCORM (double-check at the end!)
  • If the SL block does not show (e.g. white screen only), then this file needs fixing

I have attached a screenshot of an error-causing line break I encountered in one of the story.html files. Note that the error-causing line breaks can be within HTML tags or within script. 

  • Remove the error-causing line breaks
  • Save the file
  • Retry to open it in the browser, if all good:
  • Rezip your SCORM

And of course: Test it all works before deployment.

Natascha Matthes

Hi Lisa, The same issue at the window.THREE call is described in the thread I linked to above.

You should be able to fix this issue for the SCORM or Web publish as described above, not for Review though. There is most likely a line break in the story.html file of the SL block within the line that contains the window.THREE call. 

Chino Navarro

Hi Laurie, I am sorry to hear that your Storyline blocks aren't working when your course is in your LMS. I recommend doing the following:

1. User a different browser such as Google Chrome.
2. Make sure Google Chrome is fully updated.
3. Clear your browser's cache and cookies.
4. Restart your computer.

If you are still experiencing the issue after doing the steps, feel free to open a case here. Our support engineers are ready to help.