Articulate '13/Moodle "Resume" Completion Issue

Hi All,

We are experiencing the following problem with one of our clients.

LMS = Moodle 2.6

Publishing = SCORM 1.2

Set to RESUME on re-launch

Set for COMPLETED/INCOMPLETE

Set for 80% of slides to be viewed for completion

1. Learner starts course and finishes course

Completion shows up okay

1. Learner starts course and stops halfway through and exits

2. Learner resumes course and finishes

Completion never shows up okay. The only way to get completion to show up okay in the LMS is to have the learner restart the course from the beginning and go through the whole thing

I know there's a lot of chatter in the forums on this, but I'm not sure I understand the solution. We have tried the replacing the SCORMfunction.js file provided by Articulate Support and mentioned in the forums, but when we replace the file and upload it to Moodle the course will not launch. (It's possible that fix is for '09 and we're using '13.)

Does anyone know how to allow the user to resume a Studio course in Moodle 2.6 and have completion status show up properly? If you need to point me to another forum post that you think applies exactly to this item, we're happy to receive that information.

Thanks!

Keith

2 Replies
Christine Hendrickson

Hi Keith,

I'm personally not a Moodle expert, but I have seen some discussion around the community regarding some resume issues and tracking. 

One point came up in this thread, even though it's not directly on-topic: Have you tried changing the option for "Ignore Flash Cookies when in LMS"? You can change this by going to Player >> Other >> Resume in Presenter '13.

I can't speak on the JavaScript solution, myself, since I haven't used it. Hopefully some of the Moodle and coding experts can take a look and see if there's an option that you can use with the newer version of Studio. 

In the meantime, you could attempt to test the course outside of Moodle. I'd recommend using SCORM Cloud. You should be able to use the invitation and log in as a user. It may not resume the same if you launch it from the content administration itself. 

Let us know how it goes!