Moodle - SCORM freezes (Dump File included)

Hello,

For quite some time I have been experiencing a problem with the SCORM packages I use in Moodle.  They freeze when it begins loading.  If you wait, at times for a number of minutes, it will start.  You have to use Task Manager to close the brower when it's stuck.  When you re-load your browser and log back into Moodle, it will load that SCORM package fine.

We are using Moodle 1.9.10.  The problem happens mostly with IE (I use version 8).  I was testing Moodle 2.0 with our host Pteppic, and on a 3 slide presentation without any tabs, it acted up.  They forwarded me a dump file with some errors in it.  They are looking at their end, but I was hoping to get somebody in the Articulate community to give a hand. 

I have attached a the dump.  Any help or ideas would be appreciated!

Many thanks!

-Dave

29 Replies
Justin Wilcox

That error is basically saying that the content is unable to communicate with the LMS. You would get the same error if you launched a presentation outside of  your LMS via the index_lms.html file. You might want to check this article out to make sure you are doing things correctly:

http://daveperso.mediaenglishonline.com/2010/11/11/getting-your-own-lms-part-4-moodle/

Not sure if this would help but I know SCORM Cloud works with Moodle:

http://scorm.com/scorm-solved/scorm-cloud/scorm-cloud-in-use/

Dave Newgass

Hey Justin,

Thanks for chiming in on this....

I have used SCORM Cloud to diag a similar issue (at the recommendation from Articulate Support).  I'm not sure about the other recommendation though.  I read the info and don't think it fits my scenario unless you are seeing something in the dump file.  (I don't understand the file, so i will leave that to those that do.)  I can't watch the vid as my daughter is asleep and my wife is watching East Enders.  If I interupt either......you get the idea!

Any other recommendations or help is always appreciated.

Cheers,

Dave

Justin Wilcox

This section is basically saying that the content can't connect with the LMS. That's why you are getting the error. The presentation is not communicating with the LMS. This could be due to a lot of reasons but I would review Dave Moxon's article to make sure you are uploading your content correctly and launching it correctly.

38:Tue Feb 22 16:55:46 UTC 2011 - In DisplayError, strMessage=Error - unable to acquire
 LMS API, content may not play properly and results may not be recorded.
Please contact technical support.
Dave Neuweiler

I just finished this struggle with a client, and came up with some conclusions.

First, this "lock-up-on-load" issue only occurs when three factors coincide:

1. It's Moodle.

2. It's MS Internet Explorer.

3. You set the Articulate presentation to open in a pop-up window.

Remove any one of the three, and it'll load just fine.

You can use Firefox or Safari, for example, and the issue is non-existent. But we didn't want to exclude users using IE, or force them to download a new browser. Or you can set the SCORM in Moodle to open in the current window, but the scale is miserably small and the content unreadable.

So here's what we did to solve the problem.

First, we upgraded to Moodle 2.0. This version has an enhancement that allows you to better set the stage size, so you don't have to get a reasonable view of the content in a pop-up window. In the "Edit Settings" page for your SCORM, you can set the option for "Display Package" in Current Window. The width is set to 100%, so by eliminating menu blocks on the sides of the Moodle interface, you can get a good-sized window for your content to display. Eliminating the new TOC pane helps too.

Also, you should set your Articulate template (under OTHER) to "Resize the browser to fill the screen," and "Scale presentation to fill browser window." If you leave the tempalte set at "Resize browser to optimum size," you'll get the window re-sizing three times when you launch content, and winding up where the user has to manually maximize the window.

The result? It's working for us... and I hope this helps make it work for you.

I hope this helps, and if you come up with better ideas, please let us know!

Best Regards,

Dave

Dave Newgass

Hey Dave,

Dave Neuweiler said:

I just finished this struggle with a client, and came up with some conclusions.

First, this "lock-up-on-load" issue only occurs when three factors coincide:

1. It's Moodle.

2. It's MS Internet Explorer.

3. You set the Articulate presentation to open in a pop-up window.

Remove any one of the three, and it'll load just fine.

What you are saying makes a lot of sense.  So much so that I forwared your views to our Moodle host.  Let's see where we go from here.  I am using IE8, Moodle and have set AP to open in a new window....

This looks promising!

Cheers,

Dave

Dave Newgass

Hey Dave,

Pteppic has tried the solution you recommended and he says it works.  This was done on their Moodle 2.0 dev site.

The problem I now need to solve is the fact that it is not full screen.  This is a must have.  Any ideas on how to use the solution you provided,  but be able to have it in a full screen without the Moodle 'framing' it?

Also, Lee at Pteppic drops a 'thank you' your way!

Cheers,

Dave

Dave Neuweiler

Hi Dave... we couldn't figure out how to force Moodle to open with the TOC minimized and the Navigation Blocks docked. So we created a Quick-Start Guide that's attached to each enrollment e-mail. It shows the user how to find a few things, change passwords, and the like. And I added this section:

What if You Can View the Content, But it’s Too Small?

If the content is too small to comfortably view (as shown below), you can maximize the viewing area by adjusting a few settings.

First, minimize the Table of Contents (TOC).

Second, you can “dock” the Navigation and Settings Blocks by clicking on the small blue rectangle, as shown here.

Here’s an example of a fully-maximized viewing area. The TOC pane is closed, and the Navigation and Settings Blocks are “docked” at the upper left. If you hover your cursor over these docked sections, they will expand to give you access to the minimized menus.

It's illustrated with screenshots and callouts showing where to click. What we observed is that Moodle remembers these settings between sessions, so the user only has to do this once. Not the most elegant solution, but the best I could think of given that we can't figure out how to have Moodle launch with presets.

If you guys figure that part out, let me know!

Dave Newgass

I think I solved my problem....kind of.  I used the Full Screen 'hack' that I have been using for some time now:

https://player.vimeo.com/video/148895521

It has worked like a champ on Moodle 1.9.10.  I just tested it with Moodle 2.0, and it worked great.  My only problem is that you have to re-fresh the course once it loaded in order for the Full Screen tab to appear,  Is there a way to eliminate that?  It's like the full scren option is not recognised until it is re-freshed.

We are getting there!

Cheers,

Dave

Payal Tandon

Normal 0 false false false oNotPromoteQF /> EN-US X-NONE X-NONE ontGrowAutofit /> ontVertAlignCellWithSp /> ontBreakConstrainedForcedTables />

We faced a similar issue, it was IE7 though most of the time where we would see a white screen on launching SCORMs. The SCORM seemed to load fine when browser cache was cleared out. Never really got to the bottom of why it would hang the browser.  The workaround that we told our customers was to not use IE7.  The system works absolutely fine with IE8 and above.

Payal Tandon

I am not sure what the exact issue is with the font size, but if the displayed screen is smaller than expected, then may be you could click on the window outside the articulate loader and use the "zoom in" function of the browser (Control + (Multiple times +)) to increase the size of displayed course.

Have a great weekend,

Payal

Dave Neuweiler

Thanks, Payal.

Interesting. Our failures occured on multiple Windows platfrorms (XP, Vista, Win 7), all using IE 8.

The browser zoom function was not considered an option; we considered it too tacky to "inflict" on our customers.

The issue is certainly an enigma, and I'm sure that eventually the cause (and cure) will be exposed.

Best Regards,

Dave

chad nixon

This is what fixed it for me. We had the same problem with articulate. Go to the request.js in moodle, mod, scorm, folder add:

    httpReq.timeout = 5000;
    httpReq.Xontimeout= DoRequestTimeout;

function DoRequest(httpReq,url,param) {

    // httpReq.open (Method("get","post"), URL(string), Asyncronous(true,false))
    //popupwin(url+"\n"+param);
    httpReq.open("POST", url,false);
    httpReq.setRequestHeader('Content-Type', 'application/x-www-form-urlencoded');


    httpReq.timeout = 5000;
    httpReq.Xontimeout= DoRequestTimeout;


    httpReq.send(param);
    if (httpReq.status == 200) {
        //popupwin(url+"\n"+param+"\n"+httpReq.responseText);
        return httpReq.responseText;
    } else {
        return httpReq.status;
    }
}

chad nixon

This is when you are using moodle and Articulate and have a pop up window. Sometimes on the loading screen the flash freezes and you have to totally shut down IE. (Does not work for IE 7) This is a fix for that. I am not a javascript programer by no means. I just added the 2 lines in the request.js in moodle, mod, scorm, folder add: just add these 2 lines of code that are bold in the function. I found the info from this page. http://community.articulate.com/forums/p/2569/14436.aspx#14436

function DoRequest(httpReq,url,param) {


    // httpReq.open (Method("get","post"), URL(string), Asyncronous(true,false))
    //popupwin(url+"\n"+param);
    httpReq.open("POST", url,false);
    httpReq.setRequestHeader('Content-Type', 'application/x-www-form-urlencoded');


    httpReq.timeout = 5000;
    httpReq.Xontimeout= DoRequestTimeout;


    httpReq.send(param);
    if (httpReq.status == 200) {
        //popupwin(url+"\n"+param+"\n"+httpReq.responseText);
        return httpReq.responseText;
    } else {
        return httpReq.status;
    }
}

chad nixon

Yeah if you are having an issue where it freezes on the first load this should work. What I think it does is give moodle more time to load before moodle starts asking for info. Just add the code highlighted below

httpReq.timeout = 5000;
httpReq.Xontimeout= DoRequestTimeout;

to the DoRequest function in the request.js file. Make a back up of the request.js if you want so you can just post back if you have an issue.  Make sure you clear your cache on your browser as well. If it doesn't work just take it out and re post back up. This is what helped us.

Jani Lemmetyinen

Hi Chad,

one of our customers has this problem as well. It occurs with Moodle 1.9.8+ and IE7. Everything works fine with Firefox and IE8.

In SCORM popup, flash freezed just you have described earlier in this discussion thread. So we try this

httpReq.timeout = 5000;
httpReq.Xontimeout= DoRequestTimeout;

and it works fine now - thanks a lot

But: it seems that Articulate's EXIT button doesn't work now in IE7. Has anyone here meet this? Any suggestions?

Cheers,

- Jani