AICC not working in Moodle

Hello everyone,

I created a course in Storyline and published it for LMS using AICC.

I first uploaded it to my Moodle installation and when I tried accessing the course, it opened the new window but it didn't show anything (I changed the settings in Moodle so that it loaded in a new window), the window was blank.

Then, I tried to test the course using SCORM Cloud and the same thin happened, not able to see the content of the course. After doing some research, I found that I had to change the "Filename (URL)" field in the AICC settings in Storyline to "index_lms.html". With this setting, it worked in SCORM Cloud, but still is not working in Moodle, the window keeps loading with just a blank area.

Does anyone know if there is a different approach to publish the Storyline for Moodle? Or if it's an issue that I have to fix directly in Moodle?

Thanks for your help!

Julio.

7 Replies
Julio Ordonez

Hi Nick,

Thanks so much for your reply!

The problem is that the client requires the course published using AICC instead of SCORM 1.2, the good thing is that it works for the client but I cannot test it using my platform (Moodle) so I can only test the course using SCORM Cloud. And here comes my next question, if it works fine in SCORM Cloud, should it work in every other LMS?

I'm asking this because the client says the course is not bookmarking, even though that setting was enabled in Storyline (I chose the "prompt to resume" option on the player).

Thanks!

Julio.