"Always resume" feature is not working

Hi all,

I'm using Storyline 3. 

When I publish my SCORM to LMS, the player feature "Always resume" doesn't work properly (sometimes it resumes from the wrong slide, more often it doesn't work at all). Player feature "Prompt to resume" doesn't work neither (the message "Would you like to resume?" simply doesn't appear).

I tried all sorts of different set up (SCORM created in SL1 and published in SL3; SCORM created and published in SL3; SCORM 1.2 and SCORM 2004; when revisiting slides, "Reset to initial state" option and "Resum saved state" option; ecc.), but I wasn't able to obtain what I wanted.

I used Storyline 1 since 2013 and I never had such a problem... 

Is anyone else having trouble with this?

Many many thanks in advance!

Al.

 

30 Replies
Alyssa Gomez

Hi Al! I can try and lend a hand here. I have a few questions to start.

  • Can you tell me the exact update of Storyline 3 that you're using? You can check by going to Help >> About Storyline
  • You mentioned that you published the file for LMS--in what LMS are you testing the output?
  • When you close the course and reopen, do you find that it resumes to a previous slide? If so, is it always the same slide?

If you wouldn't mind sharing your file with me, I'd be happy to help you with testing. Simply attach it here!

John Mokos

I'm having the same issue with Storlyline 360.  I have quiz that selects 35 random questions from a question bank of 60.  I don't want users to be able to restart or retake the quiz so I have set the player to "always resume".  The problem is that is that once you get past question 16 it always resumes on question 16!  This occurs even of the quiz is completed and the results are submitted.  

I have published my quiz in SCORM 1.2 to SCORM Cloud and to D2L with the same results.  

John Mokos

Update.  "Always Resume" works when published in Tin Can API and for the most part in  SCORM 2004, 4th Edition.   After several tests the best results are in Tin Can (SCORM Cloud).   Shame D2L doesn't support it.   

When published in SCORM 2004 the the quiz often resumes one question prior to the one I left off on even an answer was submitted.  

Alyssa Gomez

Hey John,

It sounds like you may have been running into issues with suspend data. When that happens, we typically recommend republishing with SCORM 2004, so smart move there.

Strange that the quiz often resumes one question prior to the one you left off on, even when an answer was submitted.  I'd be curious to know whether the same problem happens outside of D2L. Have you tested the output elsewhere, like in SCORM Cloud?

Let me know if you'd like some help with that testing!

Bob O'Donnell

We just had a similar issue pop up. One of the client testers was reporting that they completed a module but when they returned it dumped them into the middle of the slide deck. There are 97 slides split up between 4 modules published as SCORM 1.2. I'm going to assume this is related to the suspend data issue. Glad I found this - I owe them an answer today.

I'll have one of our folks retest it in SCORM Cloud or a Moodle just to be sure of the behavior. Never had this come up before.

Bob O'Donnell

Ugh... Ok Leslie, I just did a quick test using SCORM Cloud. I purposely went through Mod 2 of the training and stopped at slide 35 of 40. I closed the course and upon return, Storyline took me straight to slide 22. If you guys want a look let me know. Guess I should try publishing to SCORM 2004 and give that version a whirl.

Bob O'Donnell

Shoot me an email and I'll send you an invite to the SCORM Cloud course if you want. Although that suspend data appears to be the case. I published the course as a SCORM 2004 Edition 4 course and went through to the same slide (35) in Mod 2 and upon exit and return it took right back to the correct slide.

Bob O'Donnell

Well, There's nothing really to work on. Thanks for the offer/info though.

I did read something on line where it looks like some LMS systems allow the admin to adjust the data character limit to a higher setting. I haven't had the chance to explore that with the client's system yet. The easy solution was to just publish it and submit it as a 2004, 4th edition file. It worked fine.

Alyssa Gomez

Hi Pankaj!

Thanks for letting us know the prompt to resume isn't appearing in your Storyline 3 course.

I created a quick sample file in Storyline 3, published for Web, and tested it on Tempshare in Chrome. When I refreshed the browser page, the Prompt to Resume appeared correctly. View a screen recording of my testing here!

Could you also test this link and let me know if you see the Prompt to Resume?

Alyssa Gomez

Welcome to the community, Ahmed! Sorry to hear you're having trouble with the resume behavior. Tell me more about what's going on.

  • What update of Storyline 360 did you use to publish the course? You can check this by going to Help > About Storyline
  • When you exit the course then resume, what slide do you return to?
  • Have you tested in another environment, like SCORM Cloud?
Leslie McKerchie

Hi Erwin,

Thanks for reaching out and letting us know that you are unable to resume your course as expected.

You mention that 'always resume' is not working and I'd like to ask a few more questions to better understand:

  • Is this everytime you access the course?
  • Is the course starting from the beginning or from another part of the project?
  • Has the course already been completed when you are experiencing this?
  • Have you tested in another environment, like SCORM Cloud?
Colton Myers

I've was having the same issue with a larger course with 39 slides over 4 scenes with a lot of custom variables that needed to be saved and referenced throughout the project.

I was having this issue when publishing to our LMS in SCORM 1.2.

Once I published to SCORM 2004 the issue was resolved.

Hope this helps!

Clare Newlands

hello

Storyline 360 -i'm not getting the resume function to work when packaging for LMS (TinCan). if packaged for web the same file shows the resume window as expected. if packaged for LMS, before even posting to the LMS, i test it and no resume window appears. i've then tried posting it to LMS and the same, no resume window appears. this is happening for all of our modules, causing great inconvenience to our learners. (and our LMS support team who have been troubleshooting the issue as a possible LMS induced behaviour).

any advice?

thanks, Clare.