Bookmarking Issues with Storyline 360 and CSOD

I am having an issue with bookmarking in a course I built (I am a newbie to Storyline 360, with very outdated experience from before).

1 - I turned off the player skin.  Does this mean I also turned off the bookmarking functionality?

2 - I published as SCORM 1.2.  The LMS is CSOD (Cornerstone on Demand).

3 - There are 2 places where bookmarking is not working correctly.

3a - Bookmarking is not working from mobile browsers.  If the learner exits before finishing, and then returns, they are being forced to start over from the beginning.  NOTE - Bookmarking appears to be functioning if the learner uses the CSOD App.  Just not working from mobile Chrome and mobile Safari.

3b - From non-mobile (laptop/desktop), bookmarking is not working in one branch of the course (weird).  I did build each branch as separate .story files, then imported together into the course master file.  

Any thoughts, help, suggestions?  All are appreciated.

8 Replies
Katie Riggio

Good morning, Kerri!

Great move to also reach out to our Engineers. I'm sharing what our team found publicly to help others who spot this conversation!

  1. First, you nailed it to set your slides to Resume saved state. This feature lets learners pick up where they left off if they return to the same slide later. For more details on adjusting slide properties, check out this resource
  2. We have an open issue in Storyline 360, where the Exit course trigger does not work in goodbye.html. Our team is hard at work on a fix, and are treating it as a priority. We'll also share an update in this discussion as soon as it's ready!

Thanks for reaching out, and we're here if you have any more questions!

Ashley Terwilliger

Hi Kerri, 

Good news! We released an update for Storyline 360 that fixes the 404 error you recently reported.

If you already fixed your courses using the instructions from our Support team, you don’t need to republish those courses. The latest update prevents the 404 error from happening in courses that you publish from this point forward.

If you've customized the goodbye.html file for your Storyline courses, you’ll still need to copy and paste your custom goodbye.html file into the following folder on your computer, depending on your version of Windows:

32-bit Windows
C:\Program Files\Articulate\360\Storyline\Content\scormdriver_v7

64-bit Windows
C:\Program Files (x86)\Articulate\360\Storyline\Content\scormdriver_v7

Let us know if you have any questions. We're happy to help! 

Kerri Comstock

Hi Katie and Ashley - thank you both!  Yes, problem solved, and with Murphy's luck on my side, the SMEs requested an update to the course after the update to fix the 404 Error was provided, so that problem is now solved without having to crack into the js code.  On another note, due to complex animations, I had to reset all slides to restart when revisiting.  This actually made for a better end product.

Thanks, again!

Ashley Terwilliger

Hi Kerri,

A quick update for you regarding the goodbye.html file. The latest update (Update 41) of Storyline moves the goodbye.html file back to its original location in your program files. If you’ve customized the goodbye.html file for your Storyline courses, you’ll need to copy and paste your custom file into the following folder on your computer after installing the latest Storyline 360 update.

32-bit Windows
C:\Program Files\Articulate\360\Storyline\Content\lms

64-bit Windows
C:\Program Files (x86)\Articulate\360\Storyline\Content\lms

See this article for details on customizing the goodbye.html file: https://articulate.com/support/article/Storyline-360-Customizing-or-Suppressing-the-Goodbye-html-Page

Let us know if you have any questions. We're happy to help!

Luke Barrett

Hi all,

I have a similar issue in that I've made a small text change to an existing course, republished it using the existing settings, and uploaded to our LMS (Cornerstone). The course has always run without problems (and has been updated on the LMS before), however, this latest version of the course now fails to bookmark. I accepted an update for Articulate 360 a few days ago so I'm wondering if there was anything in the update that could be causing the issues? I have noticed that the launch window has changed a bit from the previous version - the old yellow launch button has changed, and the window no longer automatically disappears or changes text to advise you to close the window after you've exited the course. I've attached an image of the window I'm talking about. 

Any help would be greatly appreciated :-)

Cheers,

Luke

Lauren Connelly

Hi Luke!

Thanks for giving us a heads up about this! I haven't seen similar issues reported since our last update so I think we should start by testing the course in another LMS environment.

Would you mind testing the course in SCORM cloud? SCORM cloud is an industry-standard testing engine which will help us determine if the error is in the course or the LMS.  Here's more details on how to troubleshoot your LMS using SCORM cloud.

Ren Gomez

Hi Luke,

That's correct! If you find that SCORM Cloud isn't replicating the issues you find in your LMS, it's best to follow up with the LMS on what may be occurring.

If you'd like some additional testing or confirmation, feel free to share your file with our support engineers, and they'd be happy to dive a bit deeper with you on this!