Button works in Flash but not HTML5

Hi. We have a number of small topics that have a button that launches a slide layer when the user clicks it. If launched in Flash the button works as expected. If launched in HTML5 the button has to be clicked twice to achieve the same result. The button is used throughout this topic and several others, all with the same behaviours as above. We have SL3 update 6: 3.6.18134.0 and Chrome 73.0.3683.86

The topics were originally built on SL2 and then updated to SL3.

Many thanks

3 Replies
Alyssa Gomez

Hey, Eric! 

Thanks for including all those helpful details. When you published this file, did you publish for web, LMS, or something else?

And where did you host the output file for testing – on a web server or on a LMS?

If you were testing from your local computer, security restrictions may be getting in the way. I would recommend hosting the output on Tempshare (for web) or SCORM Cloud (for LMS) to get a true picture of how the button behaves.

Eric Brennan-Hazell

Hi Alyssa, 

We published for LMS and part of our testing procedure is to publish to desktop before we upload to an LMS.  We've done this with previous topics which have the same functionality and they have been fine. 

However since your reply we did a small test where we deleted the button in question and recreated it. Works fine now! So, although it was a laborious process we've replaced all the faulty ones. Going back and checking the same topics on SL2 they worked fine. It seemed that it was something in the conversion process from SL2 - SL3 (maybe!).

Still works fine now - just something to watch out for in the future.