Can't Save Storyline 2 Project

I've searched the forum but I couldn't find my answer.  I have been creating a course in Storyline 2 and I've just finished updating all my scratch audio and narrations.  When I go to Save or Save As.. I get an error

" The Project File cannot be Saved.  Cannot access a disposed object.  Object name: 'StoryPackage'. "

I can preview and publish but I can't save?  I haven't tried exiting without saving because I'm an old Storyline 1 user and I'm leery that I will lose my edits.  This is the first time with the new Storyline 2 that I've had an issue.  I remember during the release notes there was something listed about AutoRecover, does this work?

What should I do?

Thanks,

Spencer

43 Replies
Kelly Taylor

Hi guys,

So I've hit this hurdle yet again, as has my colleague. We have both tried all of the above and now cannot save the project at all: locally or on the network, neither as a template, or as a project, under the current file name, nor under a new file name.

Sadly our autosave wont pick up the changes as there have been a number made since the last autosave would have kicked in.

This is the error we have been continually receiving :Cannot save disposed object

Obviously we cant send a copy of the file to support as.. well we cant save it. So any further work-arounds others have found in addition to all of the above which have already been tried would be great.

NOTE: We will also be contacting support, but you guys always come up with the goods.

Kelly Taylor

Thank Leslie,

She did, yes. But it was a very disappointing response ;

"The only option I could think of would be to copy and paste everything to a new Storyline file. I did a quick test and confirmed you can do this one scene at a time."

While this does work in some instances, Sadly this offers no guanrantees.

This is both time consuming and a poor workaround for such a commonly occurring issue. I do hope the engineers can find a solution to avoid this happening in future.

Leslie McKerchie

I understand Kelly. Most of the users in this thread were reporting issue with Storyline 2 and were able to resolve without it being a common issue. When we were able to get users files, we were unable to recreate the errors.

Your case is for Storyline 360. I'm going to add these additional notes to your case. I have not seen similar issue reported.

Were you able to check to see if there was a working version of your project in your temp files?Here's how to check: 

1) Open this folder in Windows Explorer: %appdata%\Articulate\Storyline 

2) Scan the contents of this folder for a file that starts with the name of your project. If you find one, copy it to your desktop. If you find more than one, copy the latest version to your desktop. 

3) Change the file extension of the copy on your desktop from *.tmp to *.story. 

4) Double-click the file to open it in Storyline. 

File corruption is unpredictable, and there's no straightforward way to determine what causes it. Common causes are environmental (disk errors, power outages, improper shutdowns), viruses, failed Windows updates, and even file size (i.e., very large files have a higher risk of corrupting). Consider using the preventative measures described in this article to protect your project files.

You may want to conduct a repair of your software as well.

Henrik Clausen

You're welcome :)

Facing a file size of precisely 0 bytes for the project file I couldn't save into (nor move, nor rename), I believe that the primary cause is that our network on rare occasions causes files to corrupt, and that Storyline (I'm still on version 2) has trouble handling that situation, that the project file becomes unusable right under its feet.

Leslie McKerchie

Hi Mike,

Unfortunately I do not have an explanation to share. I reviewed this thread and the cases filed and there is zero consistency to share.

Curious if the issue happens in any course you are working on or just this particular one?

If you cannot re-create the issue in a new course, I would advise to import the file into a new one and proceed.

If it's happening in any/all files, you should certainly conduct a repair of your software.