Chrome Audio Fix in SL360

The release notes state: Enhanced: We added support for Google Chrome 66. If audio stopped working in your Storyline course, install the latest update and republish.

The forum Update 3 post states: Fixed: Published content stored on your local computer wouldn't play in Google Chrome 64 and later.

Which is it?  A local computer problem or a problem with every course sent to the field?

Sam 

51 Replies
Ashley Terwilliger

Hi Sam, 

Are you looking at release notes for Storyline 3 and Storyline 360? I noticed you mentioned Update 3, which sounds like you're comparing Storyline versions. 

If so, any of the fixes recently applied to Storyline 360 will soon be available in Storyline 3. 

There are two separate audio issues linked above, one is fixed in both 3/360 (the local playback of audio) and the second is fixed in 360 with a pending fix for earlier versions of Storyline/Studio (the autoplay based on Chrome ver 66). 

Let me know if you have any other questions after reading the links articles!

Sam Carter

https://articulate.com/support/article/Articulate-Storyline-360-Version-History

Quote: Enhanced: We added support for Google Chrome 66. If audio stopped working in your Storyline course, install the latest update and republish.

This suggests courses deployed to the field may not have audio in Chrome 66.  If this is true, then courses must be re-published to ensure clients can hear audio.

By clicking "Learn More" it goes on to say: Google changed the way media is handled in Chrome 66, so audio in your Storyline and Studio HTML5 courses might not play in Chrome 66 and later. Here's what to do, depending on your version of Storyline or Studio.

So this sounds definitive.  Courses must be re-published and updates sent to clients.

Yes, we use SL360, so it seems that this error is more like the kind of error the auto industry would issue a recall over. Instead, it seems to be swept under the rug a bit as just another bug fix.

 

Ashley Terwilliger

Hi Sam, 

Chrome modified how they handle media, so our team made improvements to Articulate 360 to support this latest version of Chrome. With Storyline 360, here is how content will behave:

Learners using Chrome 66 and later now see a play button when they launch or resume a course with a video on the first slide. Clicking the play button starts the course and allows the video to play.

Videos on other slides should autoplay as expected. 

Also, per Google Chrome's documentation:

Under the new policy media content will be allowed to autoplay under the following conditions:

  • The content is muted, or does not include any audio (video only)
  • The user tapped or clicked somewhere on the site during the browsing session
  • On mobile, if the site has been added to the Home Screen by the user
  • On desktop, if the user has frequently played media on the site, according to the Media Engagement Index

So, you may want to confirm if your content can currently play based on the above information before you look at republishing and sharing with clients. 

Sam Carter

Ashley, this is encouraging.  So this issue is related to videos containing audio.  The release note is misleading: Enhanced: We added support for Google Chrome 66. If audio stopped working in your Storyline course, install the latest update and republish.

We won't expect any issues with Chrome playing audio unless it is embedded in a movie.

Thank you,

Sam

Ashley Terwilliger

Hi Sam, 

I'm glad it's encouraging! It's definitely a confusing one, so here's a bit more of a break down.

Chrome 66 disabled the autoplay of audio (in a video or audio file) and both of these items are addressed in the latest Storyline 360 Update. I previously only linked the video piece which was fixed earlier, (sorry about that!) but you'll find the audio one here and that was fixed in Update 15. 

Both of these required a change in Storyline to adapt to Chrome's new engagement rules, and in many cases with audio, if you approve it playing once on a site, you won't have to approve again. What this will look/sound like for a user: 

  • If you include audio on the first slide, they'll see a play button. After clicking to play, audio will play throughout the course. 
  • If you don't include audio on the first slide, and the user engages with the first slide (i.e. clicks next, clicks anywhere on the slide, etc.) that will count towards the user engaging with the content and the audio will play. 

So, our fix was to interpret learner interaction on the first slide (like the next button for example) as wanting to allow audio, and communicate that approval to Chrome 66 in the way that it wants to know about it. 

Chrome also maintains the Media Engagement Index (MEI) for every domain you visit. That will continuously track if you've accepted media to play a certain number of times, and then you won't need to accept any longer and it'll just play. 

Sam Carter

If I sound difficult I don't mean to be but this response seems to indicate that prior to this fix, there was no "play audio" button that would present itself in the latest Chrome releases.

In this situation, it is necessary to republish and redistribute courses to the field if there's a standard audio file on the first slide timeline (this is the case with all of our courses).

Is this correct?

Ashley Terwilliger

Hi Sam,

Content published in a version of Storyline 360 prior to 3.15.155581 will need to be republished if it's subject to the new audio playback policies of Chrome 66 and later. 

If you had users who had previously accessed the course or that domain, and now have updated their browser the MEI may have caught that (depending on the number of times, when they've chosen to play audio, etc.) so that value will remain even through Chrome 66. Since it's based on how Chrome will interpret that, I'd suggest publishing again to have total confidence that the audio will play as designed.

Paul Bailey
Ashley Terwilliger
  • If you include audio on the first slide, they'll see a play button. After clicking to play, audio will play throughout the course. 
  • If you don't include audio on the first slide, and the user engages with the first slide (i.e. clicks next, clicks anywhere on the slide, etc.) that will count towards the user engaging with the content and the audio will play. 

Ashley, are the two bullet points that I have quoted from one of your your previous post describing the end user experience after republishing with the new version of Storyline or if we do not republish with the new version?

Paul Bailey

I was impacted with losing audio personally on two computers on the same day 5/5/18. I know of others that are using the same version of Chrome that have not experienced the issue. I suspect that this is based on how our browsers had tracked our individual usage in the LMS.

I was able to resolve my lack of audio using this modifications in chrome. (see attachment)  

1) Do you know if this is a valid (temp fix) for others that may have the problem? 

2) Based on your understanding of the issue. Is this likely to impact EVERY new user to the LMS until we can re-publish the content?

Lizzie Angell

I am I correct in thinking that while you (Articulate) have done a fix to supposedly 'fix' the Chrome problem, that eventually all the other browsers, (Safari, Edge, IE, etc) will all be applying the same modification, disabling auto play and that you will then be writing a new bodge fix for these other browsers and telling everyone that the 'just need to republish' everything again in a month or twos time?  

Sam Carter
Lizzie Angell

I really think that in these situations Articulate should send it's users an email telling them that there are issues, rather than leaving them to faff around for hours thinking they are doing something wrong or being thick, before they find this string of posts 

I concur.  Any time a development occurs that can break courses deployed to the field, the consequences should be highlighted. Instead, this issue has been billed as another bug fix.

Alyssa Gomez

Hi there Paul -- If you have older courses that have not been republished yet, you may have luck asking the learner to adjust their Chrome browser setting. However, the best way to ensure a learner can workaround the issue is to recommend using a different web browser.  

This problem may not affect every new learner, unless they have never visited the LMS domain before. If they have engaged with the domain a lot in the past, Chrome’s Media Engagement Index (MEI) might allow autoplay to function.

Hi Lizzie -- I'm so sorry for all the headache this has caused you! I spoke with Vevette, and she let me know that you chatted with her about this problem, as well. What you were encountering was an issue viewing the published output locally on Chrome. Our team is investigating this bug, and we'll be sure to follow up with you as soon as we know more. 

Mark Ramsey

I did a little research and came up wit two solutions:

First, for immediate Help Desk tickets, you can instruct affected users to change the Chrome browser's AutoPlay policy to "No user gesture is required". You can change this setting on chrome://flags/#autoplay-policy

Secondly, you can instigate a code fix. Since Chrome wants to see user interaction - i.e. a button click in order to affirm that user interaction has been engaged - we can do this:

  1. create a text variable called "isChrome", and set it's default value to "false"
  2. create a button on the first slide of the Storyline file that says "PLAY", and set it's initial state to "hidden"
  3. put a trigger on this new button that will restart the timeline
  4. put another trigger on the button to make it disappear upon being clicked
  5. run a JavaScript  snippet when the timeline checks to see if the browser is Chrome
  6. if the browser is Chrome, change the "isChrome" value to "true"
  7. set up a trigger that will pause the main timeline if "isChrome" changes to "true" 
  8. have a similar trigger change the state of the new button from "hidden" to "normal", if "isChrome" changes to "true"

At this point, if the browser you are running in is Chrome, the main timeline will pause, and this new button will show. Click the button, and three things will happen:

  • The Chrome browser will now understand that there has been user interaction, so it's okay to play audio now
  • The button will disappear
  • The main timeline will start up again

Setting up the slide in this manner will not affect the Storyline running in Internet Explorer or Firefox. The button will not show, and the timeline will not pause.

I recommend that you use maybe the first second or so of the first slide to do all this. The response should be very quick, but you are going out to JavaScript/the browser to do this, so there might be a load or server issue. So far in my tests there has not been a serious timelag issue.

 

Ashley Terwilliger

Hi Mark,

What version of Storyline are you using? 

The update for Storyline 3 to support the change in Chrome's autoplay behavior is available now, and you can find information on it here. (Storyline 360's update was just prior to that). 

 I'm curious if the changes to Storyline 3/360 won't work to allow your users to use the play button and let Chrome recognize that as initiating content vs. the method you've set up to create your own play button? 

Ashley Schwartau

What a super fun issue we all get to deal with. *facepalm* So, here's a question that my team and I are confused about: how the heck do we test this if the MEI is going to build up and remember that we've interacted with a domain before? With all of the translated versions of our inventory of courses, we have 120+ courses to republish in order to make sure they function correctly in our demo portal. But if we upload something to our demo portal, after a while, it'll remember that we've been to that domain and just start working right? Will clearing our cache clear the MEI?

What about in the SCORM Cloud? How does that work? Does it 'reset' each time you launch/test a course?

Trying to better understand since we have a daunting task ahead of us, not only republishing everything but also testing to make sure its good to go, so any suggestions you can provide or light you can shed on this issue will be helfpul. :-/

Paul Bailey
Alyssa Gomez

Hi there Paul -- If you have older courses that have not been republished yet, you may have luck asking the learner to adjust their Chrome browser setting. However, the best way to ensure a learner can workaround the issue is to recommend using a different web browser.  

This problem may not affect every new learner, unless they have never visited the LMS domain before. If they have engaged with the domain a lot in the past, Chrome’s Media Engagement Index (MEI) might allow autoplay to function.

 

Alyssa,

I appreciate the information and I know this issues was not caused by Articulate and you all are trying to solve a problem that you did not create. I still need more clarification and this is the only place I know to ask. The words "might" and "may" are very concerning.  Here is my follow-up question:

If a ...

  • Chrome 66 user (that has not modified their settings)
  • that has NEVER used our LMS
  • engages  with a module published with a 360 version prior to 3.15.155581
  • which does contain audio

... would you expect anyone as described above to hear the audio?