Error 80070643

I am currently trying to install Storyline 2 Update 6, but I doens't let me finish. When the installation seems close to complete, the bar moves a bit to the left, then continues loading a bit and right after that I get the Error 80070643 (The Storyline installation folder contents appear to have been moved, renamed, or deleted).  I was running with Update 5 perfectly before trying to install this update, but now I can't even go back to that.

I tried uninstalling and installing it again but it would't let me uninstall. Running as administrator wouldn't help either, nor did any of the solutions from the other similar threads because many of them listed that you had to uninstall SL2 and do it over again, but i am unable to do that.

I understand that it may not find the previous installation files, i have them, but i don't know if they are in the same folder/place in which they were when I first installed those updates.

I have Windows 7 Home Premium 64-bit.

I have submited a support case already, but if anyone has any solution, I'm keeping this thread open.

I have attached several screenshots of the error messages I get displayed. 'SL2_uninstall' is the message i get when i try to uninstall. 'SL2_install_failed' is the error i mentioned earlier. 'SL2_try_to_open_file' is a message i get when i try to open a story2 project, and when i click ok in both windows i get the 'SL2_unrecoverable_error' (it's in spanish, but it states the route of the project and then it says 'unrecoverable error during installation'.

12 Replies
Ashley Terwilliger

Hi Mica,

Thanks for letting us know you're working with our support team. If you're able to share the case number with me (it would have been included as a part of the first email reply confirming your case) I can follow along - but suspect as you mentioned that if the files got moved Storyline is having difficulty finding them to remove as a part of the update process. I suspect our Support team will be able to get you situated! 

Mica Oli

I was able to solve the problem yesterday myself luckily. Apparently there was something wrong or broken in the SL2 Program Files folder. Here's the steps I followed for anyone who's having the same problem:

  1. I installed the SL2 version/update I had in my computer before trying to update (in this case Update 5, but it could be another) in ANOTHER computer.
  2. Once properly installed (I checked if I could open Storyline properly before this), I copied the SL2 Program Files folder from that other computer in a pendrive.
  3. Back on my computer I pasted and replaced all the archives in MY program files folder with the ones copied in the pendrive (which came from the other computer).
  4. That should make SL2 open again and work (with the previous update I had), which it did.
  5. Then i proceeded to install the new update with all windows closed just in case, and always running as administrator.

My case was #00641506 and Renato told me that what I did would 'rebuild the folders in Program Files and fix the problem'. That was it for me luckily. Hope it helps! 

Thanks anyway.

 

Rodney Faulkner

Hi, I don't understand this solution. I'm getting the second image Mica provided. I can't even install it to do steps 1 to 5.

Every other time i've had the application corrupt i've had to do a complete uninstall, inc. .NET. This is the first time it won't even install even after removing old install zips, cleared out the registry etc.

Why is it saying files have moved when that's exactly what you have to do to reinstall it?

I can see this same error littered throughout these forums but I cant see any proper solution, just various replies from your customers that they sorted it themselves one way or another.

Can you provide anything a bit more definitive about what is actually wrong?
Thanks very much, hope to hear from you soon.

Kind regards,
Rodney

 

Crystal Horn

Hi there Rodney.  I'm sorry you're running into a wall with installing Storyline.  I took a look at Mica's case, and it appeared that he had all of the previous installation files (storyline-2.exe) from updates that we've released.

Are you downloading and installing Storyline 2 for the first time, or are you downloading our most recent update (which was released May 23 of this year)?  It appears that Mica installed a previous version (pre-update) onto another machine and then copied those program files back onto his problematic machine.  I'm not sure if that's feasible for you.

Our support engineer had initially advised him to restart his machine after having downloaded the most recent update and then trying to install.

In any event, I think your best bet would be to work with our support engineers; they are good at investigating and pulling installation files from your machine to see where the breakdown is occurring.

I know you'd probably prefer more specific reasoning as to why this is happening to you, but it seems to vary case-by-case!  I'm sorry again for the trouble, but our support folks are happy to help out!

Rodney Faulkner

I've resolved this one but unfortunately I don't know how. After uninstalling and reinstalling several times (this usually resolves an glitches i get in Storyline) I left it for the night and when I tried the next morning, it worked! I didnt make any changes between these times. Sorry I can't shed any light on this one.

Jack Drolet

I had the same problem and Articulate Support sent me the tips below. The Microsoft Fix It tool is what finally got it to work. 

Since Storyline 2 is not installing on your computer, please follow the troubleshooting steps in this article to fix unexpected or erratic behavior in Articulate Storyline 2:

https://www.articulate.com/support/article/unexpected-or-erratic-behavior-in-articulate-storyline-2

You can skip the part where you are being prompted to uninstall Storyline 2. Please ensure that you are using a user account that has full admin privilege and to temporarily disable UAC.

If the issue still persist, please download and run Microsoft Fix It which can be downloaded here:

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

After running Microsoft Fix It, please reinstall Storyline 2.

Leslie McKerchie

Hello Andi and welcome to E-Learning Heroes :)

Sorry to hear that your ran into difficulty with this as well and thanks for the details of your troubleshooting.

I was popping in to advise that you reach out to our support engineers, but it appears that you are a step ahead of me (01071919).

You should be hearing from someone soon and I'll follow along as well.