feedback master button states not being inherited by feedback layers

Hello All,

If I create a brand new project, and add a multiple choice question, and then look at the states for the Continue button on the Correct feedback layer,  here’s what I see (notice the Down state):

 

If I go to the Feedback Master, and look at the states for the continue button on the Correct feedback layout, this is what I see:

 

As you can see, in a brand new project – having changed absolutely nothing – there is already a disparity between the Down state of the Feedback Master Correct Layout, and the Correct Feedback Layer it governs. 

This disparity is highlighted if I change a state on the master, because the state does not get inherited by the layers – irrespective of whether the layers existed before I made the state change, or if I add a brand new MC question after I made the state change.  

Here I have changed the color of the Down state on the Feedback Master Correct Layout.

 

When I create a brand new MC question and view the Correct layer, here’s what the states look like:

 

Am I misunderstanding something? Can anyone shed any light on this issue? 

83 Replies
Lauren Connelly

Hello Dianne!

I really appreciate you sharing your troubleshooting steps with us! I can see that this bug is still impacting both your workflow and the courses you've built. I'd like our Support Engineers to investigate further since we've already released a fix for this bug, which hasn't solved the issues on your end. I've submitted a case on your behalf and emailed you sharing the next steps. We'll continue the conversation in your case!

Selin Ilpesin

Hi, i have the same trouble in Storyline 360. I have defined the state colours of the feedback button according to our Corporate Design but they change into completely different colours after closing the feedback master. This way i need to edit each button on each feedback layer separately.

Why is this happening? I've seen this was also reported 4 years ago in another post. Any news on that issue?

Vincent Scoma

Hi Selin,

I am sorry to hear that you are running into those troubles! 

I would like our Support Engineers to review this further with you. They'll be able to take a closer look at your file and provide some possible solutions to help get you back up and running! You can connect with our team here

Please let us know if you have any questions! 

Lauren Connelly

Hi John!

Great question! To speed up finding a solution, I recommend working with our Support Engineers because of their expertise. We are continuously tracking customer impact, testing files, and determining workarounds. 

If you haven't started working with our Support Engineers, we'll start by testing a file. Feel free to use this link to share your file.

Conor Striegel

Having the same problems here! I have about 65 feedback layers where the states of the Button need to be changed manually with the format-painter because the changes made to the feedback master don't update on the layers in my question banks.

The story I'm working on will serve as a template for other eLearning-modules, so I might have to change my buttons again depending on feedback from my colleagues.

Is there any news about a fix (for SL3)?