50 Replies
Therese White

Hi all.  We have locations experiencing the same issue with our courses now when using an iPad and possibly a Samsung Galaxy tablet, where we weren't having this issue occur before.  We are reaching out to the LMS vendor.  What's interesting is that our modules were functioning successfully on iPads until recently and the Samsung Galaxy tabs as well.  Our courses are all are scorm and published as html5, if that helps.  It would be great to find out a solution.  If I hear back on the java applet or other LMS-related issue will let everyone know.  Unfortunately, we cannot test the courses on Scormcloud.  Thanks.

Allan Aikman

I am having a similar issue on the 2 latest courses I have created. The error is intermittent. People have the issue, I have gone to their desks and they have tried again and it worked. This tells me that it is unlikely to be a java issue. Of 600+ users, I have had around 12 with errors. I am about to do a global launch, so I want this to work properly. Have you been able to find the root cause of these errors?

I am using Storyline 360, SCORM 2004 4th Edition on Success Factors LMS. I never use the launch in a new window page and have made sure that it is unchecked.

Andrew England

Hi, has there been any resolution to this?

We are also experiencing this issue with a course created in Storyline 360, published as scorm 1.2 and hosted on Totara (also tested on scorm cloud).

The LMS API alert is popping up first time the course is viewed on a Samsung tablet in Chrome or in Samsung's android browser.

Thanks

Ashley Terwilliger

Hi Andrew,

That error has typically been one specific to the LMS. The information previously shared is included below: 

Some LMS’s use a Java API object to load content. Since content created in Articulate does not require Java, please do the following:

*  Contact your LMS provider and ensure that your installed version of Java is compatible with the version of the LMS you are using.
*  Ensure that you have published your content properly as described in the following article. 

Were you able to check into those things?  
Is that error only occurring on the Samsung tablet, and not anywhere else? 

Katie (Gokhshteyn) Riggio

Hi, Andrew. Thanks for reaching out in the forums, and I see you opened a support case earlier today for the same issue–smart move! I'm also perplexed as to what is causing this alert on your Samsung device – what OS is it running?

My teammate, Abel, will reach out with his findings as soon as he completes testing your file. I'll also follow along as the case progresses and share important updates here as needed! 

Andrew England

Hi Katie,

Thanks for looking into this. The issue is causing some headaches for our
client.

The Samsung Galaxy tablet we have been testing on has the spec as attached
screen capture. Hope this helps

The client has also tested on a Samsung Galaxy tablet and experiences the
issue. They're testing on a Samsung Galaxy Tab A 6.0.1.

We await your findings.

Thanks again,

Andrew

Allan Aikman

I have had this error intermittently with several e-learning modules. They have been constructed using various tools, mainly Storyline 360. I have checked Java and ensured the open in a new window is unchecked.

The latest ones with the issue, I tested in SCORM cloud and had no issues and the manifest looked ok. SuccessFactors LMS shows an error in upload, claiming an issue in the manifest.

Would it be possible for Articulate and SuccessFactors to get together and workout why this error is occurring?

I understand that if it works in SCORM cloud, the module is fine, but perhaps some communication between the two parties on what the LMS needs to handle Storyline 360 output?

 

Any thoughts?

 

regards

 

Allan

Katie (Gokhshteyn) Riggio

I'm sorry for the headaches this puzzle is causing, and appreciate the extra detail, Andrew! Every bit helps. I shared this information with Abel and see he is still hard at work carefully testing in various environments. Keep an eye out for his email soon, and I'll continue to follow along!

Hi there, Allan! I'm sorry you're still hitting that error, too. I'm sure this puzzle hasn't been fun to troubleshoot since it happens intermittently. You mentioned that about 12 out of 600+ learners run into this message – do you notice any trends in their environment? Just to verify, it sounds like you've shared the communication logs between SuccessFactors and your Storyline content with your LMS admin? 

In the meantime, I've created a case on your behalf for our Support Engineers so we can help along the way. Someone from the team will be in touch and I'll follow this case as well.

Cheryl Powers

I am recently having users report this issue error message/api lms issue launching our Rise courses using Microsoft Edge browser and we have SuccessFactors LMS. I read about the top problems and one of the common issues in the article was the network connectivity so perhaps you are on to something, since a lot of our plants and warehouses have old networks and can get dropped frequently. 

Ashley Terwilliger

Hi Cheryl,

I saw your other post here on the issue as well, and I'm sorry this error continues to put up roadblocks for your content.

Have you heard anything from your SuccessFactors team about that error? It is LMS specific, so they'd be the best resource for digging in further. I'd share with them the links that work in SCORM Cloud so that they can compare for testing.

Keep us posted on what you find out, I know that lots of folks use Success Factors so it may help someone else who runs into a similar situation. 

Katie (Gokhshteyn) Riggio

Hi, Allan. I'm very sorry this error is still plaguing your courses, and really appreciate you continuing to reach out!

I took a peek at your case with my teammate, Ryan, and saw he shared instructions on how to enable LMS debug mode. Has SuccessFactors had a chance to review those logs? If you're able to share the logs in your case, we're also happy to help you and your team interpret it!

Thanks again, and we're both standing by if you need anything else!

Ashley Terwilliger

Hi Gerry,

Our team was also working with Allan and waiting to hear back with some additional info, but I don't see we've heard much since August. 

Did you also test to see if you're receiving this error in any other LMS environments, such as SCORM Cloud? Our team is happy to help test if you'd like to share details with us in a case. 

Luke Sochacki

All, 

I had this issue recently and put a ticket into CornerStone, our LMS provider, to find out what was going on. Here's what happened in our case:

1. We published the course in 2016 as a SCORM 1.2 course

2. We made changes to the course in 2019, and replaced the publication file with the new course, which was published in SCORM 2004 (3rd Edition)

3. The LMS did not like this, and threw this error because of it. Once we found this our from CornerStone, we replaced the publication file again as a SCORM 1.2 course, and have had no issues since

Hope this helps!

Luke

 

Leslie McKerchie

Hello Vidu,

Thanks for reaching out and letting us know that you're running into a similar issue.

Did you zip the published output from the Publish Successful dialog box or manually? See Step 7 here.

Are you seeing the same error if you upload the content to SCORM Cloud or is it only happening within your LMS?