Hyperlink hover color blocking text?

I was wondering if someone could help me with a strange thing that keeps happening with my courses.

I have been converting some older Storyline 2 courses over to Storyline 360 so we can publish them for Edge users, and other than a few formatting problems I have been able to catch and fix I am having a strange thing happen with my hyperlink text.

Whenever the mouse hovers over the hyperlink text, the background color I've set for the theme sometimes appears in front of the text instead of behind it. But it only happens sporadically and seems completely random. 

I know there is a workaround to use a hotspot to jump to the url, but I am hoping someone here would know a fix that I might be overlooking.

I attached two images to show the hover working correctly on one link, but not on the other. Both are set to the same trigger and within the same text box. This is happening in Review and preview mode both with Chrome and FireFox.

I have been following the topic https://community.articulate.com/discussions/articulate-storyline/hyperlink-hover-background-is-making-hyperlink-text-unreadable but since this is different than just changing the color I figured I would ask.

Any ideas?

32 Replies
Alyssa Gomez

Hi Andrea, 

That's strange, indeed! The hover in your 'example 2' screenshot almost looks like a shape covering the text. Would you mind sharing that particular slide with me? You can do a 'Save As' to create a copy of your file, then delete all but the one slide that's giving you trouble. 

Then, click here and attach the file to a new thread comment. I'll take a look and let you know what I find!

Alyssa Gomez

Thanks for allowing me to take a peek at your file! We're seeing some buggy behavior in Storyline 360 with hyperlink hovers, and it looks like that bug is affecting your file.

Apparently when animation 'By Paragraph' is applied to a text box with a hyperlink, the hyperlink hover color covers the text completely. Until we find a fix for this bug, you can work around it by changing the Effect Options to 'As One Object.'

I hope that's helpful, and I'll be sure to let you know if I get any more information on this bug!

Andrea Belanger

That does help, thank you Alyssa. It's unfortunate though because to get the effect of the text to come in and different times, I will have to make each part a separate text box for the animation if there are hyperlinks that need added.

Any word on if this is a bug that will be getting a fix anytime soon?

Alyssa Gomez

Hi Andrea,

We're careful about testing new updates to make sure we don't put other features at risk, and I don't want to commit to a date before we have a fix finalized. In case you're interested, here's some more information on our process for tackling bugs. You're in the right place, and we’ll share as much as we can, as soon as we can! 

Alyssa Gomez

Thanks for sharing your file with me, Angie! After taking a closer look, the problem you're seeing isn't related to the bug I mentioned earlier in this thread. It's actually happening because of the light color you selected for the Hyperlink color.

To fix it, I selected a blue color that is a few shades darker thank the original Hyperlink color, and now the hyperlinks look much better.

Take a look at the changes I made in the attached file, and let me know if that will work for you!

Radosław Kwasek

Hi, I'm also waiting for fix to this issue. Meanwhile I found that:

- If You hover over the edge of the hyperlink area it will work good, but any other place closer to the center will cover the text

- You can hover the hyperlink area before the link appears and You will see the blocking rectangle

Alyssa Gomez

Hi David!

Are you seeing hyperlinked text is covered by the highlight hover color in Storyline 360? If so, is the hyperlink included in a text box with an animation with the "By Paragraph" effect option?

Our team is still monitoring this issue, and you're in the right place to stay up-to-date on any new information we share.

Ashley Terwilliger

Hi Jules,

The issue mentioned here of hyperlinked text being covered by a highlight when included in a text box with an animation and effect option of "By Paragraph". That's a fairly limited scope on the issue, but it's with our team for further investigation. We'll keep you posted here once we have more details to share!