Hyperlink hover color blocking text?

I was wondering if someone could help me with a strange thing that keeps happening with my courses.

I have been converting some older Storyline 2 courses over to Storyline 360 so we can publish them for Edge users, and other than a few formatting problems I have been able to catch and fix I am having a strange thing happen with my hyperlink text.

Whenever the mouse hovers over the hyperlink text, the background color I've set for the theme sometimes appears in front of the text instead of behind it. But it only happens sporadically and seems completely random. 

I know there is a workaround to use a hotspot to jump to the url, but I am hoping someone here would know a fix that I might be overlooking.

I attached two images to show the hover working correctly on one link, but not on the other. Both are set to the same trigger and within the same text box. This is happening in Review and preview mode both with Chrome and FireFox.

I have been following the topic https://community.articulate.com/discussions/articulate-storyline/hyperlink-hover-background-is-making-hyperlink-text-unreadable but since this is different than just changing the color I figured I would ask.

Any ideas?

36 Replies
Alison Coops

My 2 cents - almost all of my text is animated in by paragraph. The only
piece that isn't that common for me is that one of those "paragraphs" is a
hyperlink. For me it worked to just convert those to separate text boxes,
but it was extra work to figure out what the problem was and then work
around it.

Jules Griggs

Hi Ashely, thanks for replying.  Yes, it is essentially a limited scope issue which means animation by paragraph is useless if you want more than one hyperlink on your page, but also - the issue has been known for almost 1.5 years.  We recently upgraded to SL3 from SL2 and honestly had I known this was an issue (as well as this issue) - https://community.articulate.com/discussions/articulate-storyline/firefox-issue-with-jump-to-url-file-on-last-slide-of-course#reply-607420 we would not have done so.  I blame us for not adequately testing SL3 before we pulled the trigger.

My suggestion is that all the limited known bugs be listed on the SL3 page so users can make a decision if it is a show stopper.  For us, IT IS!.  

Thanks.

Vincent Scoma

Hey Everyone!

I have some good news!

We just launched the newest version of Storyline 360 (3.31.19951.0) this morning, which fixed the issue you saw when a text box has an animation with the effect option of "By Paragraph." You can review more information on our latest update here: Storyline 360 Version History

The next step is to update Storyline 360 by heading to your Articulate 360 desktop app and clicking "Update" next to Storyline 360.

As always, we are happy to answer any questions you have by posting in this discussion or you can contact our Support Engineers directly.

Eric Allen

I'd like to point out 2 things from the update from my testing.

 

1)  The issue with the blocked out hyperlinks is FIXED!  Thank you!

2)  There is one caveat that I've noticed with this fix.   Links are no longer hoverable or clickable until after a slide has finished playing, or reaches the end of the timeline.   While I don't personally hate this feature, I can see requests for this to not be the case coming my way.

My question is, was this by design, and the out-of-box feature, so to speak?   The trade-off for correcting the text blocking issue?