Issue with a TIN CAN file running in Google Chrome

I created a course in Litmos and added a module that contains a Tin Can file created with Storyline; when I run the Tin Can file with Internet Explorer in my laptop and with the Articulate Player in the iPad it works fine, but when I run it with Google Chrome in my laptop, it freezes.

I contacted the Litmos representatives, and they said they tested the file in Scorm Cloud where it showed the file was "UNKNOWN". However, I tested the file myself and it says "COMPLETE/PASS". For this reason, they told me this might be an issue of Storyline with Google Chrome.

Has anyone encountered this issue? ...Please help me!!!

Gonzalo

9 Replies
Christine Hendrickson

Hi Gonzalo,

Just curious - the course that you tested in SCORM Cloud, did you upload your project to test, or did you use the same project that the LMS team uploaded? Just trying to see if there's a reason why they'd see a different result on their end. 

Are you able to share the .STORY file here? I'd be happy to take a look at this on my end as well. Though I cannot test the from your LMS at this point, I can test in SCORM Cloud and a collection of browsers to see if there's any variation in results. 

If the file's too large, or if you want to keep it private, you're welcome to submit it through this form. If you'd like me to personally test the file, please mention my name in the case description. 

Also, please let me know what version of Google Chrome and Internet Explorer you've used for testing. 

Thank you!

Gonzalo Fernandez de Lara

Hi Christine:

I uploaded my Project to test.

I submitted the .STORY file through the form, because it's too large. I mentioned your name in the case description.

The presentation is in Spanish.

Versions:

Google Chrome: Versión 34.0.1847.116 m

Internet Explorer: Versión 11.0.9600.16659

Thank you very much!

Christine Hendrickson

Hi Gonzalo,

Thank you very much for submitting your project file through our support case system. The case (00396557 for my reference) was successfully assigned to me and I have access to the project file. 

I published your course, using the LMS and Tin Can options. I then uploaded the project to SCORM Cloud, without any modifications to the course.

I tested using version 34.0.1847.116 m of Chrome. 

I viewed the entire course successfully, including all audio/slides and videos in Chrome. I didn't pass the quiz, but I the "complete" score successfully tracked in SCORM Cloud.

Can you let me know if it freezes at a specific point in the course, or if it doesn't load at all for you, please? 

Here's the version I uploaded to SCORM Cloud:

Testing for Gonzalo

*Please let me know if you'd like me to remove this link after you've finished testing.*

If that version runs properly for you, we may need to see if it's an issue with publishing.

Can you tell me which version of Storyline you're currently using to publish? To find this information click on Help > About Articulate Storyline

Thank you!

Gonzalo Fernandez de Lara

Christine:

The Storyline version that I'm currently using to publish is: Update 5: 1401.2415.

The version that you uploaded to SCORM CLOUD works successfully in my laptop with Chrome and Internet Explorer .

The Tin Can file freezes when I run it in Litmos using Chrome; I can give you access to the course in Litmos so you can see when it happens.

Thank you,
Gonzalo
Christine Hendrickson

Hi Gonzalo,

Excellent, thank you very much for the update. If it's loading properly for you, I suggest sharing this information with the LMS. It may be specific to their servers. I realize that they've already tested in SCORM Cloud, but if they can see that it functions for you when uploaded, that may prompt them to look a little closer at the issue. 

In the meantime, I'd be happy to test the content through the LMS. If you'd like to send the details to me privately, just let me know. I can send you an email through the support case that was submitted earlier, or you can send me the details in a private message here on the forums. 

Thank you!

Scott Schmeer

I'd be very interested in knowing if there was any additional resolution to this issue. We are having the exact same problem. Any course published for Tin Can from Storyline and posted to the Litmos LMS - crashes the Chrome browser. It works fine with everything else. Litmos also told us that it appears to be a Google Chrome problem. I don't know if I believe that...

Christine Hendrickson

Hi Scott,

I was able to test Gonzalo's content through his LMS and through Google Chrome. 

I successfully completed the course in Google Chrome Version 34.0.1847.131 m and didn't experience any crashing. However, I haven't heard back from Gonzalo at this point to confirm I tested the correct course. There were multiple courses, but I believe I tested the one that was experiencing the issues on his end. 

Can you tell us what version of Chrome you're using? What other steps have you taken to test this (clearing browser cache, etc.)? What exactly happens when you test in Chrome (error messages, crashing, crashing at a specific slide/point, etc.)? 

Also, does this happen for one specific course created in Storyline, or any course you upload to the LMS and test in Chrome?

In addition, if you haven't already, please test your course in SCORM Cloud. Let us know if you experience the same issues while testing your content on this server, outside of the LMS.

Thanks!

Scott Schmeer

Hi Christine,

We are using the same version of Chrome  (34.0.1847.131 m).

We have tried multiple courses and they all crash Chrome... so the problem isn't specific to one particular course. I just tried running one of the courses through SCORM Cloud and it worked perfectly in Chrome (no crashing and it recorded completion). We are not experiencing the crash issue outside of our LMS (Litmos).

When a Tin Can published course launches from the Litmos LMS it opens in a new window (which is what we want to have happen). As soon as that happens, the window/tab which launched the course (the one behind the course window) becomes unresponsive. You can go through the entire course just fine and even close the course window ... but the "launching" window is always unresponsive. Chrome's standard "Page(s) Unresponsive" dialog will pop up saying "The following page(s) have become unresponsive. You can wait for them to become responsive or kill them." At which point the page has to be "killed". When the user logs back in to Litmos the LMS reports that the course is "In Progress" - even if the user actually completed it.

We talked to Litmos tech support. They are seeing the same behavior but at this point are suggesting that it is a Chrome issue.

Ashley Terwilliger

Hi Scott,

Thanks for the additional information and I'm sorry to hear that you're still having difficulty with it. I'd suggest you share the results of your test at SCORM Cloud with your Litmos team - as if it worked there in Chrome, it's not a Chrome specific issue, but how Litmos works with Chrome. 

Also, you may want to test if you publish using another method (Scorm 1.2 or Scorm 2004) if the same behavior occurs at Litmos. I'm not certain if you mentioned needing Tin Can for the purposes of using the mobile player or that's what Litmos said is supported.