29 Replies
Christine Hendrickson

Welcome to E-Learning Heroes, Andrea!

For the background fill, you'll want to actually adjust the option for the "Label Fill". Looks like you may have used text highlighting for your marker.

First, select the marker and click on the "Format" tab. Look in the section "Label Styles" and adjust the option for "Label Fill".

It should look something like this:

Let me know if you have any trouble with this, or any questions.

Thanks!

Andrea Hazell

Hi Guys,

thanks so much for your prompt replies.  This problem occurs while editing and while displaying.  I have played with the "label fill" option and it only changes the colour behind the text.  for instance, in the below example, I changed the label fill to red.  You can see that the background is red while the text is still black

Anything you could add would be greatly appreciated....

Jeff Clay

Just found the answer to my own problem! The background color is there due to the default text box. Simple fix: Create a new text box, give it a white fill, no fill or whatever you want your default text box (and marker text box) to be. The next marker you create will have that same default style and at that point you can tell it to make all markers look the same.

Søren Kastholm

Hi Ashley

Thanks for your answer.

My concern is how to change the text backgroundcolor of an already existing marker. I have tried to use the format painter,but I cannot get it to work. So far my only option is to create new markers.

I have included my test file. Are youable to change the text background color on these markers?

Best regards

Søren

Ashley Terwilliger-Pollard

Hi Søren,

Thanks for sharing this file - I took a further look, and it seems that once you set a "default" text box with a color, that color is applied to new marker text boxes, but not previously added ones and there isn't a way to change them. I'll be sharing this with our Quality Assurance team for further review, although I don't have a time frame to offer in regards to a fix so please continue to utilize the workaround of creating new markers once you've set the default text box fill. 

Ashley Terwilliger-Pollard

Hi Søren,

I heard back from our QA team reqarding this question, and they shared that it is by design as it's using the default text box fill even on the markers. Since the markers use text boxes it will use the default selected for the "text box". If you'd like to see a different behavior in future versions of Storyline, please feel free to share your thoughts here in the form of a feature request. Thanks! 

Alice May Flather

Hi All,

I was having the same issue and I incorporated your suggestions and it seems to have fixed the problem, but only half way in my case. In the image here, you can see the outline of the "ghost" textbox with no fill and no border and my marker with the title bar showing up just fine, but the body text of the marker still with the weird background fill. Any other suggestions that I may try? Thanks!

Alice May Flather

Hmmm... My main issue is just that I can't understand why the main text body field in the marker is a lighter color than the marker header? I want it all to be the same color like what is shown here: http://www.articulate.com/support/contact/screencast.php?screencastid=7a0f86391a0d45a5b3d4e852383b17c2

What is strange is that I have never had this issue before. I have been able to work with markers effortlessly in many previous projects, so I must be missing something here.

Thanks!

Ashley Terwilliger-Pollard

Hi Alice May,

Thanks for sharing the screencast, and I see that you are also working on this in a case with Jayem. Were you able to follow the additional steps he shared (I've copied below):

By any chance you have set a default text box in your project? I ran some test and found that it might be possible to reproduce the issue if you have set a default text box with a background fill. This is happening because the marker uses a text box in it. Whatever the assigned default text box is, it will follow. Here's a screencast of my test:

http://www.articulate.com/support/contact/screencast.php?screencastid=a997b02ee3ae4cbcbb585eca3c680b90

I suggest that you try the following steps on your end to see if this will resolve the issue:

1. Create a new text box and type it some text
2. Right click on the text box and select Format Shape
3. Click the Fill tab
4. Select No Fill
5. Click OK
6. Right-click on the text box again and select Set as Default Text Box

Please test this out by inserting a new marker. If this works, please recreate your existing markers as they will not be changed by this.

As he mentions, if you changed the default text box fill, and the marker has a text box that could be causing the issue you're seeing. Can you try to follow his steps on a new marker, and I'd also say in a new file first to confirm?

Alice May Flather

I did try the steps Jayem outlined in the screencast step by step, but didn't get the same results. I sent Jayem my project to look at (Attached). You can look at slide 2.4 so that you can see my "Ghost TextBox" that was made default as well as my marker that I created after Imade the text box default. I tried creating a marker in a fresh new storylineproject and it seems to be working fine there. SO, this makes me think thatthere is something funky going on with this specific file. I wonder if it hassomething to do with my Slide Master?

I know there is fix to this somehow! LOL

Ashley Terwilliger-Pollard

Hi Alice,

Yes, based on your description and file - if you made a default text box fill, that would also be applied to the marker. Since a new marker doesn't exhibit the same behavior either in a new file or when I add a marker to this file, I suspect it's specific to this file on your set up as well.

You'll want to check that you're following along with these guidelines for creating and working on your .story files:

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior.
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.
James Ignacio

I've been getting a similar result to the folks above. I followed the "fix" by changing the default setting for the text box and that addresses the marker title, but didn't fix the marker text section.

I'm also following the guidelines mentioned above by Ashely.

Any additional thoughts?

Kathy Lee

And, as soon as I posted this message, I had a brain wave:

The reason Search has a gray background is because I changed the colour of the textbox in the "Master title style" of the Master slide.

Once I made the Master title style "no fill", my problem is gone. I guess that is what others meant by "making a textbox default."

Sometimes, it just takes posting the question to solve the problem. And, now I realized I read only the first page of the comments and would've seen Jame's solution had I gone to page 3.