Missing story.html file when publishing to the web

Hello,

I am looking at this several different ways, but when I go to publish to the web I do not get the file: "story.html". I don't know if there are settings I am missing but I have tried a couple of different times. 

I am using WINDOWS 8 using Parallel on a MAC PRO (running Mavericks). All of the other machine functionality is just fine. 

Thank you for your help.

Regards,

Cort

17 Replies
Kristi Riley

I am having the exact same issue, and am also running Parallels on my Mac. I'm running Windows 7, but recently upgraded the Mac to Yosemite. Did you ever figure it out?

By the way, do you have any YouTube video's embedded in your project, perchance? I can publish courses that do not included embedded videos, but the one course that does, will not publish properly. 

Ashley Terwilliger

Hi Kristi,

This thread is a bit older, so I'm not certain what occurred for Cort. Are you publishing for web or another way? 

You mentioned you're having difficulty publishing in general, and I wanted to share a reminder about the best practices for working on a Mac, in addition to ensuring you're publishing following the general file name, path, location guidelines here. 

Brian Washburn

Hello all -

I know this is an old thread... but why start a new one? I'm using Storyline (1, not 2) on Windows 8 (a PC, not a Mac) but can't seem to get the story.html file when I try to publish. Never had this problem before... wondering if I missed an update or pressed the wrong button at some point?

Below is what I'm getting in the Output file... seems like everything BUT a story.html file. Any suggestions?

Brian

Ashley Terwilliger

Hi Brian,

Yes, you should have a story.html file - but I'm curious where you've set the publish location? It looks like those are  not locally stored files, perhaps in Dropbox or Google drive? You'll want to confirm you publish locally and then if you need ot upload the files there be sure to take the entire output folder. 

Also, we're currently on Update 10 of Storyline 1. So you can check which update you're using by going to the Help tab -> About Articulate Storyline. You'll be able to download the latest update here. 

Please let us know if you need anything else. 

Brian Washburn

Hi Ashley - thanks for your response. I've downloaded the most recent update (1) and I'm still not seeing the Story.html file.

Sorry for the previous screen shot. I published to my local drive (that was a screen shot from Google Drive, where I had uploaded it because I wanted to share the module). Attached is a shot of my local drive.

Any thoughts on what I might be doing wrong? I've taken out all special characters from the title, so it doesn't look like that's the issue. Not sure what else I'm missing.

Ashley Terwilliger

Hi Brian,

Thanks for doing the update - looking at this new image, I think it is there, you're just not seeing the file extensions for any of them. Look at the the 5th item down just listed as "story" - it says it's an HTML document in the type section. Have you tried opening that one? What happens when you try to place your published content on a web server? You could use one of the options mentioned here. 

Brian Washburn

Hmmm. Yep, that looks like it's it.

My ultimate goal for this whole thing is to post it on Google Drive so others can view the project. I'm using Mike Taylor's old instructions (found here: https://community.articulate.com/articles/how-to-share-your-e-learning-course-for-free-with-google-drive) which have always worked for me in the past... but it's not working on this one.

Not sure what I'm doing wrong. I thought it was because I couldn't find a file labelled story.html (in order to change the name to index.html), but maybe that's not the problem.

Brian Washburn

Per Mike's post, I created a link that begins with: http://googledrive.com/host/ and then I add everything after "folders" from the output file I've uploaded to Google Drive, so this is the link I created: http://googledrive.com/host/0By6nhY12Tfy_eFFEd3VBN3ZoaU0

And then when I put that in and hit enter, this is the URL that pops up in my browser (Chrome): https://4436e8d592f582fcdd3025e10f843c734d30a914.googledrive.com/host/0By6nhY12Tfy_eFFEd3VBN3ZoaU0/

The way Mike described it in the post has always worked for me in the past. I tried replacing the HTML5 file with "index" also (per one of the more recent comments) and that didn't work either. Maybe I did something wrong with the file? Maybe Google changed something?

Beyond Google Drive, have you used/heard of others using something else to put a module up on the web?

Thanks for your help on this, Ashley!

 

Lal Mathews

Had a similar issue. When published to the web, the story.html did get created, however, it didn't open and resulted in Page cannot be displayed. 
The same error happened when published to LMS. 

Not sure, if this is a solution - Restarting the system resolved the problem and it published correctly. Hope it helps someone stuck in that cycle - story.html not found.