Right-click trigger not working in published Story,

I use right-click in my software simulations. When I test it in preview mode it works correctly. When the Story is published  the right-click option doesn't  always work. I can't see  any real pattern in when it works and when it doesn't.

Is there some combination of Flash/Browser that is required or some publishing settings for the right-click trigger to work reliably?

58 Replies
Mark Vause

I have right-click triggers within my story, as I am writing software training.
The right-click seems unreliable.

if I preview a project - right-click works

If I publish it to my PC (desktop) right-click works.

If I copy the published project on to a network folder, or USB stick or another PC's desktop right-click doesn't work.

I have tried to attache a test project that I have been using to try and see why this doesn't work. This doesn;t ;t seemt to uplaod from here either - itjust hangs the browser. Can I e-mailit someone
(The upload option for the project on the submission form doesn't seem available either . what is supposed to happen when i click Upload?. There is not much point in doing a screen cast as there is nothing to see)

Thanks for your help

Peter Anderson

Thanks for the additional info, Mark. It sounds like the issue only occurs when working away from your local drive. When creating, editing, or publishing a Storyline project, be sure you're working from your local hard drive (typically your C: drive). Working from a network drive or a USB drive can cause erratic behavior, such as file corruption, an inability to save changes you've made to your project, and loss of resources amongst other things. This article has more information.

If you''d still like to send us the file for us to try and replicate the behavior, the best way to do that would be through this link. You may need to disable pop-up blockers to ensure the upload goes through properly. Thanks!

Laura Robinson

Hi, has anyone found a solution to this one yet?  I've also got a module that will not recognise the right-click interaction once published.  It's also on a simulator section.  It works fine in preview mode.  When I view the published story.html it actually produces a browser error that says:

"Object doesn't support this property or method

story.js"

I've been working on my local drive so that rules out the non-local drive issue - the error is still happening in spite of this.

I've used SCORM 1.2 to publish.

Thanks,

Laura

Carlos Rubinstein

I'm trying to do something similar, but the published version always gives the Flash pop-up menu when I right-click; is there a way to disable the flash pop-up menu from within Storyline, or with a parameter in the html container that calls story.swf?

Thanks,

Carlos

P.S. I'm not doing software sim, I'm trying to create an ILT component that can be controlled via a PPT remote.

Linda Miller

Still waiting to see a solution to this. In my simulation the right click brings up the flash menu. This is true when it's published and hosted on the server I'll be using, not when I use preview or run it locally.

I'm wondering since this is a known issue if there is a fix in the works and what the timeline might be.

Tomer Rotem

I also have this problem and for now to get around it i show an image of a mouse with the right click marked.

I make the right click of this mouse (the image) a hot spot and ask the learner to click on it...

Not such a direct solution to the problem but mostly a nice way to by-passs this issue.

Tomer Rotem

Hi,

I discovered something very interesting.

Right click advance will work in all browsers only after you will upload the file to remote host or to an LMS.

Otherwise there is a problem when the flash plug while it is relating to your local machine as a remote internet location.

I know how to solve this issue in explorer and it also solves issues such as engage interactions that are not presented.

have not figured this out yet how to enable the right click in local host using  chrom and FF but when i will i will update the forum.

Kim Bard

Sure.  The module is created on my C drive and the published version works perfectly with the right click functionality.  The problem is occuring when t is published and placed on a SharePoint site for review (before it's uploade to LMS).  I'm using a trigger hot spot for the user to right click to advance to the next slide and it does not work.

Ryan Moscoe

I am having a similar, though not identical, issue with right-clicking in a software simulation. Right-clicking the hotspot works in Preview mode, but when I publish for Web, nothing happens when the user right-clicks. The Flash menu doesn't even come up. I have tried publishing for HTML 5, but the results are the same. I tried publishing to my local hard drive and to a shared network drive, but I can't even open the file from my hard drive. We do not yet have an LMS, but I tried publishing for LMS anyway, just to see what would happen, and the results were the same.

Ashley Terwilliger

Hi Ryan,

When your testing the publish for Web version, are you testing on your local drive? If so, you'll want to upload to a web server to properly test and there are a few free ones you could use in this article.  

If you're still having difficulty, are you able to share your .story file with us? You're also welcome to share it as a part of a Support case as Leslie mentioned.