script error on SL application launch

I just purchased Storyline today I had this issue with the trail version but I ignored it since it didn't seem to affect the app functionality. I was hoping that once I purchased and activated it would go away. It didn't and I was wondering if anyone else has experienced this issue.

When I launch the SL application I get this script error (see attached). 

Thanks,

Mark

58 Replies
Peter Anderson

Really sorry to hear about the trouble, Jon. First, please make sure that your project files are located on your local hard drive (typically your C: drive). Working on a network drive or a USB drive can cause erratic behavior.

If Storyline continues to perform erratically on your local hard drive, a simple repair may resolve the issue.

If you're still experiencing the issue, please follow the incremental steps outlined here

Let us know if it helps. Thanks, Jon!

Jon Fish

Did all that... everything (Storyline program and project files) is on my C: drive, always. Running Windows 7 Ultimate 64-bit.

Uninstalled Storyline. Made sure that .NET 3.5.1 was enabled. Uninstalled Flash according to the instructions. Installed current Flash (same as I had before, but whatever). Restarted. Re-installed Storyline Update 2. Restarted. Same issue. Script errors (two popup windows) on startup, and then no online content for "Learning Storyline" or "Free downloads and templates"... so I guess I'm not getting the same product everyone else is getting in terms of templates, learning support, etc.

I don't know that this is an "erratic behavior" ... instead it seems it is a problem with the way you are implementing web content/feeds within the Storyline application. It was working before Update 2, but now it is not. So something in Update 2 "broke".

Jon Fish

So the script error is reported for the following URL:

http://articulate.storyline.s3.amazonaws.com/startpage/1.0.12/en/startpage.html

When I paste that into my MS Internet Explorer 9 (9.0.8112.16421) address bar, I get the same, failed load... a blank content tab for "Learning Storyline" and a blank content tab for "Free downloads and templates".

When I paste the same URL into (the most current versions of) Firefox, Chrome or Safari, I get the two tabs with the content you would expect to be there.

So is it an IE9 setting I need to change? Because clearly it is not "erratic hard drive behavior"... it's a problem with IE9.

Adam Ocho

Hi Jon, I've so far been unable to reproduce the problem you're seeing using the same version of WIndows and the same build of IE.

Could you please try the following links in IE 9 and let us know what sort of errors or warnings you see for each? Screen shots or screencast is fine too.

If you see a "Only secure content is displayed" message, please click "Show all content".

https://dl.dropbox.com/u/120667556/Storyline/1.html

https://dl.dropbox.com/u/120667556/Storyline/2.html

https://dl.dropbox.com/u/120667556/Storyline/3.html

https://dl.dropbox.com/u/120667556/Storyline/4.html

https://dl.dropbox.com/u/120667556/Storyline/5.html

Thanks for helping us track down this bug.

Jon Fish

Adam, 1-4 didn't work. Here's a screenshot of that result... basically, just the two tabs, empty.

#5 worked... to a point... each of the two tabs had thumbnails of videos, etc. Clicking on the thumbnails brought up pages that didn't load much beyond background colors. But maybe that was okay, for the purposes of your test...

Hope that helps.

Jon Fish

It worked for me, but it took some trial and error...

Here's what worked for me:

  • Launch Storyline
  • Let the two error messages appear, clicking Yes or No to them (either one, it doesn't matter).
  • THEN, use F5 (with today's keyboards, make sure that Function Lock is on or hold down the key that makes your function keys function as function keys while pressing the F5 key)

... and that works.

Clearing the cache in IE by itself (before and/or separate from Storyline) didn't seem to affect/solve the Storyline problem. I needed to use F5 after the script error messages appear.

Thanks, Adam!