Storyline 360 - Drag and Drop Issue

I have recently upgraded to Storyline 360 and have just encountered my first issue. I have set up a drag and drop screen with and 2 drop zones and ~13 drag items. When you drag an item onto the correct zone it gets stuck to the cursor and does not drop properly.

I have played around with revealing items one at a time and letting items drop on incorrect drop zones, but to no avail.

I know it is still new but still any help would be appreciated.

73 Replies
Veronica Budnikas

Hi Tom,

I've had a look at your file and while I have no idea why that is happening or how to fix it, the good news is that I published it and tested it then (I published to to be quick) and it worked just fine. 

Perhaps submit a support case to Articulate about it, but it seems to only happen in Preview mode. 

Have you tested after publishing?

Alyssa Gomez

Hi there Tom, thanks for sending over your file! I was able to see the behavior you described. I did some testing, and it seems like there was some erratic behavior associated with the drag text boxes. I deleted those, and replaced them with two new 'test' text boxes, and the interaction works as expected. I attached the updated file here so you can test it, as well. You may need to delete the drag text boxes on that slide and rebuild them. If you'd like to have one of our Support Engineers do some further investigation, you can reach out to them directly here. If you do decide to go that route, please share your case number here so I can follow along. 

Michele Arrieta

I was able to resolve a similar issue by re-building my drag and drop completely from scratch. I re-inserted all my icons and built the drag and drop slide from scratch (don't copy/paste anything from the existing knowledge check with the bug).

In my case, I had built a module in Storyline 2, converted it to 360 (for reasons too long to describe here). Once it was converted to 360, my drag and drop interaction did not function properly when viewing the story_HTML5.html version. When I click to drag an icon to a drop target, it would stick to my mouse until I clicked again to keep it in the drop target. 

Alyssa Gomez

Hey folks,

We've found a problem with Storyline 360 Freeform Drag and Drop interactions in HTML5. Specifically, drag items do not drop or "stick" to the target when you release the mouse. This happens when you set Shuffle to Answers and Snap dropped items to drop target to Tile.

We're working hard to find a fix, and in the meantime, try these workarounds:

  1. In the Drag & Drop options, set the Snap dropped items to drop target to Free.

  2. Disable answer shuffling

We'll be sure to let you know once we have an update on this issue!

 

Intist Sro

New guy here! Had the same issue after conversion from SL2 to SL3. The problem is caused by Storyline's "Markers" (i.e. checkmark, x's, etc) when used in the States (for correct/incorrect drops). It works once these markers are deleted or swapped with something else like text or png images (of checkmark, x's). Thanks.

Ashley Terwilliger

Hi Intist,

I know our team is investigating some changes to the drag and drop behavior of Storyline 360 when upgrading files, but I wanted to test out your idea. You mentioned markers and I wanted to see if you meant Storyline's markers or items you inserted as a shape/icon

If you have a copy of the .story file that you created in SL2 could you share that so that I could try upgrading it to see how it behaves and what settings you've included? 

Intist Sro
Ashley Terwilliger

... I wanted to see if you meant Storyline's markers or items you inserted as a shape/icon

Actually, it is both 'storyline's markers' (i.e. the prebuilt thingy with the text bubble) or any 'grouped' shapes that are causing the issues. A shape on it's own (not grouped) works fine; png files work also. It's not a huge problem for me as long as there's a workaround.

I've attached 3 slides in SL3: 1 works; and 2 that doesn't work (markers and grouped shapes). See the States. Thanks.

Crystal Horn

Hi, Intist. I had actually just looked at your file!  Ashley is off the hook.  😉

During Preview and in HTML5 output, I see how those states are not appearing as expected when dropping the item. In fact, once the item has been dropped, it's behaving very strangely and not even attached to the cursor when I try to move it again.

In the Flash output, the states appear as expected, but trying to move the objects again makes them behave a little strangely.

We didn't have this behavior documented, so thanks for pointing it out. I'll get a report started for our QA folks.

In the meantime, can you ungroup the shapes? Using ungrouped shapes worked both in Flash and HTML5 output. As for using markers, were you looking to include the functionality of the marker in that state (title and text box, media, animation)?

Elissa Mathurin

Hi Crystal,

 

I put in a case to Justin on this issue.  Using Instist recommendation, I got rid of any symbols in my presentation and I changed the output to Flash and HTML5 output instead of HTML5 and Flash and my drag and drops now work.  In fact I build the D&Ds two different ways and they both work.

Happy now,

Elissa