4 Replies
Dave Cox

What version of Storyline are you using? 

Storyline 360 can only do this when you are set to use the Classic Player. When you select Publish check your publish Format:

Do change this to HTML 5 only, click on the text HTML5 with Flash fallback. From here, you can move the slider to HTML5 to only publish to HTML5.

Or you can just switch to the new Modern player. To switch to the new player, click Player from the Publish panel:

Then select the Modern Player Style from the drop-down.

With the Modern Player, the only option is HTML5.

Dave

Mark Lentz

I'd like to report the same issue.  Today I created this file using the Modern player, it publishes as normal (HTML5). 

Then I changed it to the Classic player, and while using Web Output, it says "HTML5 Only", as yours does, Dave, but it nevertheless outputs the whole set of .swfs and _flash.html files.  And then it will not play correct on iOS even when I point to story.html.

If I go back to the Modern Player, it is OK again, but I want to use the Classic player in this case.

My Storyline 360 is the most up-to-date version.

Dave Cox

Hi Mark,

I'm using the latest version as well, so I just tested this to see how it responds on my system. If I select HTML5, I only see the HTML5 files. If I select HTML5/Flash I see both sets of files, You must select Articulate Mobile Player for iOS and Android when you make this selection.

I suggest that you check these boxes and then reselect HTML5 only. The checkboxes become disabled, but will remain checked. Then publish again and check to see if it will play in you mobile player. Maybe that will fix your issue.

Dave

 

Mark Lentz

Dave, you are a genius, and fixed my problem.

There's one thing I didn't mention about it:  when I tried to publish this file, I only had the option to pubish in HTML5; if I clicked on the Format, I got the message: "This project has the following features, which are only supported in HTML5 output: Jump-to-Time Trigger".  It prevented me from seeing the other options at all.

I deleted the two triggers referred to, and that allowed me to see the other options.  I clicked the two boxes (which were not clicked before).  I re-published.

Then I put the triggers back in.  I get the same message described above, but it no longer publishes the extraneous flash content.  I think somehow the exact order in which I did things in creating the file caused this quirky issue.

Thanks again!  Mark