Swipe Next on 360 Android issues

Hi all,

 

I have a couple of issues, that are related to each other. Firstly I want a swipe next feature but need to restrict the user from skipping the slides I need them to view before continuing. Normally a "restricted menu" would fix this, but the swipe feature seems to be disabled when I do this.

So to get around it I have put in a "free menu" system, disabling the menu in the top and putting an error message if they try to swipe to the next slide without viewing the entire slide. When the slide finishes, a variable is set to True and they can move on.

My issue comes with any interaction I have on the screen. When I "click on button" to view content, the layer I want is triggered but also the layer with the error message. It is basically registering a swipe when I'm simply touching the screen. There seems to be a finger lag and throwing out my error message when I don't want it.

Anyone think of a workaround for this? I would suggest that a new feature of the swipe is to have it enabled for restricted navigation. I would be ideal if the swipe feature was separated from the next button click, so we can determine where and when we want the user to swipe.

Thanks in advance for any and all suggestions/comments!

 

6 Replies
Ashley Terwilliger

Hi Ros,

The swipe next does not work with restricted navigation in Storyline 3 or 360 - and our team is looking into this. This is across all swipe enabled devices.

As for the click behavior causing an error message - could you share an example within your .story file so that we could take a look at the set up and triggers? Also what version of Android OS are you using? Do you see the same error message on Apple devices?

Ian Pow

I have a similar issue. only 7 slides including 3 quiz slides. After the intro I want the user to swipe to get to the next slide which will be a quiz slide but it just has a "loading" animation on it. Tried on our own LMs, Scorm cloud and with Opera and Chrome (on Android). Same issue each time. Published to LMS with Articluate 360. I even added in an arrow icon which should also trigger "next slide" but still when the next slide should appear it is just showing the loading animation. No heavy content in the slide (video, photos, audio). Can you help? I am testing with Android 7.1.1 Chrome 61.0.3163.98 All worked fine on desktop with the LMS, scorm cloud and when published to web. 

Ashley Terwilliger

Hi Ian,

This is a bit different as the issue mentioned earlier is specific to restricted navigation. I checked your file, and it seems that you've run into a possible software bug where a course  with a quiz timer hangs on mobile devices when all the elements in the Player are hidden after advancing to the second slide. This is something we've recently reported to our team, so I'll include this discussion as a part of that report.

In the meantime, you can see that it will work normally if you enable any player elements as I did in this example.  I tested that on iPhone 6S with iOS 10.3 running in Safari. 

You could also remove the Quiz timer and keep the player elements as you have set up. I published another example with that here.

I'll keep you posted here once I have any more information on this bug, and I'm sorry it's caused you trouble. 

Leslie McKerchie

Hey Ros :)

Great news! We just released another update for Articulate 360, and included a few important fixes and new features that you'll see in the release notes here

The Storyline 360 item you'll be interested in is how:

Learners couldn't swipe between slides in HTML5 output when navigation was restricted.

Just launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Please let us know if you have any questions, either right here or by reaching out to our Support Engineers directly.

Richard DiNobile

Hi Asheley,

I am wondering if there is a workardoun for my issue:

I am hiding my forward button until learners review all menu items on one screen and unhiding the forward button once all buttons have been visited. When testing on mobile the swipe next feature is not following those restrictions as I beileve it is independent from the buttons themselves. However, there is no way to add a trigger to disable swipe next feature without physically diasbling it within the slide properties. Is there another way I can make this happen.  Also, is the swipe issue on mobile which was posted a while ago still an issue - see this link!

https://community.articulate.com/discussions/articulate-storyline/cannot-disable-swipe

Thanks in advance for your reply.

Lauren Connelly

Hi Richard!

I'm happy to step in and help! We have logged this as a bug where swiping next can't be disabled like the next navigation button can be set to disabled. This is a bug that our team is investigating, but we haven't added it to our roadmap. I'll add your comments to our current report! 

I'd love for our Support Engineers to take a look at the file and see if there is a workaround! Would you mind sharing the file with our team? Here's a private upload link.