TinCan Output

I am testing a storyline 2 project in a tincan/xAPI enabled website.  I am using LearnDash/grassblade/WaxLRS as the xAPI stack.  Captivate 8 tincan output works fine in this setting.

I have set the version in grassblade to TinCan 1.0. Initially when I published the piece and set the launch URL to story.html, the launcher said it lacked the correct configuration information. When I set the launch path to end in story_html5.html, it launched fine. 

I would be glad to send in the file, which is a simple 4 question quiz.  If that would help troubleshoot.

-Marc Lee

marc@mlmultimedia.com

7 Replies
Marc Lee

Thanks for your suggestion, Ashley...

I uploaded the file to SCORM cloud and got the same result as with WAX LRS.
First it couldn't find the url. When I changed the url to something it could
find, it merely put up a file list rather than launching the course. When I
clicked on story.html, it said it lacked configuration data, and when I
clicked on story

Marc Lee

Ashley,

Thanks for the quick response….I did attach it before but it’s attached here again. In this regard, though, I was thinking: this file was originally SL 1.0 and I opened it in 2.0; as I understand it, the old 1.0 file is fully converted to SL 2 in this process – no? Would the LMS/TCAPI output be fully compliant with TinCan 1.0 in this case? Or would it revert to the old SL’s .95 beta level TinCan standard?

Please look at the file but, on my end, I will recreate the quiz from scratch in 2.0 just to see if that makes a difference.

Thanks!

-Marc Lee

Ashley Terwilliger

Hi Marc, 

I didn't see it attached above - and it's not attached now? If you're replying via email with the attachment, those are not posted here to the forums so you'll need to visit this page to upload the files. 

If you've upgraded the course from SL1 to SL2, when you go to publish for LMS with Tin Can enabled it'll publish with the Tin Can 1.0 and no longer refer to the Tin Can 0.9. Let us know if you're able to share the existing .story file here or one you newly created in Storyline 2. If the newly created one does work differently for you, you may want to look at importing your existing course into a new file as described here. 

Marc Lee

The answer turned out to be that opening a previously-SL1 file in SL2, and publishing to TinCanAPI did not work - either in WAXLRS or in the SCORM cloud.  By opening a fresh SL2 file and copying the slides from the updated file, then publishing to TCAPI, it worked fine.

In other words, in this test, an upgraded SL1 file's TCAPI output is not (NOT) the same as the output from a fresh SL2 file.  Can't say if this is always the case but it was in my example file.

I'll be happy to upload both the working and the non-working files if anyone is interested.

Thanks!