93 Replies
Elizabeth Pawlicki

Hi Abby!  I'm sorry to hear you're having this issue!  What browser are you using?  If you're using Internet Explorer, it's not one of the supported browsers for authoring Rise courses.  Check out this article for which browsers are supported for authoring Rise courses on laptop and desktop computers.

Sandy Murray

Good morning.  I'm new at Rise but I'm trying to upload our logo and other pictures.  Each time it says "Please verify the file type is an image and try again".  I'm working in Chrome and the logos/pictures are saved at BMP, PNG, JPG.  Is there something I'm doing wrong?

Emily Troiano

Photos get stuck on Knowledge Check

Hello. I am trying to upload photos from the content library to Knowledge Check (Fill in the blank) problems. It says "Processing..." and never loads. Nor does it usually let me "cancel" either. The little circle just keeps going round and round. It happens on Chrome and Firefox.

Désirée  Jochem

Same here. I'm trying to insert a labeled graphic. It keeps processing and then asks me to check if it's an image I'm trying to upload.
I'm experiencing the same problem with images from the content library, so I don't think my image is at fault here - and since Alan and Annie report report troubles as well, the issue has to be on Rise's side.

I'm on Chrome and wanted to upload a .png.

Allen Northrop

Same problem - trying to upload an image I've used in other courses - running on up-to-date chrome, keeps telling me to try again - also having issues uploading courses to review... gets all the way to the uploading part of the publish process then cancels out.  No internet issues - everything else is working fine... Articulate updates say everything is working fine.

Alyssa Gomez

Hey, everyone! So sorry for the headaches! Yesterday we had problems uploading and viewing images in Rise 360 and Review 360, but that issue is now resolved.

You can subscribe to updates on our Articulate Status page here

And if you're still having trouble with images in Rise 360, please reach out! Our team is standing by to help. 

Lindsay Eichenlaub

Hi all, it looks like this same issue is happening again. I went to the Rise360 updates page and nothing has been reported yet. Been trying to upload png and jpg for a labeled image. They work perfectly fine with other image options. Just the labeled image seems to be broken, which I’m really depending on to complete a course build this week. Please advise.