Images won't upload in Rise

Apr 17, 2018

I am having trouble uploading my own images into Rise. When I try uploading in Blocks it continues to tell me there was an issue and to try again. When I try to upload in the Labeled Graphic, it says it is uploading, but never does. 

93 Replies
David Daoud

Hello, Maybe it's because the global outage on Articulate

"Our cloud hosting provider is experiencing a distributed denial of service attack which is resulting in delays and intermittent errors when accessing Articulate 360 apps,, E-Learning Heroes, and Articulate Online. We're looking into it and will let you know when it's fixed. We're sorry for the trouble!"

"This incident affects: Articulate 360 (Review, Content Library, Content Library Images, Rise, Desktop 360 App Updates, Team Slides, Storyline 360 Text to Speech) and Articulate ID, E-Learning Heroes, Account Management,, Articulate Online, Store, Product Activation, Articulate Blogs, Tempshare."

David Daoud

Last update on this issue on
[RESOLVED] Intermittent DNS Resolution Errors
Between 10:30 AM and 6:30 PM PDT, we experienced intermittent errors with resolution of some AWS DNS names. Beginning at 5:16 PM, a very small number of specific DNS names experienced a higher error rate. These issues have been resolved.

So I guess it should be resolved soon on Articulate side


Annie Louden

Hi Syleste,

I don't know if you're subscribed to Articulate's status updates. If you are, you'll see that Rise and Review go down kinda periodically. I'm not trying to be mean to Articulate; but it's true.

Anyway, even if the status says everything is fine, I run into the problem you described about it saying processing but doing nothing. I just close my browser, wait about 5 minutes, and usually it works again.


Marlies Claeys

I'm having the same problems. I continuously got error messages uploading my pictures in a carrousel. And now it keeps processing if I want to insert a labeled graphic. And it's not the first time... Not really inclined on getting a paid license if this is how it works...

I have even tried different browsers and computers but keep having the same problem over and over again. 

Abigail Truebig

Hi, I'm having the same issue. I've tried Chrome and now Edge and they both say "Please verify the file type is an image and try again." - well I've tried every which way - png, jpg - made the image as large as I could. I uploaded as an Image Centred in a different block and it has uploaded with no issues, but I really wanted the functionality of a Labeled Graphic.

This discussion is closed. You can start a new discussion or contact Articulate Support.