Rise blank screen issue

Hi All,
I have a client who is having an issue when re-visiting a Rise course. It works perfectly and as expected when testing in SCORM cloud.

Oddly the course launches fine but on re-visit they just get a blank screen.

One of the difficulties is that I don’t have any access to the system to see what is happening in real time to further debug.

My only real course of action was to get a bit more system specific details to see if anything here would be an issue, they have come back with the following:

LMS: Kallidus Version 10.1.12
Tested on desktop PC running Windows 7
Browser: IE 11
Pop-Up Blocker: Off

Version of JavaScript: Version 8

This all looks fine and in line with the Rise browser compatibility specs.

Since this runs all fine in SCORM cloud I’m at a bit of a loss as to what the issue could be. Has anyone had any similar issues and any resolutions? Or areas for the client to look into further their side of things?

Thanks

28 Replies
Stuart Marshall

I see this issue when I update the content and replace the scorm files on the LMS. Anyone who has previously launched the content (pre-updated content) is presented with a blank screen when the re-launch the course. Have you made updates to the content in this way?

Also, I know Articulate point people to SCORM cloud for testing content but it is not really a particularly helpful tool as absolutely any scorm content will work on it as it should- regardless of how well put together the SCORM content is. No other LMS offers anything like the flexibility/forgiveness of scorm cloud.

Ashley Terwilliger

Hi Stuart,

I also answered your other post here, and I wanted to share the info for Chris as well.

Have the learners tried to refresh the browser page? It sounds like it may be stuck on the relaunch as it's a new version of the course. 
When you update (overwrite) existing course files in your LMS or web server, learners who previously started the course won't be able to resume where they left off. They should start over at the first slide in the updated course. You'll want to keep this in mind when updating courses that have already been delivered to learners.
Chris Ridley

Thanks for the input, the course hasn’t had any content updates as it still in a prototype phase and hasn’t been rolled out to any learners yet. It's sort of doing what it was intended for – testing to see if the clients LMS will be able to run Rise courses before we go into full production. Unfortunately, it's not the result we were hoping for. 

That being said it’s something I will flag with them to see if they are doing any kind of update on their side of things. 

Ashley Terwilliger

Ah, sounds a bit different than Stuart's issue than.

You mentioned IE11 - how does it behave in any other browsers? I've seen a number of issues with certain LMSs forcing IE11 into compatibility mode, and that will cause issues with Rise being strictly HTML5 output. I would think you'd see that on the first attempt, not just a relaunch but it's worth looking into with your team! There are some additional troubleshooting steps here that may help.

Stephanie EV

Hi everyone,

Was there a solution to this problem? I have the exact same issue with my Rise file. I have updated content and republished for scorm 1.2. I have uploaded the zip to the course and all i get it a blank screen. 

I wanted to see whether the issue lay only within an existing course so i created a new mock course and uploaded the exact same file - it worked perfectly.

I cant erase learner records, etc so what would my solution to this problem be? 

Thank you

Ashley Terwilliger

Hi Stephanie, 

Thanks for reaching out here and starting a case! I saw you were working with Abel as well, and that he was doing some initial testing of your file. I gave him a heads up about this forum discussion too as the Rise courses showing blank or as a black page upon overwriting a previous version in your LMS is something our team is looking into. 

When you overwrite a course it will also overwrite the suspend/resume data for your learner, that is something we'd expect to happen. 

Stephanie EV

Hi Ashley,

Yes I did get a reply from Abel who told me that he was able to succesfully upload the file to an LMS - which I was also able to do. The problem isnt with uploading a scorm file to the LMS. The problem is updating that scorm and re-uploading the file to the same course (overriding old file).

As mentioned, I created a brand new course (and hid the original course) and uploaded the scorm - it worked fine.

So basically the problem lies within updating content,.

Lecky Wintour

I'm having the same problem in Google Chrome - I am trying to update the course content on Rise and now all I see is a blank screen when I try to open up the course. I am not sure what else to do, I have been working on my courses for the last two weeks with no issue but today I can't see anything, I restarted my laptop (MacBook Air) but still the same issue. I also cleared my browsing data. Can anyone please help me as I am really stuck and need to work on updating my courses,
thanks, everyone!

Ashley Terwilliger

Hi Lecky, 

I'm glad to hear you're back up and running, but I'd like to figure out what's going on, as that's not what I'd expect. 

Rise supports the following browsers for authoring on a Mac:

- Google Chrome (latest version)—Best experience
- Safari (latest version)
- Firefox (latest version)

And those same browsers are supported for viewing the output or a Share link on a Mac. You'll see all those noted here, and Internet Explorer is only supported for viewing output in a Windows environment. 

Can you tell me were you editing the course or viewing the output? Also, are you only running into trouble with one course? Can you view my Rise course here? 

Lecky Wintour

Hi Ashley thanks for coming back to me.

Sadly it is not working after I initially thought.

I am in the latest version of Chrome and I am editing an existing Rise - when I try and access my Rise now it is just looping so I can't even try to open any other courses to check if it is just affected by one.

Any help you can offer is really appreciated.

Stephanie EV

I had the same issue back in May and worked with the support team to solve the problem. Asking the learner to clear their cache isnt an acceptable long term solution for me (and doesndt always work). Please find response below from articulate support team back in May:

A few months ago, we introduced a change to Rise that could cause content to lock up and display a blank page if two things were true:

- You had replaced a Rise course inside your LMS with a different Rise course (or even a duplicated copy of your original Rise course), and...
- A learner attempted to resume a course that had been suspended before replacing the course content.

We won't go into too much detail, but the crux of the problem was a suspend_data incompatibility between the two courses, and the result was a lock-up upon resume.

We’ve fixed this problem, and today one of two things will happen:

- If you replace a Rise course inside your LMS with a revised version of the same Rise course, bookmarking will work as expected. Learners can suspend the course before the course is revised, and those same learners can resume the course after the revision.

- If you replace a Rise course inside your LMS with a different Rise course (or even a duplicated copy of your original Rise course), learners will not be able to resume the course where they suspended it before the revision. In this scenario, learners will return to the beginning of the course, but the content should never lock up.