Rise not completing & progress not recorded for 5% of learners

The course has been launched for 6 months now and through one call from a learner and then doing an audit of completions and logs, plus talking to users, I've found some sessions are not being recorded. The biggest clue is we have a discussion forum after the eLearning. So no eLearning completion and a discussion comment is a red flag.

Approx. 5% of learners are doing the eLearning, based on their reports to me and the LMS log. However, when I check by logging in as them, I get a fresh Rise course, as if they have never been there (or they've just opened lesson 1). One learner reports they did the course twice and both times it didn't record. 

It has me beat. I haven't been able to replicate it and I haven't identified any patterns (e.g a certain browser).

I did update the SCORM in the first 2 weeks after the launch with minor changes and I checked that my test user progress data was unaffected. That's the only anomaly I'm aware of.

Any suggestions? I hear SCORM Cloud mentioned as a baseline test, but not sure how that can help with intermittent problems.

43 Replies
Crystal Horn

Hi, Paul. You've done some really great troubleshooting so far, looking for the same indicators that I would.

You mentioned updating the content after it was launched. We don't support resuming content after it's been overwritten with a new version, so handling resume behavior is open to variance in LMS environments. Could affected learners have been in progress during this update?

Another possibility is that the affected learners had connectivity issues that prevented the course from communicating effectively with the LMS. Deciding to work closely with a learner who is having the most problems, you could enable LMS debug mode and collect the resulting log after they reproduce the problem. You can also explore whether they're using a supported browser, or if they have something unique in their environment like a VPN, home network, or other wifi instability.

Keep us posted!

Karl Muller

I have experienced exactly the same thing: for a very small number of users, Rise does not record their progress data or completion status.

While they are in a training session, Rise indicates what they have completed with the check marks and the completion percentage changes. However, when they exit the course and LMS in the correct manner, none of their data is saved. 

Each time they access their course after a previous training session, it is a fresh course showing no previous completion data.

There is no commonality at all between any of these users as they are in different locations/cities and use different devices, operating systems, have good internet connections, etc.

When I log in as them everything works normally. 

These problems are also not related to updating courses that were in progress.

Some learners are very irate when they complete a course several times and no progress data is recorded. What makes things worse that our training is required for government certification purposes.

Paul Tottle

Thanks for the comments Karl and Crystal.

I wished I'd done that Crystal with the person who did the course twice and it reset. We're in different locations around the country, too, making it hard to sit-alongside.

I'll look out for an opportunity to do the LMS debug.

I did check the logs and those people started the course after I did the changes.

Even though Articulate literature shows we can't resume after making changes to the content, we were able to. Our LMS picked where we left off. But I did wonder if I could create some mismatch of identifiers that could in the future not work with updates to the LMS (we haven't had any updates, so far)

Karl Muller

We have worked with our LMS vendor to determine the cause. 

Our LMS is set up to open the Rise courses in a new browser window over the existing LMS window that stays open in the background.

According to the vendor, the only known instances of this happening is when the window that is running the course loses connectivity with the LMS. This typically happens when the learner inadvertently closes the background window containing the LMS while the course is still in progress. So from the learner perspective everything appears to be normal as they are still able to use the course. However, when they choose to Exit the course (we use the Rise Exit link), there is no longer an active session to send the learner data back to the LMS.

We have not been able to verify if this is what has been happening with the users that have had this problem.

As this happens very infrequently to about 0.5% of our users it is thankfully not a widespread problem. For the few that it does happen to it is extremely frustrating.

Paul Tottle

I did sit in with a staff member who had twice been unable to complete the course, using a duplicate of the course. However, it completed okay!

Karl, I tested closing the background tabs containing the browser and this was not a problem. The course tab continues to communicate with the LMS. (I could see using the debug option)

Interestingly, I was able to replicate the problem in the LMS by not enrolling the student and then giving 'Guest' access. In this setup, progress and completion data were not recorded. However, searching back through our LMS logs I could find no evidence that this scenario (not enrolled +guest) occurred.

Team emPower

Hi,

I have a similar issue at hand. Some users of my course too have reported that the course completions are not getting recorded.

My checks say - most of them were using it on a phone. And, instead of closing the course using the 'Exit Course' link, they swiped the window to close the screen. [The exit button is really small to fetch any attention.]

Now, I were thinking of using an exit page after the quiz to solve this issue - however, there's another issue now - and that should fetch your attention - when I swiped the tab while taking the course/quiz, rather than closing it, the bookmarks too didn't get registered.

Team emPower

It's a Rise 360, LMS, Scorm 1.2 course. The tracking is done using quiz results. And, closing the window saves the last chapter/question as bookmark.

Everything's working well over the computer and over the phone, if you click the close screen cross.

The course opens on a mobile browser. I have tested the course on an Android, chrome and an iOS phone. Same results. If you swipe the screen- the data ain't getting registered.

Gouri Pradhan

HI team, 

We are seeing the same issue with a Rise360, Scorm 1.2 course. The course does not register progress when done using IE but works fine using Google Chrome.

I tried in SCORM Cloud, but it worked using IE when I tried it. 

However, in the LMS it is certainly not registering progress or completion. When I close out of it and launch the course again, it goes back to the start of the course. 

Thanks,

Gouri Pradhan

Louise Lindop

Hi all. Just wondering if anyone found any solution to the issues reported in this thread. Like others, I have a small percentage of users who are not marking as complete and cannot find what is common between them. It's a Rise course published for SCORM 1.2. I am not able to reproduce the problem either on my own LMS (LearnUpon) or on SCORM Cloud. When I sign on as the user who is having difficulties it all works OK for me. Any ideas or information would be appreciated. Louise

Karl Muller

Hi Louise, what you are describing is exactly what some of out learners are experiencing.

What we do when a learner reports this, is to have them switch to a different browser. AFAIK this has worked in most cases.

The only advice that our LMS vendor has been able to give is for learners to clear their cookies and cache. I can't speak to the success of this.

Louise Lindop

Thanks Karl. Good to know we are not alone with this issue. It is a small percentage of users but very difficult with all the different browsers / devices / user behaviour to pinpoint a set of circumstances that causes it to happen. I have done some testing where I lose internet connectivity mid-course, leave it running on one device and open on another etc, but have not managed to replicate the problem. Like you, we normally direct people to another device or browser or in some cases need to set manual completion.

Paul Tottle

I didn't find a solution, however I've not had any reports of problems in the last 6 months. Now I make sure that any updated SCORM has the same identifier in the manifest file as the original. I've also added a re-engagement plugin activity (Totara/Moodle) that alerts people if they have gone onto complete the discussion forum, but haven't completed the eLearning. That catches people who may have only done 95% and didn't quite scroll to the end of the Rise course, but also it catches the errors we're talking about in this forum. But as I said no errors now in the last 6 months. And I can't clearly say what the cause was or the solution.