Bug? Hover state changing text size on buttons on master slides

Hi there,

I have been unable to find an answer to this.  When I create a button on a layer in the master slide (say just a text box), I also create a hover state which just changes the color of the text (didn't change font size).  When I preview this, it is fine in normal state, but when I hover over the button, the program shrinks the text size dramatically.  Exact same button works just fine on normal slide (not the master).  Anyone have any experience with this?

I also happen to have problems with fonts on the master slide.  For example, I set a font in a text box on the master slide (just a regular text box, not a placeholder) and when I click out of it, Articulate changes the font size to something else automatically (I have Do Not Autofit already checked in the Format Shape: Text dialogue box).  I am unable to ever have my font size that I have chosen stick.

Thoughts?

Eric Albertson

45 Replies
Doug Rice

I've been having the same problem. However, changing the font size on the hover state didn't work for me. Font size changes wouldn't stick when I modified any of the button states. I'm not changing colors at all...just a simple, default button. After playing with the button's text box autofit, margin, and wrap settings, it finally started working. However, I can apply the same combination of settings to another button and it doesn't work. Using format painter from the working button doesn't fix it either. I ended up just duplicating the button that was working to create the other buttons I needed. Definitely a bug.

Doug Rice

Ok, more tweaking...

I found that if I delete all objects on the Hover state and then recreate them manually, the font sizes seem to stick. Simply duplicating the Normal state and naming it Hover didn't work. So, for example, I created a text box on a slide master and set the font size, color, etc., the way I wanted it. This was my Normal state. I then created a new state, named it Hover, and recreated the text box from, formatting it how I wanted it to look. Now, when I hover over the text box, the font size is correct.

Not sure if this will work for you, Eric. Sounds like you already found a work around. Upping the font size in the hover states didn't work for me.

I'll submit a bug report for this.

Doug

B K

Has there been any type of solution to this 'bug'? 

I am having the same issue as Eric.  The buttons located on a master slide layer are set up correctly (text size, font, color) but when on any other state besides Normal, text and icon size changes dramatically.  The same button copy and pasted on a slide outside of master works just fine.

-BK

Christine Hendrickson

Hi BK,

Are you changing your story size, by any chance? I do see a current bug report on an issue similar to this. Looks like this happens if the story size is changed to 960x720. 

If you're using a different story size, can you tell me if the same thing happens when using the default story size?

Thanks!

Christine

Blake Griffin

Christine,

I had this issue a few weeks ago... I eventually found a workaround.  Sadly, I don't remember exactly what I did.  I seem to recall it had to do with the way I was creating the buttons and its various states.  

I went back to the file and tried to replicate the error, but now it works.  If it occurs again, I will let you know.

Thanks,

Blake

Blake Griffin

Christine,

I am still having the issue and I have Update 2 installed.  I did some testing, and here is what I have discovered. 

  1. If you create a button from a text box and add a hover state, it will retain its font size regardless of whether it is on a slide or on the master.
  2. If you create a button from the insert button option in the interactive objects tool area, it will retain its size on the slide and on the master even if it is created on the slide and pasted to the master.  Now, if you reduce the font size of the button on the master, that is where the problem seems to occur... the hover state appears in a smaller font size when previewed or published. 

I had the slide size at 1024 x 768.  Then I reduced the size of the stage to the default size of 720 x 540 and the problem goes away.

I hope this helps, if you need anything more specific... private message me and I can send you my phone number and we can chat.

Thank you,

Blake

PS: See attached

B K

I have a story size of 1000x600.

I found a way to work around the issue by applying text and icons to a buttons in each of its states.  While editing on state normal, I apply the text  using a text box rather than applying the text directly to the button.  From there to ensure the same text size on each state I copy and paste it to each state.

It's  more work than I want, but it will work until this is resolved in a future update.

Christine Hendrickson

@Blake

Thanks very much for that information! I did take a look at the file and I can see exactly what you mean. It seems like a link between the version on the slide and the master breaks when it's modified, or the story size is modified.

Any chance you could pass this along to our support team? If we haven't already documented this, I know they'd probably like to test this. It may be something our QA team should check out as well. 

You'll be able to attach the .STORY file on the second page of the following form:

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

@ BK

Thanks very much for that! That sounds like a good solution. I know it's a little extra work, but hopefully this will help anyone who's experiencing the same issue.

Hope you're both having a great day!

Christine

Mike Bethany

I have the exact same problem. It happens only when I change the story size from the default 720x405 and only if I then change the font size. No workarounds fix the problem. Problem report filed with example and pointed to this post.

P.S. I also couldn't log into this website, a grey semi-transparent overlay fills the screen but there's no login prompt. I had to create a new account to be able to bypass the non-existant login prompt.

Doug Rice

I've been fighting with this bug again and found something else you can try. Sometimes it works. Sometimes it doesn't...

In my case, I created a button on a master layer and added a button icon to it (no other text). The default font size on the newly created button was 18.5pt. However, I wanted to reduce it slightly to 18pt. That's when the problems occurred. If I kept the font size at the default 18.5pt, the button icon remained the same size across all states. If I changed the font size to 18pt, my hover and down states would show a smaller icon.

I thought maybe I could trick Storyline and use a non-standard font size so I tried 18.1pt. Of course, Storyline didn't like this and rounded the font size down to 18. However...miracle of miracles...this fixed the problem. Don't know why but it does seem to work.