Bug? Hover state changing text size on buttons on master slides

Hi there,

I have been unable to find an answer to this.  When I create a button on a layer in the master slide (say just a text box), I also create a hover state which just changes the color of the text (didn't change font size).  When I preview this, it is fine in normal state, but when I hover over the button, the program shrinks the text size dramatically.  Exact same button works just fine on normal slide (not the master).  Anyone have any experience with this?

I also happen to have problems with fonts on the master slide.  For example, I set a font in a text box on the master slide (just a regular text box, not a placeholder) and when I click out of it, Articulate changes the font size to something else automatically (I have Do Not Autofit already checked in the Format Shape: Text dialogue box).  I am unable to ever have my font size that I have chosen stick.

Thoughts?

Eric Albertson

45 Replies
Ashley Terwilliger

Hi Ryan,

I'm sorry that I don't have any updates to share - but I do see that this is still with our QA team. We have linked this thread to the existing QA report filed with our team, so that when there is additional information to share we'll be able to post here in the forum thread as well. Please ensure you're subscribed to replies at the top so that you'll get notifications via email.

Layton Fogah

I just stumbled across this issue and after a few hours of the workarounds I have given up.   I did notice that if I create a hover text on the master slide at font 20 it works properly.  If I shrink the text to font 14 the hover does not display the text size correctly.   You can see an example of this in the attached file.   (Option 1 - is fine, the other options not so much)  I hope it helps the amazing people at Articulate work out the bugs.

Marcel Lendi

I run into the same problem when trying to make buttons on the master slide with a story size of 1920x1080. With the button hoovering or using other self made states the text shrinks.

I couldn't find a good solution in the fora except for using text boxes glued on top of the buttons. I fiddled around a little bit and I found out that if I use a too big font and downsize my button afterwards (which also downsizes my text), the shrinkage of hoovering and other states is gone.

It is a workaround, a bit more elegant I think.

Marcelo Kassick

Hello Christine,

Perhaps, this bug has been already solved by now. Anyway, I'll share my workaround.  I've solved the "shrinking" hover simply placing the text inside a transparent shape (a box) as I observed that the hover behavior was fine when using buttons. Hope this is helpful.

Tks

Marcelo

Bjarne O

I'm also challenged by the weird font size behaviours of storyline when using custom story sizes... I've was able to reproduce the issue as demonstrated in this thread

https://community.articulate.com/discussions/articulate-storyline/custom-story-size-causes-font-sizes-to-change-erratically

My Christmas wish, is that articulate eventually acknowledges how annoying this bug is and fixes it :)

Andrew Wills

Any fix for this yet?

I created a template with back and next buttons (text) that have normal and disabled states. When I load the template into a new project (after changing the story size on the new project) these buttons actually move location when I create a trigger that changes one from disabled to enabled.

 

Ashley Terwilliger

Hi Debbie,

This discussion is a bit older and encompasses a few different versions of Storyline, so I'd like to start from the beginning with what you're running into: 

  • What version/update of Storyline are you using? 
  • What are you seeing occur? Can you replicate it on a file you can share here?
  • Where are you viewing/hosting your content? 
  • What browsers and outputs does this occur with? 

Let me know and we'll keep troubleshooting from there!

Steve Covello

I have figured out a semi-solution for this problem, but it only works on situations where there is only one line of text. A text box with a line break, for example, will not accept this solution. Here is a checklist of things you can try and hopefully it will resolve the problem:

  • The text should have a font size that is an even number, and no decimal value, like don't use 21.5 as your font size.
  • The text box height should be an odd number,
  • Text vertical alignment should be "Middle". (This might not matter but it worked for me)
  • Autofit should be set to "Resize shape to fit text".
  • The top and bottom internal margins should be an even number.
  • Check that all the states have exactly the same margin, box dimension, text alignment, and autofit values. Using the format painter DOES NOT WORK on all of the different states. You need to check them all after you use the format painter.

It is very important that when you check the height of the box/button that you use the breakout panel and NOT the ribbon display as a basis for checking consistency in the height value across all states (while in edit mode with states). The figure in the panel is the "real" figure. If you edit it in the panel, the value will take.

It is possible that some of these points might be unrelated to the problem, but all I can tell you is that I got it to work -- except for when there is a line break. If it works with an odd-numbered font size, you go girl!