Course complete trigger not working

A 4 slide course I am testing in my LMS will not mark completion using track by course complete trigger. I suspect it might be related to the July 21st Storyline 360 Build 3.42.22691.0? I was able to get the course to mark complete using number of slides. 

Here is the log from Scorm Cloud:

[12:51:42.841] Beginning prerequisites evaluation of activity Executive_Directive_87_Social_Media_ORG
[12:51:42.841] Beginning prerequisites evaluation of activity Executive_Directive_87_Social_Media_ORG
[12:51:42.841] Beginning prerequisites evaluation of activity ED87_Acknowledgment_SCO
+ [12:51:44.963] LMSInitialize('') returned 'true' in 0 seconds
+ [12:51:44.963] LMSGetValue('cmi.core.lesson_mode') returned 'normal' in 0.001 seconds
[12:51:44.965] LMSGetLastError() returned '0' in 0 seconds
+ [12:51:44.965] LMSGetValue('cmi.core.lesson_mode') returned 'normal' in 0 seconds
[12:51:44.965] LMSGetLastError() returned '0' in 0 seconds
+ [12:51:44.966] LMSGetValue('cmi.core.lesson_status') returned 'not attempted' in 0 seconds
[12:51:44.966] LMSGetLastError() returned '0' in 0 seconds
+ [12:51:44.966] LMSSetValue('cmi.core.lesson_status', 'incomplete') returned 'true' in 0.002 seconds
+ [12:51:44.969] LMSSetValue('cmi.core.exit', 'suspend') returned 'true' in 0 seconds
+ [12:51:44.970] LMSGetValue('cmi.suspend_data') returned '' in 0 seconds
[12:51:44.970] LMSGetLastError() returned '0' in 0 seconds
+ [12:51:44.970] LMSGetValue('cmi.core.lesson_status') returned 'incomplete' in 0 seconds
[12:51:44.970] LMSGetLastError() returned '0' in 0 seconds
+ [12:51:44.971] LMSSetValue('cmi.core.lesson_status', 'incomplete') returned 'true' in 0.001 seconds
[12:51:45.119] Beginning prerequisites evaluation of activity Executive_Directive_87_Social_Media_ORG
[12:51:45.119] Beginning prerequisites evaluation of activity Executive_Directive_87_Social_Media_ORG
[12:51:45.119] Beginning prerequisites evaluation of activity ED87_Acknowledgment_SCO
+ [12:51:47.740] LMSSetValue('cmi.suspend_data', '27146070ji1001112a0101201112D200v_player.5a1rjh9U21A.65Z3qDsUrGx1^1^002000') returned 'true' in 0 seconds
+ [12:51:48.537] LMSSetValue('cmi.suspend_data', '2e16607080on1001212f010120111201212D200v_player.5a1rjh9U21A.6QKDAKLqRh21^1^002000') returned 'true' in 0.001 seconds
+ [12:51:52.828] LMSSetValue('cmi.suspend_data', '2e16607080on1001212f010120111201212D200v_player.5a1rjh9U21A.6QKDAKLqRh21^1^002000') returned 'true' in 0 seconds
+ [12:51:52.832] LMSSetValue('cmi.core.session_time', '0000:00:07.86') returned 'true' in 0.001 seconds
+ [12:51:52.833] LMSCommit('') returned 'true' in 0.001 seconds
+ [12:51:53.441] LMSSetValue('cmi.suspend_data', '2f5860708090ts1001312k01012011120121201312D200v_player.5a1rjh9U21A.60GzMcQC51n1^1^00~2V3~2Q3f210b101001a1a103sV0~2A234003400A780501c1^q_default_Selected_DisabledA780501c1^q_default_Selected_DisabledA780501c1^q_default_Selected_DisabledA780501c1^q_default_Selected_Disabled34003400QN2slH3400340034003400q70020181^g_default_Visited000000000') returned 'true' in 0 seconds
+ [12:51:54.271] LMSSetValue('cmi.core.session_time', '0000:00:09.30') returned 'true' in 0 seconds
+ [12:51:54.272] LMSSetValue('cmi.core.exit', 'suspend') returned 'true' in 0 seconds
+ [12:51:54.272] LMSCommit('') returned 'true' in 0 seconds
+ [12:51:54.272] LMSFinish('') returned 'true' in 0.001 seconds
+ [12:51:54.273] Pre-evaluation of exit action
+ [12:51:54.866] OverallSequencingProcess for SCORM 1.1 / SCORM 1.2

23 Replies
Leslie McKerchie

Hi Melanie,

Thanks for contacting us and sharing what you're experiencing.

This is an issue we are currently investigating specific to the latest update. I've added this conversation to the report so that we can share updates with you here.

In the meantime, the following workarounds are available:

  1. Tracking via the number of slides.
  2. Tracking via result slide.
  3. Installing update 41.
Ashley Terwilliger

Hi Melanie,

Thanks for alerting us to this issue! Our team released a fix this AM noted as:

  • Fixed: Font sizes changed unexpectedly in some projects with custom slide sizes.

Please download and install the latest Storyline 360 Build 3.42.22724.0. 

We're still working on the course completion trigger fix, so we'll let you know when that's ready. 

If you have any questions, please do let us know here or connect with our Support Team!

Bret Jorgensen
Robert Webbe
Bret Jorgensen

Hi Melanie, We're testing a fix for the Course Completion Trigger issue now. Timing on the release remains 'ASAP'. 

I just installed version 3.42.22724.0 (July 23, 2020), is the fix in this version? There is nothing about that in the release notes so I guess not yet.

The release containing a fix for the course completion trigger issue is scheduled to go out at 9 am EST today. 

Bret Jorgensen
Robert Webbe
Bret Jorgensen

Hi Melanie, We're testing a fix for the Course Completion Trigger issue now. Timing on the release remains 'ASAP'. 

I just installed version 3.42.22724.0 (July 23, 2020), is the fix in this version? There is nothing about that in the release notes so I guess not yet.

The release containing a fix for the course completion trigger issue is scheduled to go out at 9 am EST today. 

Sasha Malone

Our courses are not completing either, both Rise and Storyline, even though I had update to the latest storyline and republished the courses, that still didn't help.  I have just updated the completion for the storyline courses to complete using the number of slides viewed. but this is not ideal.  The results slide didn't make a difference either.  ANy ideas?

Lauren Connelly

Hi Stephanie!

Great question! You should see the index_lms.html located in the published output folder when publishing for LMS. If you don't, I'd recommend publishing the project again to get a fresh copy of the published output folder.

If you'd like us to take a look at your project, you can either attach it to this discussion or upload it to us in a support case.

Maria Costa-Stienstra

Hi, Michael, and welcome to E-Learning Heroes! ✨

Thank you for reaching out! 

My initial recommendation would be to test your course with SCORM Cloud. Check out this step-by-step article!

If it works as expected in SCORM Cloud, I would advise you to reach out to your LMS for more information. If you can share the name of the LMS you use, others in the community might offer suggestions as well. 

If you still see the same behavior in SCORM Cloud, my recommendation would be to open a support case here, so we can take a closer look at your settings.

Let me know if this works!