Courses converted from Storyline 1 (SL1) to Storyline 2 (SL2) - Not tracking properly when learner fails.

Jan 27, 2015

Here are the issues we have been experiencing:

1.    Both AICC and SCORM 2004, 4th edition Items with SL1 to SL2 content are completing when learners fail the in-course assessment and moving to there Learning History.

2.    AICC items that complete on fail sometime do not have Object Details in the learner’s Items Completed record for that instance of the item

3.    AICC items that complete on fail sometimes have a score of “100” in the learner’s Items Completed record

4.    SCORM 2004, 4th edition items that complete do have Object Details in the learner’s Items Completed record for that instance of the item; however, the Object “Finished” Status is “No” and the Score (%) value is incorrect.

When we convert from SL1 to SL2, a second set of Results Variables are created by SL2. These items can not be removed from the course.  The bookmarking also stops working. 

We have review debug files and  talked to PMP support folks.   Any ideas or suggestions ???

57 Replies
Melissa Morrison

We have 8 modules that were created in S1 and then converted into S2. These modules are also translated into 16 languages by a vendor. 7 of the 8 modules have quizzes, all of those 7 modules with a Retry Quiz button at the end, since passing the quiz with an 80% or higher is a must. Recently, as in the past month, we are hearing the scores are not being sent to the LMS after the first attempt.

Ashley Terwilliger-Pollard

Hi Melissa,

Are you seeing this on all 7 of the quizzes? Are the translations all in the same course and a users sees different options based on a branching or variables? 

Do you know anything else about the users who did not receive a score - is that all users, or just a subset? Are they accessing the course in a particular browser? Are they closing the course prior to the results slide? Do they report passing the course? Could they be clicking on the retry button and then closing the course - that would reset their score and therefore pass a 0 to your LMS?

Any other information you could share would help us figure out some other ideas for troubleshooting! 

Melissa Morrison

We are seeing this in several of the courses, in different languages. It is not all Users, but it does seem to be Users who are using the Retry Quiz function, and this is in Moodle. Different browers, Chrome and IE. They report passing the quiz, and are sending in screen shots when they can. We have specific instructions on closing the course, so while it could be that, I don't think so.

Ashley Terwilliger-Pollard

Hi Melissa,

How are the different languages of the quizzes linked? Are they all in the one published Storyline file or are you linking to other files from a master course? 

These type of issues that are inconsistent are notoriously difficulty to track down - but if some users are having the results calculated correctly and their scores passed I'd look again into how the course is being closed, at what slide the user is leaving the screen, etc. You also mentioned it happening within the last month - were these courses newly published in the last month? If not, I'd look to Moodle's support of the browsers (Flash and HTML5) in use and anything else that may have changed in the LMS environment. 

Keep us posted if you find a common thread or if there is anything else we can do to help. 

Melissa Morrison

Hi Ashley,

The quizzes are all in each course, since they had to be translated into so many other languages.

One Tester reported the following:

"I first took the module, intentionally failing the exam - got one right.
On the quiz results slide, I pressed the Retake Quiz button and the score changed to 0.  As we know, it didn’t take me back to restart the quiz. Exited out. SH&E Connect (our Moodle LMS) didn’t have the module “checked” as I failed the exam. Clicked on ‘Grades’ and it showed me as scoring 0.  Clicked on the module again. SH&E Connect showed 1 attempt with 0 score.  

Noted the “Start a New Attempt” option was not there.
Pressed ‘Enter’ to go back into the module, selected ‘No’ to continue where I left off. Took the module again - passed the quiz missing 1 - quiz results displayed 87%. Exited out using the ‘Exit Course’ menu without first clicking next to go to the closing slide (wanted to see what would happen). Thai Hazcom now is “checked” and grade showed 87%.

Now it gets weirder: I clicked on the course again. SH&E Connect was still saying only 1 attempt, but was showing my brilliant score of 87% and now the ‘Start a new attempt’ feature was back.   - Clicked ‘Enter’.  This time I said ‘Yes’ to continue where I left off but guess where it started?  On the quiz score slide and it was showing my score as 0 again.  Now, my grade in SH&E Connect is 0 but Thai Hazcom still has a checkmark as completed."

Ashley Terwilliger-Pollard

Hi Melissa, 

Thanks for this - although some of it doesn't make sense to me so I'm going to try and break it down to ask for more detail. 

For the first attempt - if the user clicked "retake" it should reset the score in Storyline and in your LMS. So that sounds like it worked correctly - with the exception of bringing the user back to the beginning? What happened - the course just stayed on that slide? What do you have the triggers set up as on that slide? 

Is "Start a new attempt" in your LMS? If so, I'd ask them if there is a way to have that reset? If a user has passed the quiz, I'd expect that they would not see the prompt to start a new. Often an LMS will force a course into "Review" mode if they've reached the completion requirement. 

The third attempt things are definitely getting weird. It sounds like it's a combo of the course being in "Review" mode and resetting the attempt.

Have you asked your LMS team about these oddities - as that is where it's being controlled from as far as resetting the score you're seeing in the LMS and the "start a new attempt" button?

Ashley Terwilliger-Pollard

Hi Indrani, 

I have it set as a user can take the quiz section only once. 

Where have you set this? Storyline will allow you to set the questions attempts and than use the method here to limit the overall quiz attempt.  Perhaps it's a setting in your  Learning Management System (LMS) to restrict the number of times a user can access a course? 

You could also look at enabling the Resume for "Always" and if the user has completed the quiz they'll be brought back to the page they left off on. 

Ashley Terwilliger-Pollard

Thanks  Indrani - that looks like your individual question attempt. What that does with 1 attempt will advance the user to the "Incorrect" layer if they answer wrong and not allow them to try again.

  • If the user left the course and didn't resume to where they'd left off - they'd get to take it again. 
  • If you enabled the "retry" button on your results slide, the attempts would be reset and they'd get to try the question again. 

It sounds like for your needs to only let them take the quiz once, but still access the course I'd do the following: 

  • Set the Resume behavior to "Always" 
  • Remove the "retry" function from your Results slide 
  • Double check with your LMS that they will let the user re-enter the course even if they've reached the completion point (the results slide) so that they can view course content again. 

Hope that helps! 

Melissa Morrison

Hi Ashley,

So our LMS vendor has told us the problem exist for all our Chinese modules when they test in Moodle and SCORM Cloud. 

Our English courses, do have this issue, which we tested in SCORM Cloud and Moodle. We failed the course on the first attempt and then retook the course with a passing score and recorded it. We logged what each score was, and then looked up what SCORM Cloud or Moodle had recorded what the scores were. SCORM Cloud and Moodle are recording the passing scores.

Melissa Morrison
Melissa Morrison
Ashley Terwilliger-Pollard

Sorry Melissa - it threw me for a loop when I saw all the files. Do you also have one of the SL1 files that worked properly?  For testing, it would be helpful to compare the original and then the upgraded one since that may be connected to the issue you're experiencing. 

I'm also happy to open a support case for you if that'd be an easier method to share them vs. uploading here in ELH! 

This discussion is closed. You can start a new discussion or contact Articulate Support.