drag problem with video seekbar

Feb 20, 2020

Hi there! I have a big problem.

I used to put video into a course with the video-player and seekbar on (I mean not the slide seekbar but the seekbar inside the video). Now that I have installed the latest release of the Storyline 360, I can't drag the video-seekbar like I did before.

Anyone with the same problem? 😖

Thank you so much for a quick reply. 🙏😔

28 Replies
Ren Gomez

Hi Jack,

Thanks for reaching out, and I appreciate you clarifying the details with my teammate, Jopney. It looks like she followed up with you regarding this issue and confirmed that we do have an active bug where you cannot scrub the seekbar in the built-in video controls during preview or publish.

I will be sure to jump back in here when we have any progress to share on a fix. 

Katie Riggio

Hi everybody!

Great news for this Tuesday morning: A hotfix for Storyline 360 is ready, and it addresses the issue where learners couldn't click or drag the seekbar on the built-in video controls! 

You can explore the release notes here, and download the latest update with these steps. Thanks for helping us make this improvement!

Enrico Matteazzi

Thank you Katie. I assume that Articulate developers allways debug this software... don't they? This kind of bug cannot be accepted by my italian clients. And it is not accepted also by me. A software like Storyline must be perfect. So please please please! Fix all the bugs before give us a new realese! ...... ok? :) Thanks.

Ashley Terwilliger-Pollard

Hi Enrico,

Our team works hard to test every update, fix and new features to ensure we don't have any impact on other parts of the tool - but with the wide array of features and use cases, sometimes things slip through the cracks. Luckily, we were able to get out a hotfix for this issue and you should be able to use the latest update and not run into issues with the seekbar on the built-in video controls.

Let our Support Team know if you run into any trouble with this update! 

Leslie McKerchie

Hi Hillary,

Thanks for contacting us to share that you're running into a similar issue.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Ahmed Al Saati

Please Lesilie wait... Do not look at the project file... Because I have the solution :)

For me the same problem happened. What I discovered is that the problem is under Video Tools--> OPTIONS --> Video Options section--> Play Video

If you select "Automatically", everything will work fine. If you select When clicked OR When triggered, it will have this sync problem. One problem is left which is if you make the Play Video "Automatically" you will have another problem which is if you click the video in the slide it will pause while the seekbar continues!! I solved this also simple by adding two triggers :))

Pause timeline on this slide

When the user click Video1


Resume timeline on this slide

When the user click Video1

If you want to live with Articulate 360, then you need to work upside down sometimes!! :))

Al Lauer

We are having problems with the seek bar and video too. When clicking on the seek bar in a published module, the bar will move to the spot clicked or dragged, but the video will start over from the beginning. However, the seek bar continues moving from the spot in which it was clicked causing the video to stop and automatic branching to happen when the seek bar timeline ends. 

Has there been a fix provided by Articulate? Will there be an Updater action built to retrofit published and live modules?

Lauren Connelly

Hi Al!

We did release a hotfix in March 2020 to solve the bug where you couldn't click or scrub the seekbar of the built-in video controls in Preview and Published output. The fix was released in Storyline 360 Update 38 (Build 3.38.21779.0).

If you're still running into this issue while using an updated version of Storyline 360, we'll need our Support Engineers to lend a hand. Would you mind sharing the affected file using this secure upload link

Thank you for bringing this to our attention! 

Anton Noffke

I am having a problem with the seekbar too. My content is mostly video's. I would expect that to get to the end of the video one would simply drag it to the extreme right. But some videos end sooner than that, perhaps 1/3 of the way across. Is there a way of scaling the seekbar so the the end of the video is at the end of the seekbar no matter how long the video is?

Leslie McKerchie

Hi Anton,

Thanks for letting us know what you are experiencing with your seekbar. I'm not clear if you're experiencing the issue with the video controls or the seekbar on your slide.

Would you be able to share a sample .story file for us to take a look at an example of what you are seeing? You can share it publicly here or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Charles Hinds

Hi Everyone,

I'm having problems with the seekbar not working (Storyline 360) with basic slides that have audio and some image animations. First problem is that it doesn't identify the true duration of the slide. Upon completion of the slide it dragging the playhead doesn't to a earlier position doesn't change the position of the visual. In additional pause and play does not control the slide, and rewind does not control the slide. In other words the seekbar doesn't work at all. I've tried multiple approaches to try to resolve this: I downgraded my version to see if this would solve the problem, as the seekbar was working in previous versions. I've changed to the modern play tested without success, and reverted back to the classic player, again without success. I've tried different settings in slide properties and seekbar properties in the player control without success. As any observed this problem with Storyline 360 in the recent versions.

Maria Costa-Stienstra

Hi, Charles.

I am sorry you are experiencing this issue!

Quick question: does it happen in every file you open or start in Storyline 360, or only with a specific .story file?

If it's happening with a specific project, can you share the .story file with us through a support case so we can investigate what's happening?

Charles Hinds

Thanks Maria,

I've isolated the bug, I believe, which occurs when I load a layer containing a hotspot from a master slide. It was easy enough to use an alternative solution, but figuring out what was causing the problem took some time. That said, I've shared an example (.story) of the problem with support to hopefully help others.