Images in Storyline disappear from presentation after publish

 Hello,
I'm having an issue with a presentation in Storyline whereby my images (jpegs & pngs) have disappeared. They appear in the preview pane, but in the slide view, they are missing. If I then preview the project, they don't appear.

The slides these images appear on only have 1 layer. It seems as though the images are there- if you click on the slide, there is an active object outline where they should be. I have tried removing these blank boxes and re-inserting the images using the Insert> Picture function but all that is inserted is an empty object box.

I have also attempted to view the presentation on a colleague's pc with Storyline installed but the same issue has occurred.

I am working with the images locally, When creating, editing, or publishing a Storyline project, from local hard drive (typically your C: drive).


I used images from Insert> Characters > photograph>


I have put in a lot of effort and time in animating the slides and If I have to redo it again I will be behind schedule.


Please find the attached source file for your reference.

140 Replies
Christine Hendrickson

Hi Michael, 

Without actually seeing the files, I'm afraid I cannot confirm what is actually causing the problem. Have you checked all of the suggestions in this thread? 

Make sure you're working with local courses and image files. Also, make sure your course files and image files contain no special characters (this includes underscores and spaces). You said that not all of the images are missing - is there any common thread with the ones that have gone missing? Are they named differently, or in a different directory? 

You mentioned that the images are missing when you import them into another course. Are you importing from the Articulate Menu > Import > Storyline and selecting the slides you'd like to import? Or are you using a different method? 

If you can give a little more information, I'd appreciate it :)

Thanks!

Christine

Vicki Kunkel

Well, add me to the list having this same problem. VERY frustrating--especially considering I am on a tight client deadline.  I have tried all the solutions mentioned in this thread with no results. Looks as if I will NOW have to re-do the entire course from scratch!  

Like everyone else, things worked fine until the upgrade. 

If anyone has any more recent resolutions that weren't listed in the thread, please post. But, given that it's the weekend and I can't wait due to the deadline, I will just have to re-do. Lost time and money. 

Christine Hendrickson

Hi Vicki,

I sincerely apologize for the frustration. I totally understand and hopefully we can revisit this when you have time.

Are you referring to Update 2, or Update 3? Update 3 was released May 21st. Most of the posts here are prior to the last update. If you're referring to Update 2, it might help to install the latest update. 

To find this information, click on "Help" and "About Articulate Storyline".

If you're not running version 3 (1305.2012), please download and install the update using the link below:

Articulate - Storyline Update 3

If the problem continues, please let us know.

Thanks very much,

Christine

George Lake

Folks:

Hey I know I’m late to the party but I'll add my $0.02 to the conversation given we've had multiple users lose several hundred hours of work to this issue and seem to have a short term fix:

1.     We are all running Storyline Update #3, this does not help given we don’t think it’s a SL issue.

2.     We're a corporate environment and thus sit behind multiple firewalls and filters.

3.     When connected to our corporate network Storyline regularly experience the exact issue described above.

4.     When I disconnect from our Corporate network the issue goes away.  I can immediately replicate the error (within a few minutes) simply by reconnecting to the network. 

5.     I’ve run Storyline off the corporate network for several hundred hours since and have never lost an image or corrupted a file.

 

After extensive testing both off and on our network we believe the issue centers around our corporate filter and or network settings.  So for those that are working on a tight deadline and just need it to work.  I'd suggest going solo and getting off your network and/or turning your firewall off.

 

Normal 0 false false false oNotPromoteQF /> EN-CA X-NONE X-NONE ontGrowAutofit /> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-fareast-language:EN-US;} -->
Ashley Terwilliger

Hi Christian,

This thread is a bit older with a few different situations happening, so could you offer more information about what is happening in your set up specifically? As you'll see in the most recent post from George, he was running Storyline from a corporate network, and that was causing his difficulty. 

Jason Smith

We're seeing the issue as well.  The course we're working on has always been saved on the local C drive in the documents folder, but now when we open the .story project, several images are not visable.  Only an outline of it is there.   The only way to get it back is to delete the image, rename the image from the hard drive, then re-insert the image.  We're on the Storyline Update 4 version.

Thanks,

Jason

Ashley Terwilliger

Hi Jason,

It seemed a number of the previous posters in this thread had the problem associated with being on a network drive or previously with Storyline Update 2. Were you previously using Update 3 without problems? Did it only appear in Update 4? Are your image files saved locally as well? You'll want to make sure that all the files associated with your project are saved locally, have file paths that don't exceed 260 characters, and file names that don't include special characters, accents, or symbols. Are you able to share the .story file here with us so that we can take a look? If you'd prefer to share it privately, you can also send it here. 

Carey G.

Just wanted to say thanks for all of this discussion!

I had a problem where text boxes weren't working properly after publication. After reading through these posts, I tried a few things and was able to get the course to work properly.

Thanks everyone!

Slowly but surely.....getting my Storyline experience....

Donald Ardiel

I am now having the same problem that is identified in the discussion above.

I loaded Update 5 yesterday and today all of the images, both PNG and JPG have disappeared from slide view. The images are in the preview to the left but cannot be seen in the slide view. I am not running on a network and all files are resident on the same hard drive.  When I try and reinsert the image, it appears as an empty small frame in the centre of the slide, just as shown above.I have saved the file to a different name with no change.

Suggestions?

Christine Hendrickson

Hi Donald, 

You mentioned that you've saved the file with a new name, but have you tried importing the original slides into a new file?

If not, here's how:

Importing from Another Storyline Project -E-Learning Heroes

If that doesn't help, are you able to insert one of the images into a new project? Does the same thing happen here?

Thanks!

Robert DeSimone

This problem just started happening for me. I just lost 100's of hours of work.  I tried the following:

Create a new file and import the presentation into that new file. Used "Change picture" to import the images back into the presentation. It did not work. Then tried importing a new instance of the picture, that also did not work. In all cases, it comes in as a white box with no content. Any one have any idea? Clearly Articulate is failing to address this problem as it goes back over a year and there has been NO SOLUTION.
Christine Hendrickson

Hi Robert,

I sincerely apologize for the trouble you've had with this. I was able to find your support case (#00393908 for my reference) and I see that Cleo was working with you to test this.

It looks like the issue you submitted was confirmed and is being tested. I do see that Cleo shared the details for your case to the investigation. 

This thread and any others related to the issue will be updated as soon as we have information on a fix, or any additional workarounds. Also, since you have a case open for this specific issue, you'll receive a message from Cleo through your support case, when there's an update.

Best,

Christine

Jason Ranston

Robert DeSimone said:

This problem just started happening for me. I just lost 100's of hours of work.  I tried the following:

Create a new file and import the presentation into that new file. Used "Change picture" to import the images back into the presentation. It did not work. Then tried importing a new instance of the picture, that also did not work. In all cases, it comes in as a white box with no content. Any one have any idea? Clearly Articulate is failing to address this problem as it goes back over a year and there has been NO SOLUTION.
Couldn't agree more.  Lots of talk no solution.  Lost 100's of hours here too.
Michael Fimian

Well, I'm back after a year...  After a relatively quiet spell, my images are starting to disappear again, lousing up our production schedule. Have had to postpone the start of a couple of courses.  What's scary is that it's happening to all our files eventually;  thousands of hours worth of work.


We version and BU daily;  I've been pulling files from archives, having them updated, but eventually they become corrupt in the same fashion.

Am working on Miker's suggestions and hope this issue gets resolved soon.  If not, we may have to drop Storyline.

Jackie Van Nice

After seeing this issue in the forum for awhile I finally got to experience it today. Too bad this wasn't a party I wanted to join.

SL1 update 5 crashed for no reason I could determine (I was changing the fill color on an inserted object; file had only been open for a few minutes and it's a small file) and when I brought it back up all of my images were gone from slide view.

  • They DO show up in story view.
  • They DO show up in the sidebar to the left of slide view.
  • They DO NOT show up in slide view so I can work on them.
  • They DO NOT show up in preview.
  • Publishing doesn't even work. It appears to go through all of the steps, but no option window pops up at the end, and nothing gets published.

Update:

  • Did a cold boot.
  • Created a new SL file and imported first one into it. Now all images are gone even in preview. Still won't publish.
Ashley Terwilliger

Hi Jackie,

I'm sorry to hear that you've run into this issue as well. I checked on Michael's support case to see if there was anything determined yet in that instance I could share with you here - and it looks like the files came to Miker at the end of the day Friday, so I'm not certain he's had a chance to review them yet. 

Let's start with the general troubleshooting steps below and I'll continue to keep an eye on Michael's case as well.

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.
  • Conduct the detailed repair of Storyline here including the clean up files. 

Please feel free to let us know if you're able to follow along with those steps. 

Sara Fromme

Not sure if this is relevant but I've also read that some PowerPoint users are losing their images and they are having a tough time reproducing the issues for Microsoft.

http://answers.microsoft.com/en-us/office/forum/office_365hp-powerpoint/powerpoint-2013-images-in-presentation-disappear/dbacd4f2-a514-4f67-b4d9-c3c33010eb3e

Some people suggest it's an issue with the video cards or maybe RAM. Not sure, but just thought I'd throw this out for consideration.

With computers there are so many variables that it's not always easy to figure out the issues. HTH

Duncan Brooking

Hello all,

I'm in the same boat as others it seems.

The first time this happened to me it was a 245 slide multi choice quiz. Luckily there were no sharp objects nearby.

This is not a full solution, however it can save some time. It may not work for others, but it does for me.

I save a new version of the file each day. When this media corruption issue occurs, I open the last "good" version alongside the "bad" version and copy and paste the "bad" slides from the corrupted into the "good" version.

The media will all re-appear with one exception. I then save the "good" version as a new file and delete all the unwanted/duplicate slides.

Now for the exception. The media will not re-appear if the image/video file has been edited between the .story versions. Unfortunately these instances have to be renamed and then placed in the story file again.

Duncan.