Is it just me or has playback from the timeline stopped outputting to headphones?

For the past few days I've noticed that when I preview a slide in SL 360 by pressing "play" below the timeline, the playback will only go to my computer speakers, not my earphones. All of the other audio -- system sounds within SL and audio in Preview mode -- go to my earphones.

In SL2, playback won't go to my earphones when I play audio from the timeline OR in Preview mode. System sounds go to my earphones.

I've only noticed this happening in Storyline, not any other application. I've checked my audio settings in Windows, and I don't see anything amiss.

Is this just me?

17 Replies
Ashley Terwilliger

Hi Rachel,

As I mentioned to Ben I'd look into the headphone/device settings and ensure it's set up to allow for use in programs such as Storyline. I am on Windows 10 myself, and haven't run into any issues with my headphones. Since you're also seeing it in Storyline 2 - that'd point more towards a change in your computer/Windows/etc. since the last update for Storyline 2 was in May of 2017. 

Rachel Ingram

I played around with my audio settings within Windows, but everything looks OK. I haven't made any changes to these settings recently (if ever). I also tried rebooting my computer and trying a different set of earphones.

Is it weird that in 360, this only occurs when I play a slide by clicking Play on the timeline? (In other words, while I'm editing a slide within Storyline.) Everything else -- the system sounds and even playing a slide in Preview mode -- will properly output to my earphones when they are plugged in.

Ashley Terwilliger

Hi Rachel,

We've seen a few users mentioned this and so far it's been Storyline 2 and 360, so it seems odd that it could be happening in both without any other Windows update? 

A suggestion for another user was to look at how audio plays in a browser that's relying on Flash as the preview in Storyline 2 is Flash based. 

Have you also tried repairing Storyline? 

 

Rachel Ingram

Hi Ashley,

Thanks. I just tried repairing Storyline, but it didn't fix the issue.

I wasn't completely sure what you meant by a browser relying on Flash, BUT I published the course to Flash and viewed it in both Chrome and Firefox. Chrome was fine, but in Firefox the audio wouldn't output to my earphones (only to my computer speakers). So it must be Flash-related!! What does that mean? I checked to see if my Flash Player is up-to-date and it is.

Thanks again for your help. I feel like I'm getting close...

Rachel Ingram

Michael, you are so wonderful. Thanks so much for posting this. I tried it and it worked! So I guess if anyone else reads this, just go to "Manage audio devices" in your Windows Control Panel, disable your computer speakers (most likely labeled "Speakers"), click Apply, and then go back and enable them, and click Apply again.

I'll post here if I have problems again, but the audio appears to be working properly now.

Thanks again, Michael!

Ashley Terwilliger

Thanks for your patience as we dug into this!

It appears that the latest Flash update 27 (although there is now a new version 27 in Beta) changed how the audio settings would work for Flash playback. The timeline preview in all versions of Storyline and Quizmaker is Flash based.

We've detailed out some steps here on how to fix this for Flash, and this is a behavior our team is still looking at fixing in Storyline/Quizmaker so that you won't run into it again!