Maintaining LMS Connection for reporting

Greetings! We are having an issue in which a course built in SL360, SCORM2004, 4thE, will report inconsistently.

Sometimes the Completion will report, but the interactions are not recorded. Sometimes a course will still show as "In Progress" yet the interactions are reported. And some are recording both completions and interactions correctly. All from the same course.

Our LMS vendor implies with their guidance that this may be a browser &/or an issue maintaining connection to the LMS.

We are adding in some checks to our courses to try to make sure users are on an "up-to-date" browser. From my research, it seems that this inconsistency in reporting/maintaining connection with an LMS may be a fairly common problem.

I am curious if others experience a similar issue in their LMS and what triggers, or even JavaScript (which I know Articulate staff cannot provide) others might include in their course builds such that the connection to the LMS is either maintained &/or checked and reestablished so that actual submission happens.

Thank you!

4 Replies
Leslie McKerchie

Hi everyone,

Thanks for chiming in and sharing your thoughts. We do have a feature request for the ability of the HTML5 output to notify LMS users if they lose their internet connection similar to the solution that we had for Flash output.

I've added this conversation to our report so that we can share any updates we have with you in the future.

I also wanted to share some information about how we manage these feature requests.