129 Replies
Thorsten Zimprich

I love that workaround. It worked for 2 text entry fields but now I used 5 and don't get an error it produces. Here is the problem description:

  • I click on first entry field, enter correct text
  • I click into 2nd field like a user would do as well and enter correct text
  • I repeat that for all 5 fields
  • then I tested
    • A - clicking somewhere inside quiz area to trigger focus change and afterwards I click on submit button --> Error message like "that form is not properly filled, please enter all text"
    • B - clicking directly on submit button --> even if answers are correct I get lead to retry screen

I am sure it is just a small detail I tried to find by checking my trigger rules. Has anyone any idea?

 

How can I display content of the entry variables to see which variable isn't working like I believe it should do?

(would help debugging)

Thanks in advance

Thorsten

 

 

Thorsten Zimprich

I find out how to display Variables = %NAME% and displayed all 5 Variables. In copied file with just the quiz I debugged it and it worked. Did the same thing on main file. Variables are going to be displayed and entered correctly, but it doesn't work in the end because Articulate tells me that not every variable was entered, although debug fields tells me that every variable is filled in correctly! ARRRRGH

Thorsten Zimprich

I guess I found the reason and it is a sad story to tell. It seems to have to do something with brackets. My quiz is about citation therefore I have to test the students about their knowledge of these things: [...] , [sic!] , 'QUOTED QUOTE' , and so on. I guess Articulate doesn't convert brackets into text? Which means code injection may be possible?  But it means that articulate could work weird like explained above because it has problems to distinguish code brackets and text brackets.